# Repository Problem Suma 3.1

**URL:** <https://forums.suse.com/t/repository-problem-suma-3-1/30413>\
**Category:** SUSE Multi Linux Manager\
**Created:** [October 6, 2017, 11:05am UTC](https://forums.suse.com/t/repository-problem-suma-3-1/30413 "2017-10-06T11:05:06Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![mayas](https://avatars.discourse-cdn.com/v4/letter/m/ee7513/32.png) [@mayas](https://forums.suse.com/u/mayas)\
**Post date:** [October 6, 2017, 11:05am UTC](https://forums.suse.com/t/repository-problem-suma-3-1/30413/1 "2017-10-06T11:05:06Z")

</div>

Hi,  
i have a new rpm pakage and i create a repo on my folder. The Suse Manager 3.1 giv me this error:

sumaserver:/srv/www/htdocs/pub/repositories/ptf # /usr/bin/spacewalk-repo-sync --channel stable-sles12-sp2-kernel-ptf-x86\_64 --type yum --non-interactive  
07:12:51 ======================================  
07:12:51 | Channel: stable-sles12-sp2-kernel-ptf-x86\_64  
07:12:51 ======================================  
07:12:51 Sync of channel started.  
07:12:51 RepoError: Cannot retrieve repository metadata (repomd.xml) for repository: ptf. Please verify its path and try again  
07:12:51 Total time: 0:00:00

Config Repo in Suma

Repository URL: [http://sumaserver/pub/customrepo/ptf](http://sumaserver/pub/customrepo/ptf)

Config Sumaserver:

sumaserver:/srv/www/htdocs/pub/repositories/stable-sles12-sp2-kernel-ptf-x86\_64 # createrepo .  
Spawning worker 0 with 1 pkgs  
Workers Finished  
Saving Primary metadata  
Saving file lists metadata  
Saving other metadata  
sumaserver:/srv/www/htdocs/pub/repositories/stable-sles12-sp2-kernel-ptf-x86\_64 # ls -l  
total 36672  
-rw-r–r-- 1 root root 37549573 Oct 4 08:43 kernel-default-4.4.74-92.35.1.13607.0.PTF.1030850.x86\_64.rpm  
drwxr-xr-x 1 root root 494 Oct 6 07:15 repodata

Now, when i sync in sumaserver the new Channel i have this error:

2017/10/05 15:38:38 +02:00 Command: [’/usr/bin/spacewalk-repo-sync’, ‘–channel’, ‘stable-sles12-sp2-kernel-ptf-x86\_64’, ‘–type’, ‘yum’, ‘–non-interactive’]  
2017/10/05 15:38:38 +02:00 Sync of channel started.  
2017/10/05 15:38:38 +02:00 RepoError: Cannot retrieve repository metadata (repomd.xml) for repository: ptf. Please verify its path and try again

When i control with curl on the sumaserver i have this error:

curl -Sks [http://sumaserver/pub/customrepo/ptf](http://sumaserver/pub/customrepo/ptf)

Error Messages:  
Your system policy has denied access to the requested URL

Can someone help? Maybe a problem with rhn.conf?

Thanks

Murat

---

<div class="post-metadata">

**Author:** ![malcolmlewis](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/malcolmlewis/32/11375_2.png) [@malcolmlewis](https://forums.suse.com/u/malcolmlewis)\
**Post date:** [October 6, 2017, 2:30pm UTC](https://forums.suse.com/t/repository-problem-suma-3-1/30413/2 "2017-10-06T14:30:08Z")

</div>

Hi and welcome to the forum 🙂  
Your location(s) are pub/repositories/stable-sles12-sp2-kernel-ptf-x86\_64, pub/customrepo/ptf or pub/repositories/ptf you seem to be looking at three different places? You used createrepo in stable-sles12-sp2-kernel-ptf-x86\_64.

---

<div class="post-metadata">

**Author:** ![mayas](https://avatars.discourse-cdn.com/v4/letter/m/ee7513/32.png) [@mayas](https://forums.suse.com/u/mayas)\
**Post date:** [October 6, 2017, 4:41pm UTC](https://forums.suse.com/t/repository-problem-suma-3-1/30413/3 "2017-10-06T16:41:47Z")

</div>

The Problem was the /etc/rhn/rhn.conf file.  
I put this on the file:

server.satellite.no\_proxy = susemanager

then it works
