# RKE and ssh - How to

**URL:** <https://forums.suse.com/t/rke-and-ssh-how-to/9974>\
**Category:** Rancher 2.0 Tech Preview\
**Created:** [April 5, 2018, 3:02pm UTC](https://forums.suse.com/t/rke-and-ssh-how-to/9974 "2018-04-05T15:02:03Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![gabx](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/gabx/32/3871_2.png) [@gabx](https://forums.suse.com/u/gabx)\
**Post date:** [April 5, 2018, 3:02pm UTC](https://forums.suse.com/t/rke-and-ssh-how-to/9974/1 "2018-04-05T15:02:04Z")

</div>

I have one issue with RKE when installing my first cluster with 3 node roles (etcd, control, worker) each one being on a specific VM.  
I am left with this error:  
`Error waiting for container [rke-port-checker] on host [10.52.16.184]: Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?`

**EDIT** : googling a little helped me to find it is the TCP protocol.  
I suspect I have this issue due to either _iptables_ or _SELinux_. These two services are usually a good culprit for this kind of permission error. Reading the [RKE github](https://github.com/rancher/rke) REDAME, I saw a few settings I need to do, like allow some ports in my _iptables_. I need to know which protocol: **TCP** or **UDP** , or both?

Then, I read RKE works by connecting to each server via SSH. My sshd config is to allow specific user with no password but a key. Shall I add any user, maybe _docker_, in my sshd config?

Thank you

---

<div class="post-metadata">

**Author:** ![Fraser\_Goffin](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/fraser_goffin/32/6608_2.png) [@Fraser\_Goffin](https://forums.suse.com/u/Fraser_Goffin)\
**Post date:** [April 15, 2018, 6:19pm UTC](https://forums.suse.com/t/rke-and-ssh-how-to/9974/2 "2018-04-15T18:19:45Z")

</div>

So, setting aside Rancher and RKE for a moment, can you connect to the docker daemon directly using the API just using the docker client (I’m assuming you have configured the daemon to enable remote connection) ?

---

<div class="post-metadata">

**Author:** ![superseb](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/superseb/32/2424_2.png) [@superseb](https://forums.suse.com/u/superseb)\
**Post date:** [April 16, 2018, 7:24pm UTC](https://forums.suse.com/t/rke-and-ssh-how-to/9974/3 "2018-04-16T19:24:04Z")

</div>

The error is confusing and I have created this issue: [https://github.com/rancher/rke/issues/507](https://github.com/rancher/rke/issues/507)

But the root cause is still that the required ports are not opened between the hosts.
