# Rmt mirroring doesn't work from rmt-server-mirror.timer

**URL:** <https://forums.suse.com/t/rmt-mirroring-doesnt-work-from-rmt-server-mirror-timer/45293>\
**Category:** SLES Configure-Administer\
**Created:** [March 10, 2025, 4:47pm UTC](https://forums.suse.com/t/rmt-mirroring-doesnt-work-from-rmt-server-mirror-timer/45293 "2025-03-10T16:47:06Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![gerardr](https://avatars.discourse-cdn.com/v4/letter/g/2bfe46/32.png) [@gerardr](https://forums.suse.com/u/gerardr)\
**Post date:** [March 10, 2025, 4:47pm UTC](https://forums.suse.com/t/rmt-mirroring-doesnt-work-from-rmt-server-mirror-timer/45293/1 "2025-03-10T16:47:06Z")

</div>

Dear forum members,

When entering

rmt-cli mirror

from the commandline, our rmt server (called ‘rmt-ng’, on sles15sp6) mirrors all our repos without complaint. But it fails to run from the timer service, and I get errors like this in the systemlog:

2025-03-10T14:55:14.810769+01:00 rmt-ng rmt-cli[23427]: WARN: Repository ‘SLE-Module-Python3-15-SP6-Updates’ (6663): Error while mirroring repository: Could not create local directory /usr/share/rmt/public/repo/SUSE/Updates/SLE-Module-Python3/15-SP6/x86\_64/update/ with error: File exists @ dir\_s\_mkdir - /usr/share/rmt/public/repo.

and later:

2025-03-10T14:55:14.810843+01:00 rmt-ng rmt-cli[23427]: WARN: Mirroring completed with errors.  
2025-03-10T14:55:14.818757+01:00 rmt-ng systemd[1]: rmt-server-mirror.service: Main process exited, code=exited, status=1/FAILURE  
2025-03-10T14:55:14.818814+01:00 rmt-ng systemd[1]: rmt-server-mirror.service: Failed with result ‘exit-code’.

Unsurprisingly, that directory does indeed exist. But why would that be an error? It was put there by the manual mirror action… For now, I just do the mirroring by hand every now and then, but it sure would be nice to get this automated. So any help is greatly appreciated!

gerard

---

<div class="post-metadata">

**Author:** ![smflood](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/smflood/32/10576_2.png) [@smflood](https://forums.suse.com/u/smflood)\
**Post date:** [March 11, 2025, 12:50pm UTC](https://forums.suse.com/t/rmt-mirroring-doesnt-work-from-rmt-server-mirror-timer/45293/2 "2025-03-11T12:50:12Z")

</div>

Note those are warnings not errors - does the timer service mirror other packages without errors?

If you’re mirroring by hand do the permissions match those of the auto-mirrored files/directories?

---

<div class="post-metadata">

**Author:** ![gerardr](https://avatars.discourse-cdn.com/v4/letter/g/2bfe46/32.png) [@gerardr](https://forums.suse.com/u/gerardr)\
**Post date:** [March 11, 2025, 1:54pm UTC](https://forums.suse.com/t/rmt-mirroring-doesnt-work-from-rmt-server-mirror-timer/45293/3 "2025-03-11T13:54:10Z")

</div>

Warnings indeed, but those were the only errors I could find. The warnings come for every mirrored product. When done by hand the permissions are 644 for the rpm files. I believe that is the same as when run from the timer service, but I’m not totally sure, since last week I changed them to 660 to see if that would make a difference (It didn’t.)  
Thanks for your answer!
