# SAPInstance primitive doesn't start

**URL:** <https://forums.suse.com/t/sapinstance-primitive-doesnt-start/23386>\
**Category:** SLES High Availability Extension\
**Created:** [December 8, 2012, 11:18am UTC](https://forums.suse.com/t/sapinstance-primitive-doesnt-start/23386 "2012-12-08T11:18:12Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![cosentino](https://avatars.discourse-cdn.com/v4/letter/c/8baadc/32.png) [@cosentino](https://forums.suse.com/u/cosentino)\
**Post date:** [December 8, 2012, 11:18am UTC](https://forums.suse.com/t/sapinstance-primitive-doesnt-start/23386/1 "2012-12-08T11:18:12Z")

</div>

Hi Gurus,

I’m installing a new SLES for SAP 11 SP2 cluster, but after configure the “SAPInstance” primitive this doesn’t start. After migrate the group to other node I get the following error:

```auto
Dec 8 09:50:50 ewmp01 mgmtd: [3883]: ERROR: unpack_rsc_op: Preventing ASCS00 from re-starting anywhere in the cluster : operation start failed 'not configured' (rc=6)
```

But if I try to start manually (with startsap script) from the command line as usually it works perfectly in both nodes (obviously only will start in the node where the group is placed).

This is the configuration of the primitive:

`primitive ASCS00 ocf:heartbeat:SAPInstance \\
        operations $id="ASCS00-operations" \\
        op monitor interval="120s" timeout="60s" start_delay="120s" \\
        op start interval="0" enabled="true" timeout="180" \\
        op stop interval="0" enabled="true" timeout="240" \\
        params InstanceName="EWP_ASCS00_ewp" START_PROFILE="/usr/sap/EWP/SYS/profile/EWP_ASCS00_ewp" AUTOMATIC_RECOVER="true" SHUTDOWN_METHOD="normal" START_WAITTIME="360" MONITOR_SERVICES="msg_server" \\
        meta target-role="Started" is-managed="true"`

I have configured also an order constraint.

```auto
order o_ascs inf: p_exportfs_sapmnt:promote ASCS00:start
```

---

<div class="post-metadata">

**Author:** ![cosentino](https://avatars.discourse-cdn.com/v4/letter/c/8baadc/32.png) [@cosentino](https://forums.suse.com/u/cosentino)\
**Post date:** [December 8, 2012, 1:32pm UTC](https://forums.suse.com/t/sapinstance-primitive-doesnt-start/23386/2 "2012-12-08T13:32:06Z")

</div>

Hi again, the problem is solved, after clean the resource (group) everything becomes to work correctly.
