# sg\_persist PR in: command not supported

**URL:** <https://forums.suse.com/t/sg-persist-pr-in-command-not-supported/26528>\
**Category:** SLES Configure-Administer\
**Created:** [January 6, 2015, 5:28am UTC](https://forums.suse.com/t/sg-persist-pr-in-command-not-supported/26528 "2015-01-06T05:28:00Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![tongninguniverse](https://avatars.discourse-cdn.com/v4/letter/t/dbc845/32.png) [@tongninguniverse](https://forums.suse.com/u/tongninguniverse)\
**Post date:** [January 6, 2015, 5:28am UTC](https://forums.suse.com/t/sg-persist-pr-in-command-not-supported/26528/1 "2015-01-06T05:28:00Z")

</div>

Hello experts,

I have some problem about sg\_persist command:

root@hosta:/root \> sg\_persist --in --report-capabilities -v /dev/sdb  
inquiry cdb: 12 00 00 00 24 00  
VMware Virtual disk 1.0  
Peripheral device type: disk  
Persistent Reservation In cmd: 5e 02 00 00 00 00 00 20 00 00  
persistent reservation in: transport: Host\_status=0x10 [DID\_TARGET\_FAILURE]  
Driver\_status=0x08 [DRIVER\_SENSE, SUGGEST\_OK]

persistent reservation in: Fixed format, current; Sense key: Illegal Request  
Additional sense: Invalid command operation code  
Sense Key Specific: Error in Command byte 0  
PR in: command not supported

root@hosta:/root \> sg\_persist /dev/sdb

> > No service action given; assume Persistent Reserve In command  
> > with Read Keys service action  
> > VMware Virtual disk 1.0  
> > Peripheral device type: disk  
> > persistent reservation in: transport: Host\_status=0x10 [DID\_TARGET\_FAILURE]  
> > Driver\_status=0x08 [DRIVER\_SENSE, SUGGEST\_OK]

PR in: command not supported

Do you know any hint about how to analyze and solve this problem?

Thanks & Best Regards,  
Tong Ning

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/flex022/uploads/suse/original/2X/5/5012ba89e3ffb5220dac47d5ea0ba032e2fe1cb6.png) [@system](https://forums.suse.com/u/system)\
**Post date:** [January 11, 2015, 3:30pm UTC](https://forums.suse.com/t/sg-persist-pr-in-command-not-supported/26528/2 "2015-01-11T15:30:26Z")

</div>

Tongninguniverse,

It appears that in the past few days you have not received a response to your  
posting. That concerns us, and has triggered this automated reply.

Has your issue been resolved? If not, you might try one of the following options:

- Visit [http://www.suse.com/support](http://www.suse.com/support) and search the knowledgebase and/or check all  
the other support options available.
- You could also try posting your message again. Make sure it is posted in the  
correct newsgroup. ([http://forums.suse.com](http://forums.suse.com))

Be sure to read the forum FAQ about what to expect in the way of responses:  
[http://forums.suse.com/faq.php](http://forums.suse.com/faq.php)

If this is a reply to a duplicate posting, please ignore and accept our apologies  
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your SUSE Forums Team  
[http://forums.suse.com](http://forums.suse.com)

---

<div class="post-metadata">

**Author:** ![Jens-U](https://avatars.discourse-cdn.com/v4/letter/j/d78d45/32.png) [@Jens-U](https://forums.suse.com/u/Jens-U)\
**Post date:** [January 12, 2015, 5:03pm UTC](https://forums.suse.com/t/sg-persist-pr-in-command-not-supported/26528/3 "2015-01-12T17:03:16Z")

</div>

Hi Ting Ning,

[QUOTE=tongninguniverse;25635]Hello experts,

I have some problem about sg\_persist command:

root@hosta:/root \> sg\_persist --in --report-capabilities -v /dev/sdb  
inquiry cdb: 12 00 00 00 24 00  
VMware Virtual disk 1.0  
Peripheral device type: disk  
Persistent Reservation In cmd: 5e 02 00 00 00 00 00 20 00 00  
persistent reservation in: transport: Host\_status=0x10 [DID\_TARGET\_FAILURE]  
Driver\_status=0x08 [DRIVER\_SENSE, SUGGEST\_OK]

persistent reservation in: Fixed format, current; Sense key: Illegal Request  
Additional sense: Invalid command operation code  
Sense Key Specific: Error in Command byte 0  
PR in: command not supported

root@hosta:/root \> sg\_persist /dev/sdb

> > No service action given; assume Persistent Reserve In command  
> > with Read Keys service action  
> > VMware Virtual disk 1.0  
> > Peripheral device type: disk  
> > persistent reservation in: transport: Host\_status=0x10 [DID\_TARGET\_FAILURE]  
> > Driver\_status=0x08 [DRIVER\_SENSE, SUGGEST\_OK]

PR in: command not supported

Do you know any hint about how to analyze and solve this problem?[/QUOTE]

It will help to provide specifics of what’s behind that virtual disk you’re querying, persistent SCSI reservations need to be supported by the underlying layer.

Regards,  
Jens
