# sle11 repo-caching problem

**URL:** <https://forums.suse.com/t/sle11-repo-caching-problem/30473>\
**Category:** SUSE Multi Linux Manager\
**Created:** [October 26, 2017, 11:02am UTC](https://forums.suse.com/t/sle11-repo-caching-problem/30473 "2017-10-26T11:02:35Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Jochen](https://avatars.discourse-cdn.com/v4/letter/j/91b2a8/32.png) [@Jochen](https://forums.suse.com/u/Jochen)\
**Post date:** [October 26, 2017, 11:02am UTC](https://forums.suse.com/t/sle11-repo-caching-problem/30473/1 "2017-10-26T11:02:35Z")

</div>

Hi,

I’m new to this forum and I’m not very expierenced in suma. We still build the suma environment in our company. During Tests an error appears while registering sles11 based clients via traditional bootstraping.

The error occures only when sle11 systems call the function “repo2solv” on the custom-repositorys. Deep debugging showed, that we need to change the hash from sha512 to sha256 - that works. But the problem still exists, when we add empty channels to the systems who are sle11 based.

In SLES12 all works fine … anyone have an idea?

Best Regards

---

<div class="post-metadata">

**Author:** ![mcalmer](https://avatars.discourse-cdn.com/v4/letter/m/b4bc9f/32.png) [@mcalmer](https://forums.suse.com/u/mcalmer)\
**Post date:** [October 27, 2017, 9:47am UTC](https://forums.suse.com/t/sle11-repo-caching-problem/30473/2 "2017-10-27T09:47:28Z")

</div>

[QUOTE=sielckjo;39993]Hi,

The error occures only when sle11 systems call the function “repo2solv” on the custom-repositorys. Deep debugging showed, that we need to change the hash from sha512 to sha256 - that works. But the problem still exists, when we add empty channels to the systems who are sle11 based.

Best Regards[/QUOTE]

sha512 is not supported on SLE11, sha256 is the best you can get on it. For the empty channel please check if metadata were generated at all (/var/cache/rhn/repodata// ).  
If metadata are available, please provide more info about the error you see.

---

<div class="post-metadata">

**Author:** ![Jochen](https://avatars.discourse-cdn.com/v4/letter/j/91b2a8/32.png) [@Jochen](https://forums.suse.com/u/Jochen)\
**Post date:** [November 9, 2017, 8:52am UTC](https://forums.suse.com/t/sle11-repo-caching-problem/30473/3 "2017-11-09T08:52:59Z")

</div>

It’s solved!! We changed the value sha256 to the softwarechannels and now all is fine with the caching.

Thank you mcalmer!
