# SMT error SLES10SP3

**URL:** <https://forums.suse.com/t/smt-error-sles10sp3/22047>\
**Category:** SLES Updates\
**Created:** [January 26, 2012, 8:36pm UTC](https://forums.suse.com/t/smt-error-sles10sp3/22047 "2012-01-26T20:36:01Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![System1](https://avatars.discourse-cdn.com/v4/letter/s/51bf81/32.png) [@System1](https://forums.suse.com/u/System1)\
**Post date:** [January 26, 2012, 8:36pm UTC](https://forums.suse.com/t/smt-error-sles10sp3/22047/1 "2012-01-26T20:36:01Z")

</div>

I have a customer that just installed a new SMT server, and they are  
trying to have their first server update from that source. The SMT -  
server name is - lifeboat2 and the server that they are trying to update  
is called DC1-eDir

When they attempted to update the server they are getting the following  
error:

Failed to parse XML metadata: Can’t add repository at  
[http://lifeboat2.pwcs.edu/repo/$RCE/OES2-SP3-Online/sles-10-x86\_64:](http://lifeboat2.pwcs.edu/repo/$RCE/OES2-SP3-Online/sles-10-x86_64:)  
Unknown Error: Downloading metadata  
failed (is YUM source?) or user did not accept remote source. Aborting  
refresh.ERROR: Could not add ‘[http://Lifeboat2.pwcs.edu/](http://Lifeboat2.pwcs.edu/)’: Failed to  
parse XML metadata: Can’t add  
repository at  
[http://lifeboat2.pwcs.edu/repo/$RCE/OES2-SP3-Online/sles-10-x86\_64:](http://lifeboat2.pwcs.edu/repo/$RCE/OES2-SP3-Online/sles-10-x86_64:)  
Unknown Error: Downloading metadata failed (is YUM source?) or user  
did not accept remote source. Aborting  
refresh.Cannot execute /usr/bin/rug sa -t nu [http://Lifeboat2.pwcs.edu/](http://Lifeboat2.pwcs.edu/)  
SMT-http\_Lifeboat2\_pwcs\_edu: Bad file descriptor  
DC1-eDIR:~/downloads #

They also tried the following

We also try to edit the robots.txt file and added the " Allow:  
/repo/keys " before the Disallow: / line but received the same results.

I forgot to let you know that but in both cases we get the same error.

Would anyone have any ideas what I can start looking into to fix this  
problem?

Thank you,

## – dschaldenovell

dschaldenovell’s Profile: [http://forums.novell.com/member.php?userid=93234](http://forums.novell.com/member.php?userid=93234)  
View this thread: [http://forums.novell.com/showthread.php?t=451395](http://forums.novell.com/showthread.php?t=451395)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/flex022/uploads/suse/original/2X/5/5012ba89e3ffb5220dac47d5ea0ba032e2fe1cb6.png) [@system](https://forums.suse.com/u/system)\
**Post date:** [January 31, 2012, 10:27pm UTC](https://forums.suse.com/t/smt-error-sles10sp3/22047/2 "2012-01-31T22:27:16Z")

</div>

dschaldenovell,

It appears that in the past few days you have not received a response to your  
posting. That concerns us, and has triggered this automated reply.

Has your problem been resolved? If not, you might try one of the following options:

- Visit [http://support.novell.com](http://support.novell.com) and search the knowledgebase and/or check all  
the other self support options and support programs available.
- You could also try posting your message again. Make sure it is posted in the  
correct newsgroup. ([http://forums.novell.com](http://forums.novell.com))

Be sure to read the forum FAQ about what to expect in the way of responses:  
[http://forums.novell.com/faq.php](http://forums.novell.com/faq.php)

If this is a reply to a duplicate posting, please ignore and accept our apologies  
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your Novell Product Support Forums Team  
[http://forums.novell.com/](http://forums.novell.com/)

---

<div class="post-metadata">

**Author:** ![dschaldenovell](https://avatars.discourse-cdn.com/v4/letter/d/85e7bf/32.png) [@dschaldenovell](https://forums.suse.com/u/dschaldenovell)\
**Post date:** [February 9, 2012, 2:10pm UTC](https://forums.suse.com/t/smt-error-sles10sp3/22047/3 "2012-02-09T14:10:25Z")

</div>

[QUOTE=dschaldenovell;1624]I have a customer that just installed a new SMT server, and they are  
trying to have their first server update from that source. The SMT -  
server name is - lifeboat2 and the server that they are trying to update  
is called DC1-eDir

When they attempted to update the server they are getting the following  
error:

Failed to parse XML metadata: Can’t add repository at  
[http://lifeboat2.pwcs.edu/repo/$RCE/OES2-SP3-Online/sles-10-x86\_64:](http://lifeboat2.pwcs.edu/repo/$RCE/OES2-SP3-Online/sles-10-x86_64:)  
Unknown Error: Downloading metadata  
failed (is YUM source?) or user did not accept remote source. Aborting  
refresh.ERROR: Could not add ‘[http://Lifeboat2.pwcs.edu/](http://Lifeboat2.pwcs.edu/)’: Failed to  
parse XML metadata: Can’t add  
repository at  
[http://lifeboat2.pwcs.edu/repo/$RCE/OES2-SP3-Online/sles-10-x86\_64:](http://lifeboat2.pwcs.edu/repo/$RCE/OES2-SP3-Online/sles-10-x86_64:)  
Unknown Error: Downloading metadata failed (is YUM source?) or user  
did not accept remote source. Aborting  
refresh.Cannot execute /usr/bin/rug sa -t nu [http://Lifeboat2.pwcs.edu/](http://Lifeboat2.pwcs.edu/)  
SMT-http\_Lifeboat2\_pwcs\_edu: Bad file descriptor  
DC1-eDIR:~/downloads #

They also tried the following

We also try to edit the robots.txt file and added the " Allow:  
/repo/keys " before the Disallow: / line but received the same results.

I forgot to let you know that but in both cases we get the same error.

Would anyone have any ideas what I can start looking into to fix this  
problem?

Thank you,

## – dschaldenovell

dschaldenovell’s Profile: [http://forums.novell.com/member.php?userid=93234](http://forums.novell.com/member.php?userid=93234)  
View this thread: [http://forums.novell.com/showthread.php?t=451395](http://forums.novell.com/showthread.php?t=451395)[/QUOTE]

Another SMT server issue for my customer,

"In reference to the SMT project. I have about a 15 zen7 servers that get the same error when trying to run the SMT script or even do a rug sl. See below for error. I went thru about 190 servers and about 15 zen7 out of 90(-ish) zen7 get that same error. Any advice??

BRMS-Zen7:~/downloads # rug sl

\*\* (/usr/lib64/rug/rug.exe:30898): WARNING \*\*: process\_set\_current: error creating process handle

\*\* (/usr/lib64/rug/rug.exe:30898): WARNING \*\*: thread\_attach: error creating thread handle

\*\* (/usr/lib64/rug/rug.exe:30898): WARNING \*\*: CreateThread: error creating thread handle

Unhandled Exception: System.ExecutionEngineException: Couldn’t create thread

Any thoughts would be most appreciated.
