# Solved - Certificate error in logs

**URL:** <https://forums.suse.com/t/solved-certificate-error-in-logs/14686>\
**Category:** SUSE Rancher Prime\
**Created:** [July 1, 2019, 2:26pm UTC](https://forums.suse.com/t/solved-certificate-error-in-logs/14686 "2019-07-01T14:26:30Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![dc.901](https://avatars.discourse-cdn.com/v4/letter/d/977dab/32.png) [@dc.901](https://forums.suse.com/u/dc.901)\
**Post date:** [July 1, 2019, 2:26pm UTC](https://forums.suse.com/t/solved-certificate-error-in-logs/14686/1 "2019-07-01T14:26:30Z")

</div>

I have rancher 2.2.4 in HA…  
When I first installed rancher, it had self-signed cert, with this command:

```auto
helm install rancher-latest/rancher \
  --name rancher \
  --namespace cattle-system \
  --set hostname=rancher.my.org
```

* * *

After few weeks, did helm upgrade rancher, and using real certificate:

```auto
helm repo add rancher-stable https://releases.rancher.com/server-charts/stable

helm upgrade rancher rancher-stable/rancher \
  --namespace cattle-system \
  --set hostname=rancher.my.org \
  --set ingress.tls.source=secret \
  --set privateCA=true

kubectl -n cattle-system delete secret tls-rancher-ingress

kubectl -n cattle-system create secret tls tls-rancher-ingress --cert=tls.crt --key=tls.key

kubectl -n cattle-system create secret generic tls-ca --from-file=cacerts.pem
```

* * *

After this point, my custom cluster took several minutes, but it came back.  
However, I am now seeing these:

```auto
time="2019-07-01T14:21:16Z" level=info msg="Connecting to wss://rancher.my.org/v3/connect with token <my_token>"
time="2019-07-01T14:21:16Z" level=info msg="Connecting to proxy" url="wss://rancher.my.org/v3/connect"
time="2019-07-01T14:21:16Z" level=error msg="Failed to connect to proxy" error="x509: certificate signed by unknown authority"
time="2019-07-01T14:21:16Z" level=error msg="Failed to connect to proxy" error="x509: certificate signed by unknown authority"
```

* * *

I am trying to figure out what is causing this and how can I resolve it?

Thank you!

---

<div class="post-metadata">

**Author:** ![cjellick](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/cjellick/32/2876_2.png) [@cjellick](https://forums.suse.com/u/cjellick)\
**Post date:** [July 1, 2019, 3:53pm UTC](https://forums.suse.com/t/solved-certificate-error-in-logs/14686/2 "2019-07-01T15:53:00Z")

</div>

I’m not 100% sure if this will work, but you could try deleting the cluster-agent pod. That would cause it to get recreated and it then might have the correct ca cert.

---

<div class="post-metadata">

**Author:** ![dc.901](https://avatars.discourse-cdn.com/v4/letter/d/977dab/32.png) [@dc.901](https://forums.suse.com/u/dc.901)\
**Post date:** [July 1, 2019, 5:09pm UTC](https://forums.suse.com/t/solved-certificate-error-in-logs/14686/3 "2019-07-01T17:09:51Z")

</div>

Thanks for reply!  
Have a stupid question, but want to confirm.  
Do I delete cluster-agent pod running on one of the three nodes of rancher-cluster or cluster-agent pod running on custom cluster?

---

<div class="post-metadata">

**Author:** ![dc.901](https://avatars.discourse-cdn.com/v4/letter/d/977dab/32.png) [@dc.901](https://forums.suse.com/u/dc.901)\
**Post date:** [July 4, 2019, 12:03am UTC](https://forums.suse.com/t/solved-certificate-error-in-logs/14686/4 "2019-07-04T00:03:33Z")

</div>

Ended up rebuilding the whole environment, and now the errors are gone.
