# \[SOLVED\] Convoy-nfs: Failed to allocate instance, bad instance, scheduling failed

**URL:** <https://forums.suse.com/t/solved-convoy-nfs-failed-to-allocate-instance-bad-instance-scheduling-failed/4544>\
**Category:** Convoy\
**Created:** [November 7, 2016, 4:43pm UTC](https://forums.suse.com/t/solved-convoy-nfs-failed-to-allocate-instance-bad-instance-scheduling-failed/4544 "2016-11-07T16:43:23Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Nicolinux](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/nicolinux/32/1825_2.png) [@Nicolinux](https://forums.suse.com/u/Nicolinux)\
**Post date:** [November 7, 2016, 4:43pm UTC](https://forums.suse.com/t/solved-convoy-nfs-failed-to-allocate-instance-bad-instance-scheduling-failed/4544/1 "2016-11-07T16:43:23Z")

</div>

As soon as I try to create a service which uses the convoy-nfs driver, I get the following error:

`Failed to allocate instance [container:1i84]: Bad instance [container:1i84] in state [error]: Scheduling failed: valid host(s) [], volume [65] must have exactly these pool(s): [3], valid host(s) []`

I have used the catalog template to create the convoy-nfs stack. The NFS server is configured on the same machine where the Rancher server runs. The other hosts already mounted the nfs share. It doesn’t matter if I create a volume first or specify the volume name during service creation. I get the same error.  
The rancher/server container reports the following:

`2016-11-07 16:19:48,206 ERROR [cba5e2f8-0be9-4d83-9843-c7a1658f309b:1760] [instance:85] [instance.start->(InstanceStart)] [] [cutorService-44] [i.c.p.process.instance.InstanceStart] Failed to Scheduling for instance [85]`

Rancher version: v1.2.0-pre4-rc6  
Convoy-agent: 0.9.0  
Docker: 1.12.2

---

<div class="post-metadata">

**Author:** ![Nicolinux](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/nicolinux/32/1825_2.png) [@Nicolinux](https://forums.suse.com/u/Nicolinux)\
**Post date:** [November 9, 2016, 6:37pm UTC](https://forums.suse.com/t/solved-convoy-nfs-failed-to-allocate-instance-bad-instance-scheduling-failed/4544/2 "2016-11-09T18:37:48Z")

</div>

I still have the same issue. Is there really no one who knows what’s up?  
I tried to disable the firewall, restart the docker services, the rancher container, delete the convoy-nfs stack and add it again but it still doesn’t work.

---

<div class="post-metadata">

**Author:** ![Nicolinux](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/nicolinux/32/1825_2.png) [@Nicolinux](https://forums.suse.com/u/Nicolinux)\
**Post date:** [November 10, 2016, 2:09pm UTC](https://forums.suse.com/t/solved-convoy-nfs-failed-to-allocate-instance-bad-instance-scheduling-failed/4544/3 "2016-11-10T14:09:12Z")

</div>

Replying to myself again…  
I have reverted to rancher v1.2.0-pre3 and set up convoy-nfs with this mount options only: “nfsvers=4”.  
Now I can create services wich use the convoy-nfs driver.
