# sssd not starting- failed

**URL:** <https://forums.suse.com/t/sssd-not-starting-failed/29577>\
**Category:** SLES Configure-Administer\
**Created:** [March 25, 2017, 6:26pm UTC](https://forums.suse.com/t/sssd-not-starting-failed/29577 "2017-03-25T18:26:41Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![srisum0728](https://avatars.discourse-cdn.com/v4/letter/s/4491bb/32.png) [@srisum0728](https://forums.suse.com/u/srisum0728)\
**Post date:** [March 25, 2017, 6:26pm UTC](https://forums.suse.com/t/sssd-not-starting-failed/29577/1 "2017-03-25T18:26:41Z")

</div>

Hi,

I am unable to start sssd as its getting failed with below error.

OS: SLES 11  
Version: 3

# uname -r

2.6.32.59-0.7-default

# sssd -d4

ldb: unable to dlopen /usr/lib64/ldb/tdb.so : /usr/lib64/ldb/tdb.so: undefined symbol: tdb\_transaction\_prepare\_commit

# /etc/init.d/sssd restart

Shutting down sssd done  
Starting sssd failed

# rpm -qf /usr/lib64/ldb/tdb.so

libldb1-3.6.3-64.1

# rpm -Vv libldb1-3.6.3-64.1

… /usr/lib64/ldb  
… /usr/lib64/ldb/asq.so  
… /usr/lib64/ldb/ldap.so  
… /usr/lib64/ldb/libldb-cmdline.so  
… /usr/lib64/ldb/paged\_results.so  
… /usr/lib64/ldb/paged\_searches.so  
… /usr/lib64/ldb/rdn\_name.so  
… /usr/lib64/ldb/sample.so  
… /usr/lib64/ldb/server\_sort.so  
… /usr/lib64/ldb/skel.so  
… /usr/lib64/ldb/tdb.so  
… /usr/lib64/libldb.so.1  
… /usr/lib64/libldb.so.1.0.2  
… /usr/lib64/libpyldb-util.so.1  
… /usr/lib64/libpyldb-util.so.1.0.2  
~:/var/lib #

Could anyone help on this?

Regards,  
Sridaran G

---

<div class="post-metadata">

**Author:** ![tbrinkmann](https://avatars.discourse-cdn.com/v4/letter/t/e99b99/32.png) [@tbrinkmann](https://forums.suse.com/u/tbrinkmann)\
**Post date:** [March 27, 2017, 4:13pm UTC](https://forums.suse.com/t/sssd-not-starting-failed/29577/2 "2017-03-27T16:13:58Z")

</div>

Re,

please do not use outdated sp3, on sp4 it works fine.

[https://www.suse.com/lifecycle/](https://www.suse.com/lifecycle/)

ON SP4  
libldb1-3.6.3-84.1  
sssd-1.9.4-0.26.1

\*T

---

<div class="post-metadata">

**Author:** ![srisum0728](https://avatars.discourse-cdn.com/v4/letter/s/4491bb/32.png) [@srisum0728](https://forums.suse.com/u/srisum0728)\
**Post date:** [March 27, 2017, 5:32pm UTC](https://forums.suse.com/t/sssd-not-starting-failed/29577/3 "2017-03-27T17:32:34Z")

</div>

Hello,

Thanks for the response!  
Will update to SP4 latest and try with sssd.

Regards,  
Sridaran G

---

<div class="post-metadata">

**Author:** ![Lawrence1](https://avatars.discourse-cdn.com/v4/letter/l/e56c9b/32.png) [@Lawrence1](https://forums.suse.com/u/Lawrence1)\
**Post date:** [August 6, 2017, 6:10pm UTC](https://forums.suse.com/t/sssd-not-starting-failed/29577/4 "2017-08-06T18:10:15Z")

</div>

srisum0728,

Verify the permissions on the /etc/sssd/sssd.conf file, it should be owned by root and be set to 600 (root:root 600).

If the existing SSSD cache files can be deleted (/var/lib/sssd/db/\*.ldb) delete them and try to restart the daemon.

If the daemon still fails to start post your /etc/sssd/sssd.conf contents and we’tt try to help you.

– lawrence
