# SUSE 11.4 Server + apache 2 + php 5.3 with ico8 module

**URL:** <https://forums.suse.com/t/suse-11-4-server-apache-2-php-5-3-with-ico8-module/32220>\
**Category:** SLES High Availability Extension\
**Created:** [April 1, 2018, 10:22pm UTC](https://forums.suse.com/t/suse-11-4-server-apache-2-php-5-3-with-ico8-module/32220 "2018-04-01T22:22:08Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![oxalc](https://avatars.discourse-cdn.com/v4/letter/o/a183cd/32.png) [@oxalc](https://forums.suse.com/u/oxalc)\
**Post date:** [April 1, 2018, 10:22pm UTC](https://forums.suse.com/t/suse-11-4-server-apache-2-php-5-3-with-ico8-module/32220/1 "2018-04-01T22:22:08Z")

</div>

Hello,

I have a SUSE 11.4 Server + apache 2 + php 5.3 and I want to use it with oracle for which I need a ico8 module to run on this config.  
I have used this guide [https://en.opensuse.org/SDB:Howto\_build\_oci8\_extension\_module\_for\_php](https://en.opensuse.org/SDB:Howto_build_oci8_extension_module_for_php)  
but after doing all the steps I am getting this error in apache logs:

[Sun Apr 01 20:40:31 2018] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]  
Inconsistency detected by ld.so: dl-open.c: 596: \_dl\_open: Assertion `\_dl\_debug\_initialize (0, args.nsid)-\>r\_state == RT\_CONSISTENT’ failed!

and Apache server would not start.

I have added and deleted many parameters and I need help to run the webserver, with that would be enough.

Any help would be very much appreciate it.

Thank you.

This is the httpd.conf  
[PHP]

# 

# /etc/apache2/httpd.conf

# 

# This is the main Apache server configuration file. It contains the

# configuration directives that give the server its instructions.

# See URL:http://httpd.apache.org/docs-2.2/ for detailed information about

# the directives.

# Based upon the default apache configuration file that ships with apache,

# which is based upon the NCSA server configuration files originally by Rob

# McCool. This file was knocked together by Peter Poeml [poeml+apache@suse.de](mailto:poeml+apache@suse.de).

# If possible, avoid changes to this file. It does mainly contain Include

# statements and global settings that can/should be overridden in the

# configuration of your virtual hosts.

# Quickstart guide:

# [http://en.opensuse.org/Apache\_Quickstart\_HOWTO](http://en.opensuse.org/Apache_Quickstart_HOWTO)

# Overview of include files, chronologically:

# 

# httpd.conf

# |

# |-- uid.conf . . . . . . . . . . . . . . UserID/GroupID to run under

# |-- server-tuning.conf . . . . . . . . . sizing of the server (how many processes to start, …)

# |-- sysconfig.d/loadmodule.conf . . . . . [\*] load these modules

# |-- listen.conf . . . . . . . . . . . . . IP adresses / ports to listen on

# |-- mod\_log\_config.conf . . . . . . . . . define logging formats

# |-- sysconfig.d/global.conf . . . . . . . [\*] server-wide general settings

# |-- mod\_status.conf . . . . . . . . . . . restrict access to mod\_status (server monitoring)

# |-- mod\_info.conf . . . . . . . . . . . . restrict access to mod\_info

# |-- mod\_usertrack.conf . . . . . . . . . defaults for cookie-based user tracking

# |-- mod\_autoindex-defaults.conf . . . . . defaults for displaying of server-generated directory listings

# |-- mod\_mime-defaults.conf . . . . . . . defaults for mod\_mime configuration

# |-- errors.conf . . . . . . . . . . . . . customize error responses

# |-- ssl-global.conf . . . . . . . . . . . SSL conf that applies to default server _and all_ virtual hosts

# |

# |-- default-server.conf . . . . . . . . . set up the default server that replies to non-virtual-host requests

# | |–mod\_userdir.conf . . . . . . . . enable UserDir (if mod\_userdir is loaded)

# | `–conf.d/apache2-manual?conf . . . add the docs (‘?’ = if installed)

# |

# |-- sysconfig.d/include.conf . . . . . . [\*] your include files

# | (for each file to be included here, put its name

# | into APACHE\_INCLUDE\_\* in /etc/sysconfig/apache2)

# |

# `-- vhosts.d/ . . . . . . . . . . . . . . for each virtual host, place one file here

# `-- _.conf . . . . . . . . . . . . . (_.conf is automatically included)

# 

# 

# Files marked [\*] are created from sysconfig upon server restart: instead of

# these files, you edit /etc/sysconfig/apache2

# Filesystem layout:

# 

# /etc/apache2/

# |-- charset.conv . . . . . . . . . . . . for mod\_auth\_ldap

# |-- conf.d/

# | |-- apache2-manual.conf . . . . . . . conf that comes with apache2-doc

# | |-- mod\_php4.conf . . . . . . . . . . (example) conf that comes with apache2-mod\_php4

# | `-- … . . . . . . . . . . . . . . . other configuration added by packages

# |-- default-server.conf

# |-- errors.conf

# |-- httpd.conf . . . . . . . . . . . . . top level configuration file

# |-- listen.conf

# |-- magic

# |-- mime.types → ../mime.types

# |-- mod\_autoindex-defaults.conf

# |-- mod\_info.conf

# |-- mod\_log\_config.conf

# |-- mod\_mime-defaults.conf

# |-- mod\_perl-startup.pl

# |-- mod\_status.conf

# |-- mod\_userdir.conf

# |-- mod\_usertrack.conf

# |-- server-tuning.conf

# |-- ssl-global.conf

# |-- ssl.crl/ . . . . . . . . . . . . . . PEM-encoded X.509 Certificate Revocation Lists (CRL)

# |-- ssl.crt/ . . . . . . . . . . . . . . PEM-encoded X.509 Certificates

# |-- ssl.csr/ . . . . . . . . . . . . . . PEM-encoded X.509 Certificate Signing Requests

# |-- ssl.key/ . . . . . . . . . . . . . . PEM-encoded RSA Private Keys

# |-- ssl.prm/ . . . . . . . . . . . . . . public DSA Parameter Files

# |-- sysconfig.d/ . . . . . . . . . . . . files that are created from /etc/sysconfig/apache2

# | |-- global.conf

# | |-- include.conf

# | `-- loadmodule.conf

# |-- uid.conf

# `-- vhosts.d/ . . . . . . . . . . . . . . put your virtual host configuration (\*.conf) here

# |-- vhost-ssl.template

# `-- vhost.template

### Global Environment

# 

# The directives in this section affect the overall operation of Apache,

# such as the number of concurrent requests.

# run under this user/group id

Include /etc/apache2/uid.conf

# - how many server processes to start (server pool regulation)

# - usage of KeepAlive

Include /etc/apache2/server-tuning.conf

# ErrorLog: The location of the error log file.

# If you do not specify an ErrorLog directive within a

# container, error messages relating to that virtual host will be

# logged here. If you _do_ define an error logfile for a

# container, that host’s errors will be logged there and not here.

ErrorLog /var/log/apache2/error\_log

# generated from APACHE\_MODULES in /etc/sysconfig/apache2

Include /etc/apache2/sysconfig.d/loadmodule.conf

# IP addresses / ports to listen on

Include /etc/apache2/listen.conf

# predefined logging formats

Include /etc/apache2/mod\_log\_config.conf

# generated from global settings in /etc/sysconfig/apache2

Include /etc/apache2/sysconfig.d/global.conf

# optional mod\_status, mod\_info

Include /etc/apache2/mod\_status.conf  
Include /etc/apache2/mod\_info.conf

# optional cookie-based user tracking

# read the documentation before using it!!

Include /etc/apache2/mod\_usertrack.conf

# configuration of server-generated directory listings

Include /etc/apache2/mod\_autoindex-defaults.conf

# associate MIME types with filename extensions

TypesConfig /etc/apache2/mime.types  
DefaultType text/plain  
Include /etc/apache2/mod\_mime-defaults.conf

# set up (customizable) error responses

Include /etc/apache2/errors.conf

# global (server-wide) SSL configuration, that is not specific to

# any virtual host

Include /etc/apache2/ssl-global.conf

# forbid access to the entire filesystem by default
 Options None AllowOverride None Order deny,allow Deny from all
# use .htaccess files for overriding,

AccessFileName .htaccess

# and never show them

\<Files ~ “^\.ht”\>  
Order allow,deny  
Deny from all

# List of resources to look for when the client requests a directory

DirectoryIndex index.html index.html.var

### ‘Main’ server configuration

# 

# The directives in this section set up the values used by the ‘main’

# server, which responds to any requests that aren’t handled by a

# definition. These values also provide defaults for

# any containers you may define later in the file.

# 

# All of these directives may appear inside containers,

# in which case these default settings will be overridden for the

# virtual host being defined.

# 

Include /etc/apache2/default-server.conf

# Another way to include your own files

# 

# The file below is generated from /etc/sysconfig/apache2,

# include arbitrary files as named in APACHE\_CONF\_INCLUDE\_FILES and

# APACHE\_CONF\_INCLUDE\_DIRS

Include /etc/apache2/sysconfig.d/include.conf

### Virtual server configuration

# 

# VirtualHost: If you want to maintain multiple domains/hostnames on your

# machine you can setup VirtualHost containers for them. Most configurations

# use only name-based virtual hosts so the server doesn’t need to worry about

# IP addresses. This is indicated by the asterisks in the directives below.

# 

# Please see the documentation at

# URL:http://httpd.apache.org/docs-2.2/vhosts/

# for further details before you try to setup virtual hosts.

# 

# You may use the command line option ‘-S’ to verify your virtual host

# configuration.

# 

Include /etc/apache2/vhosts.d/\*.conf

# Note: instead of adding your own configuration here, consider

# adding it in your own file (/etc/apache2/httpd.conf.local)

# putting its name into APACHE\_CONF\_INCLUDE\_FILES in

# /etc/sysconfig/apache2 – this will make system updates

# easier 🙂

AddHandler application/x-httpd-php .php

# configure the path to php.ini

PHPIniDir “/etc/php5/apache2/php.ini”

\<FilesMatch \.php$\>  
SetHandler application/x-httpd-php

 # # Allow server status reports generated by mod\_status, # with the URL of http://servername/server-status # Change the ".example.com" to match your domain to enable. # ExtendedStatus On SetHandler server-status Order deny,allow Deny from all Allow from .example.com 

#

# Include conf/ssl.conf

#

[/PHP]

This is the ssl-globalconf  
[PHP]

## 

## SSL Global Context

## 

## All SSL configuration in this context applies both to

## the main server and all SSL-enabled virtual hosts.

## 

# These are the configuration directives to instruct the server how to

# serve pages over an https connection. For detailing information about these

# directives see URL:http://httpd.apache.org/docs-2.2/mod/mod\_ssl.html

# 

# Do NOT simply read the instructions in here without understanding

# what they do. They’re here only as hints or reminders. If you are unsure

# consult the online docs. You have been warned.

# This global SSL configuration is ignored if

# “SSL” is not defined, or if “NOSSL” is defined.
#

```
#
# Some MIME-types for downloading Certificates and CRLs
#
AddType application/x-x509-ca-cert .crt
AddType application/x-pkcs7-crl .crl

# Pass Phrase Dialog:
# Configure the pass phrase gathering process.
# The filtering dialog program (`builtin' is a internal
# terminal dialog) has to provide the pass phrase on stdout.
SSLPassPhraseDialog builtin

# Inter-Process Session Cache:
# Configure the SSL Session Cache: First the mechanism 
# to use and second the expiring timeout (in seconds).
# shm means the same as shmht. 
# Note that on most platforms shared memory segments are not allowed to be on 
# network-mounted drives, so in that case you need to use the dbm method.
#SSLSessionCache none
#SSLSessionCache dbm:/var/lib/apache2/ssl_scache
#SSLSessionCache shmht:/var/lib/apache2/ssl_scache(512000)
SSLSessionCache shmcb:/var/lib/apache2/ssl_scache(512000)
SSLSessionCacheTimeout 600

# This configures the SSL engine's semaphore (aka. lock) which is
# used for mutual exclusion of operations which have to be done in a
# synchronized way between the pre-forked Apache server processes.
# "default" tells the SSL Module to pick the default locking
# implementation as determined by the platform and APR.
SSLMutex default

# Pseudo Random Number Generator (PRNG):
# Configure one or more sources to seed the PRNG of the 
# SSL library. The seed data should be of good random quality.
# WARNING! On some platforms /dev/random blocks if not enough entropy
# is available. This means you then cannot use the /dev/random device
# because it would lead to very long connection times (as long as
# it requires to make more entropy available). But usually those
# platforms additionally provide a /dev/urandom device which doesn't
# block. So, if available, use this one instead. Read the mod_ssl User
# Manual for more details.
SSLRandomSeed startup builtin
SSLRandomSeed connect builtin
#SSLRandomSeed startup file:/dev/random 512
#SSLRandomSeed connect file:/dev/random 512
#SSLRandomSeed startup file:/dev/urandom 512
#SSLRandomSeed connect file:/dev/urandom 512

```

[/PHP]

---

<div class="post-metadata">

**Author:** ![Automatic\_Reply](https://avatars.discourse-cdn.com/v4/letter/a/ecb155/32.png) [@Automatic\_Reply](https://forums.suse.com/u/Automatic_Reply)\
**Post date:** [April 6, 2018, 7:30am UTC](https://forums.suse.com/t/suse-11-4-server-apache-2-php-5-3-with-ico8-module/32220/2 "2018-04-06T07:30:21Z")

</div>

oxalc,

It appears that in the past few days you have not received a response to your  
posting. That concerns us, and has triggered this automated reply.

These forums are peer-to-peer, best effort, volunteer run and that if your issue  
is urgent or not getting a response, you might try one of the following options:

- Visit [http://www.suse.com/support](http://www.suse.com/support) and search the knowledgebase and/or check all  
the other support options available.
- Open a service request: [https://www.suse.com/support](https://www.suse.com/support)
- You could also try posting your message again. Make sure it is posted in the  
correct newsgroup. ([http://forums.suse.com](http://forums.suse.com))

Be sure to read the forum FAQ about what to expect in the way of responses:  
[http://forums.suse.com/faq.php](http://forums.suse.com/faq.php)

If this is a reply to a duplicate posting or otherwise posted in error, please  
ignore and accept our apologies and rest assured we will issue a stern reprimand  
to our posting bot…

Good luck!

Your SUSE Forums Team  
[http://forums.suse.com](http://forums.suse.com)
