# SUSE 15 SP6 RMT issue

**URL:** <https://forums.suse.com/t/suse-15-sp6-rmt-issue/44256>\
**Category:** SUSE Linux Enterprise Server\
**Created:** [October 7, 2024, 12:37pm UTC](https://forums.suse.com/t/suse-15-sp6-rmt-issue/44256 "2024-10-07T12:37:21Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![MingC](https://avatars.discourse-cdn.com/v4/letter/m/8edcca/32.png) [@MingC](https://forums.suse.com/u/MingC)\
**Post date:** [October 7, 2024, 12:37pm UTC](https://forums.suse.com/t/suse-15-sp6-rmt-issue/44256/1 "2024-10-07T12:37:22Z")

</div>

I am experiencing two issues with RMT installation. My RMT installation is using private IP. I have a satellite office that needs to connect to the RMT server for update. I configured a NAT for the RMT server but after running the shell script "rmt-client-setup-res"at the satellite office, it produced the following error.  
**command ‘/usr/bin/zypper --disable-repositories --xmlout --non-interactive products -i’ failed**  
**Error: zypper returned 1 with '\<?xml version='1.0'?\>**  
  
**Unexpected exception.**  
**Invalid path name component '/download/nux/dextop/el7/$basearch/ [http://mirror.li.nux.ro/li.nux.ro/nux/dextop/el7/$basearch/&apos;](http://mirror.li.nux.ro/li.nux.ro/nux/dextop/el7/$basearch/&apos;)**  
  
**Please file a bug report about this.**  
**See [SDB:Zypper troubleshooting - openSUSE Wiki](http://en.opensuse.org/Zypper/Troubleshooting) for instructions.**  
**’ (exit status 1)**  
I wonder if this is related the the NAT IP since I didn’t have such error for other servers.

Second issue is with the SUSE repo. It is not downloading certian packages with the error that checksum doesn’t match. Below are the 16 packages with this issue.

**bind-9.11.4-26.P2.el7\_9.16.x86\_64.rpm**  
**bind-chroot-9.11.4-26.P2.el7\_9.16.x86\_64.rpm**  
**bind-devel-9.11.4-26.P2.el7\_9.16.x86\_64.rpm**  
**bind-export-devel-9.11.4-26.P2.el7\_9.16.x86\_64.rpm**  
**bind-export-libs-9.11.4-26.P2.el7\_9.16.x86\_64.rpm**  
**bind-libs-9.11.4-26.P2.el7\_9.16.x86\_64.rpm**  
**bind-libs-lite-9.11.4-26.P2.el7\_9.16.x86\_64.rpm**  
**bind-license-9.11.4-26.P2.el7\_9.16.noarch.rpm**  
**bind-lite-devel-9.11.4-26.P2.el7\_9.16.x86\_64.rpm**  
**bind-pkcs11-9.11.4-26.P2.el7\_9.16.x86\_64.rpm**  
**bind-pkcs11-devel-9.11.4-26.P2.el7\_9.16.x86\_64.rpm**  
**bind-pkcs11-libs-9.11.4-26.P2.el7\_9.16.x86\_64.rpm**  
**bind-pkcs11-utils-9.11.4-26.P2.el7\_9.16.x86\_64.rpm**  
**bind-sdb-9.11.4-26.P2.el7\_9.16.x86\_64.rpm**  
**bind-sdb-chroot-9.11.4-26.P2.el7\_9.16.x86\_64.rpm**  
**bind-utils-9.11.4-26.P2.el7\_9.16.x86\_64.rpm**

Any help will be greatly appreciated. Thank You

---

<div class="post-metadata">

**Author:** ![Zulu](https://avatars.discourse-cdn.com/v4/letter/z/a9adbd/32.png) [@Zulu](https://forums.suse.com/u/Zulu)\
**Post date:** [October 9, 2024, 1:28pm UTC](https://forums.suse.com/t/suse-15-sp6-rmt-issue/44256/2 "2024-10-09T13:28:05Z")

</div>

I have the same issue with the listed packages where I am trying to setup RMT server and when doing the initial sync after doing this  
rmt-cli product enable 2702  
It fails to create `repodata` directory as rmt-cli mirror command fails with above 16 files on checksum doesn’t match. This then is causing the clients to not register as there is no repodata directory on the server.

---

<div class="post-metadata">

**Author:** ![MingC](https://avatars.discourse-cdn.com/v4/letter/m/8edcca/32.png) [@MingC](https://forums.suse.com/u/MingC)\
**Post date:** [October 9, 2024, 7:19pm UTC](https://forums.suse.com/t/suse-15-sp6-rmt-issue/44256/3 "2024-10-09T19:19:07Z")

</div>

The issue is still happening with my RMT install. I think the error is on SUSE side but since I didn’t purchase my subscription with support, I cannot contact them. As a temporary solution, I found the missing rpm files and manually installed them to the Centos7 servers and then did yum update. Hopefully that will work for you too.

---

<div class="post-metadata">

**Author:** ![Zulu](https://avatars.discourse-cdn.com/v4/letter/z/a9adbd/32.png) [@Zulu](https://forums.suse.com/u/Zulu)\
**Post date:** [October 10, 2024, 8:34am UTC](https://forums.suse.com/t/suse-15-sp6-rmt-issue/44256/4 "2024-10-10T08:34:07Z")

</div>

Check this by @JKWMoore

> [@Initial rmt sync failing](https://forums.suse.com/t/initial-rmt-sync-failing/44276/2):
>
> You may be able to bypass part of the issue here. I managed to get things fully resynced despite the checksum errors causing the same issue. It seems like because the checksums cause failed downloads it aborts saving the repodata folder. (SUSE please fix this too). What you need to do is go to the folder where the repodata is meant to be, start the mirror operation and wait for it to download the repodata to a temporary folder. When you’re sure it is no longer touching anything in the repoda…

---

<div class="post-metadata">

**Author:** ![JKWMoore](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/jkwmoore/32/11609_2.png) [@JKWMoore](https://forums.suse.com/u/JKWMoore)\
**Post date:** [October 14, 2024, 9:09am UTC](https://forums.suse.com/t/suse-15-sp6-rmt-issue/44256/5 "2024-10-14T09:09:42Z")

</div>

N.b I now see the mirror working correctly.
