# Too long wait mesos aws build

**URL:** <https://forums.suse.com/t/too-long-wait-mesos-aws-build/4629>\
**Category:** Rancher 1.x\
**Created:** [November 16, 2016, 1:02pm UTC](https://forums.suse.com/t/too-long-wait-mesos-aws-build/4629 "2016-11-16T13:02:30Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![pvcon13](https://avatars.discourse-cdn.com/v4/letter/p/9fc29f/32.png) [@pvcon13](https://forums.suse.com/u/pvcon13)\
**Post date:** [November 16, 2016, 1:02pm UTC](https://forums.suse.com/t/too-long-wait-mesos-aws-build/4629/1 "2016-11-16T13:02:30Z")

</div>

Error detecting OS: Too many retries waiting for SSH to be available. Last error: Maximum number of retries (60) exceeded

---

<div class="post-metadata">

**Author:** ![pvcon13](https://avatars.discourse-cdn.com/v4/letter/p/9fc29f/32.png) [@pvcon13](https://forums.suse.com/u/pvcon13)\
**Post date:** [November 16, 2016, 1:04pm UTC](https://forums.suse.com/t/too-long-wait-mesos-aws-build/4629/2 "2016-11-16T13:04:20Z")

</div>

Is this an aws limit perhaps or a timing config in Rancher? It would seem the machines get build and then when this error shows up Rancher Terminates them. Doing three at a time as the project suggests. Any ideas?

---

<div class="post-metadata">

**Author:** ![pvcon13](https://avatars.discourse-cdn.com/v4/letter/p/9fc29f/32.png) [@pvcon13](https://forums.suse.com/u/pvcon13)\
**Post date:** [November 16, 2016, 4:10pm UTC](https://forums.suse.com/t/too-long-wait-mesos-aws-build/4629/3 "2016-11-16T16:10:06Z")

</div>

today getting a different error : exit status 1  
Is this also related to the aws server taking too long to initialize?

---

<div class="post-metadata">

**Author:** ![aemneina](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/aemneina/32/1323_2.png) [@aemneina](https://forums.suse.com/u/aemneina)\
**Post date:** [November 17, 2016, 12:18am UTC](https://forums.suse.com/t/too-long-wait-mesos-aws-build/4629/4 "2016-11-17T00:18:03Z")

</div>

are you adding hosts to an environment? This would indicate that the server cant ssh into the potential host to provision it. Can you make sure the security group has the right permissions?

---

<div class="post-metadata">

**Author:** ![pvcon13](https://avatars.discourse-cdn.com/v4/letter/p/9fc29f/32.png) [@pvcon13](https://forums.suse.com/u/pvcon13)\
**Post date:** [November 17, 2016, 8:20pm UTC](https://forums.suse.com/t/too-long-wait-mesos-aws-build/4629/5 "2016-11-17T20:20:08Z")

</div>

solved. its was security group and user name etc
