# Unable to Create VM

**URL:** <https://forums.suse.com/t/unable-to-create-vm/26726>\
**Category:** SLES Virtualization\
**Created:** [February 26, 2015, 12:44am UTC](https://forums.suse.com/t/unable-to-create-vm/26726 "2015-02-26T00:44:59Z")\
**Posts on this page:** 20\
**Page:** 1

<div class="post-metadata">

**Author:** ![carnold6](https://avatars.discourse-cdn.com/v4/letter/c/3bc359/32.png) [@carnold6](https://forums.suse.com/u/carnold6)\
**Post date:** [February 26, 2015, 12:44am UTC](https://forums.suse.com/t/unable-to-create-vm/26726/1 "2015-02-26T00:44:59Z")

</div>

SLES12 and latest updates. Installed Xen and Xen tools. Reboot and select the SLES12 with Xen option. Click on create VM in yast and select CDROM media install. Made 2048GB RAM with 108GB drive. Used br0 for the bridge. Click finish and got this error:

Unable to complete install: ‘internal error: libxenlight failed to create new domain ‘2012r2lab’’

Traceback (most recent call last):  
File “/usr/share/virt-manager/virtManager/asyncjob.py”, line 91, in cb\_wrapper  
callback(asyncjob, \*args, \*\*kwargs)  
File “/usr/share/virt-manager/virtManager/create.py”, line 1908, in do\_install  
guest.start\_install(meter=meter)  
File “/usr/share/virt-manager/virtinst/guest.py”, line 426, in start\_install  
noboot)  
File “/usr/share/virt-manager/virtinst/guest.py”, line 490, in \_create\_guest  
dom = self.conn.createLinux(start\_xml or final\_xml, 0)  
File “/usr/lib64/python2.7/site-packages/libvirt.py”, line 3297, in createLinux  
if ret is None:raise libvirtError(‘virDomainCreateLinux() failed’, conn=self)  
libvirtError: internal error: libxenlight failed to create new domain ‘2012r2lab’

Oh, the guest is 2012R2 fullyvirtualized and the 2012R2 disc is in the drive. Any ideas?

---

<div class="post-metadata">

**Author:** ![Jens-U](https://avatars.discourse-cdn.com/v4/letter/j/d78d45/32.png) [@Jens-U](https://forums.suse.com/u/Jens-U)\
**Post date:** [February 26, 2015, 12:51pm UTC](https://forums.suse.com/t/unable-to-create-vm/26726/2 "2015-02-26T12:51:37Z")

</div>

Hi carnold6,

> Any ideas?

what’s in the related Xen logs? I’d assume you’ll find there the actual error that occurred during VM creation.

Regards,  
Jens

---

<div class="post-metadata">

**Author:** ![mhuels](https://avatars.discourse-cdn.com/v4/letter/m/7ab992/32.png) [@mhuels](https://forums.suse.com/u/mhuels)\
**Post date:** [February 26, 2015, 2:15pm UTC](https://forums.suse.com/t/unable-to-create-vm/26726/3 "2015-02-26T14:15:33Z")

</div>

same problem on my SLES 12 System. The VMs worked fine until the last update.

server:/var/log/libvirt/libxl # tail vm.domain.de.log  
libxl: debug: libxl\_create.c:1376:do\_domain\_create: ao 0x7f10580037c0: inprogress: poller=0x7f10780ec270, flags=ic  
libxl: debug: libxl\_event.c:1563:libxl\_\_ao\_\_destroy: ao 0x7f10580037c0: destroy  
libxl: debug: libxl\_create.c:1362:do\_domain\_create: ao 0x7f106c004c20: create: how=(nil) callback=(nil) poller=0x7f10780ec270  
xc: error: xc\_alloc\_hypercall\_buffer: mmap failed (11 = Resource temporarily unavailabl): Internal error

i cant see any ressource problem on my server.

mfg  
Manfred

---

<div class="post-metadata">

**Author:** ![carnold6](https://avatars.discourse-cdn.com/v4/letter/c/3bc359/32.png) [@carnold6](https://forums.suse.com/u/carnold6)\
**Post date:** [February 26, 2015, 2:18pm UTC](https://forums.suse.com/t/unable-to-create-vm/26726/4 "2015-02-26T14:18:44Z")

</div>

[QUOTE=jmozdzen;26562]Hi carnold6,

> Any ideas?

what’s in the related Xen logs? I’d assume you’ll find there the actual error that occurred during VM creation.[/QUOTE]

Not even sure where the corresponding log file is since this is the first time i have every used Xen. I did get a VM created and 2012r2 installed by rerunning the yast applet, install hypervisor and tools. The first time i installed Xen and xen tools only. The 2nd time i installed kvm and tools and then i was able to create the VM. What do you need to install in order to get a VM working? Xen and KVM or just one of those?

---

<div class="post-metadata">

**Author:** ![Jens-U](https://avatars.discourse-cdn.com/v4/letter/j/d78d45/32.png) [@Jens-U](https://forums.suse.com/u/Jens-U)\
**Post date:** [February 26, 2015, 2:27pm UTC](https://forums.suse.com/t/unable-to-create-vm/26726/5 "2015-02-26T14:27:13Z")

</div>

Hi carnold6,

> Not even sure where the corresponding log file

my best guess would be the /var/log/xen directory, with individual log files per VM (only created when the ComU start was successful), xend.log for the management daemon and probably a separate log file for DomU configuration.

> What do you need to install in order to get a VM working? Xen and KVM or just one of those?

```
            On SLES11 I know you'll only need Xen installed, not KVM. For SLES12, I have no practical experience, so I cannot tell if that has changed... but I'd call any requirement to manually add "kvm" to the list (in order to be able to create Xen DomUs) a dependency problem worth reporting ;)

```

Regards,  
Jens

PS: Judging from Manfreds reply, /var/log/libvirt seems to be an additional / alternate location for related log files.

---

<div class="post-metadata">

**Author:** ![Jens-U](https://avatars.discourse-cdn.com/v4/letter/j/d78d45/32.png) [@Jens-U](https://forums.suse.com/u/Jens-U)\
**Post date:** [February 26, 2015, 2:47pm UTC](https://forums.suse.com/t/unable-to-create-vm/26726/6 "2015-02-26T14:47:13Z")

</div>

Hi Manfred,

[QUOTE=mhuels;26568]same problem on my SLES 12 System. The VMs worked fine until the last update.

server:/var/log/libvirt/libxl # tail vm.domain.de.log  
libxl: debug: libxl\_create.c:1376:do\_domain\_create: ao 0x7f10580037c0: inprogress: poller=0x7f10780ec270, flags=ic  
libxl: debug: libxl\_event.c:1563:libxl\_\_ao\_\_destroy: ao 0x7f10580037c0: destroy  
libxl: debug: libxl\_create.c:1362:do\_domain\_create: ao 0x7f106c004c20: create: how=(nil) callback=(nil) poller=0x7f10780ec270  
xc: error: xc\_alloc\_hypercall\_buffer: mmap failed (11 = Resource temporarily unavailabl): Internal error

i cant see any ressource problem on my server.

mfg  
Manfred[/QUOTE]

“11” is EAGAIN, which by looking at mmap’s man page ought to say “EAGAIN The file has been locked, or too much memory has been locked (see setrlimit(2)).”

Does your invoking shell have too restricted ulimits (“ulimit -l”)?

Regards,  
Jens

---

<div class="post-metadata">

**Author:** ![mhuels](https://avatars.discourse-cdn.com/v4/letter/m/7ab992/32.png) [@mhuels](https://forums.suse.com/u/mhuels)\
**Post date:** [February 26, 2015, 3:48pm UTC](https://forums.suse.com/t/unable-to-create-vm/26726/7 "2015-02-26T15:48:33Z")

</div>

server:/var/log/libvirt/libxl # ulimit -l  
64

i guess, it could be a bug like  
[http://lists.opensuse.org/opensuse-bugs/2014-04/msg00259.html](http://lists.opensuse.org/opensuse-bugs/2014-04/msg00259.html)  
because the SLES 12 default installation takes btrfs on all partitions

/dev/sda5 on /var/tmp type btrfs (rw,relatime,space\_cache)  
/dev/sda5 on /var/spool type btrfs (rw,relatime,space\_cache)  
/dev/sda5 on /var/log type btrfs (rw,relatime,space\_cache)  
/dev/sda5 on /tmp type btrfs (rw,relatime,space\_cache)  
/dev/sda5 on /boot/grub2/x86\_64-efi type btrfs (rw,relatime,space\_cache)  
/dev/sda5 on /boot/grub2/i386-pc type btrfs (rw,relatime,space\_cache)

mfg  
Manfred

---

<div class="post-metadata">

**Author:** ![Jens-U](https://avatars.discourse-cdn.com/v4/letter/j/d78d45/32.png) [@Jens-U](https://forums.suse.com/u/Jens-U)\
**Post date:** [February 26, 2015, 4:14pm UTC](https://forums.suse.com/t/unable-to-create-vm/26726/8 "2015-02-26T16:14:49Z")

</div>

Hi Manfred,

[QUOTE=mhuels;26576]server:/var/log/libvirt/libxl # ulimit -l  
64

i guess, it could be a bug like  
[http://lists.opensuse.org/opensuse-bugs/2014-04/msg00259.html](http://lists.opensuse.org/opensuse-bugs/2014-04/msg00259.html)  
because the SLES 12 default installation takes btrfs on all partitions[/QUOTE]

to me it doesn’t look like the same thing.

In your case, the lib is complaining about not having access to sufficient shared memory space. Have you tried setting the limit to “unlimited” or to a much higher value than it currently is? What memory size have you specified for the DomU to be started?

Regards,  
Jens

---

<div class="post-metadata">

**Author:** ![mhuels](https://avatars.discourse-cdn.com/v4/letter/m/7ab992/32.png) [@mhuels](https://forums.suse.com/u/mhuels)\
**Post date:** [February 26, 2015, 6:07pm UTC](https://forums.suse.com/t/unable-to-create-vm/26726/9 "2015-02-26T18:07:45Z")

</div>

Hi Jens  
the problem dont care about Memory of the DomU. My VM, which works until last SLES update, has 4 GByte, but if i try to make a new VM with 1 GByte, the error remains the same.  
I took a look to the configs of libvirt and found no entry to change ulimit for this process.  
My server seems to have a lot of shared memory space

server:~ # ipcs -lm  
------ Shared Memory Limits --------  
max number of segments = 4096  
max seg size (kbytes) = 18014398509481983  
max total shared memory (kbytes) = 18014398509480960  
min seg size (bytes) = 1

The server has no other function than to load the VMs.  
I found no entry to increase the limit shown by ulimit -l

i tried changing  
LIBVIRTD\_NOFILES\_LIMIT=“8192”  
in  
server:/# cat /etc/sysconfig/libvirtd  
but that had no effect.  
mfg  
Manfred

---

<div class="post-metadata">

**Author:** ![Jens-U](https://avatars.discourse-cdn.com/v4/letter/j/d78d45/32.png) [@Jens-U](https://forums.suse.com/u/Jens-U)\
**Post date:** [February 26, 2015, 6:55pm UTC](https://forums.suse.com/t/unable-to-create-vm/26726/10 "2015-02-26T18:55:41Z")

</div>

Hi Manfred,

let me start by telling that I have not yet had to do this via SLES12.

> the problem dont care about Memory of the DomU.

While I can perfectly follow you, especially if one takes into consideration that the 64k ulimit for locked memory seems to be fairly default and the Internet isn’t flooded with such messages, I had a look at the source code patch that introduced this message (it’s from April 2014) and it suggests that you indeed stumbled over such a situation.

Have you opened a service request with SUSE, so that a product engineer can voice a qualified opinion on this?

> I found no entry to increase the limit shown by ulimit -l

As most likely the limit set for “libvirtd” applies, look up the pid of that process and dump the content of /proc//limits… that way you can see what limits actually apply to that process. “ulimit -l” is just for the current session, not system-wide (as are the other limits adjustable via “ulimit”).

Looking at /etc/init.d/libvirtd on an opensuse machine (I don’t have a SLES12 at hand), I can see that during “start” handling the ulimit is already adjusted for the NOFILES limit… you could adopt that to set the locked memory limit, too.

> LIBVIRTD\_NOFILES\_LIMIT=“8192”

Judging by the name of the variable, it will only influence the “number of open files” limit. How it’s handled can be seen in /etc/init.d/libvirtd, at least on on an opensuse machine… my guess is that it’s the same for SLES12 ATM.

Regards,  
Jens

---

<div class="post-metadata">

**Author:** ![mhuels](https://avatars.discourse-cdn.com/v4/letter/m/7ab992/32.png) [@mhuels](https://forums.suse.com/u/mhuels)\
**Post date:** [February 27, 2015, 12:15pm UTC](https://forums.suse.com/t/unable-to-create-vm/26726/11 "2015-02-27T12:15:53Z")

</div>

[QUOTE=jmozdzen;26590]Hi Manfred,

As most likely the limit set for “libvirtd” applies, look up the pid of that process and dump the content of /proc//limits… that way you can see what limits actually apply to that process. “ulimit -l” is just for the current session, not system-wide (as are the other limits adjustable via “ulimit”).

[/QUOTE]

Ok, there is a hard limit of 64k for “max locked memory”

server:/var/tmp # cat /proc/2118/limits  
Limit Soft Limit Hard Limit Units  
Max cpu time unlimited unlimited seconds  
Max file size unlimited unlimited bytes  
Max data size unlimited unlimited bytes  
Max stack size 8388608 unlimited bytes  
Max core file size 0 unlimited bytes  
Max resident set unlimited unlimited bytes  
Max processes 187199 187199 processes  
Max open files 1024 4096 files  
Max locked memory 65536 65536 bytes  
Max address space unlimited unlimited bytes  
Max file locks unlimited unlimited locks  
Max pending signals 187199 187199 signals  
Max msgqueue size 819200 819200 bytes  
Max nice priority 0 0  
Max realtime priority 0 0  
Max realtime timeout unlimited unlimited us

i dont actually know the method to increase this value, but i hope dr. google will help me.

The hard limit is differing to the values on my old SLES 11 Servers. Perhaps i was a bit too fast to adopt the brandnew SLES 12 system. 😉

mfg  
Manfred

---

<div class="post-metadata">

**Author:** ![Jens-U](https://avatars.discourse-cdn.com/v4/letter/j/d78d45/32.png) [@Jens-U](https://forums.suse.com/u/Jens-U)\
**Post date:** [February 27, 2015, 12:42pm UTC](https://forums.suse.com/t/unable-to-create-vm/26726/12 "2015-02-27T12:42:09Z")

</div>

Hi Manfred,

[QUOTE=mhuels;26619]  
i dont actually know the method to increase this value, but i hope dr. google will help me.[/QUOTE]

Does changing it in the libvirtd start script help? And for good debugging measure, you might want to add a successive call to “(date;ulimit -a; echo “”) \>\> /tmp/libvirtd.startup.ulimits.log” to have a log of the actual limits during startup…

Best regards,  
Jens

---

<div class="post-metadata">

**Author:** ![mhuels](https://avatars.discourse-cdn.com/v4/letter/m/7ab992/32.png) [@mhuels](https://forums.suse.com/u/mhuels)\
**Post date:** [February 27, 2015, 1:43pm UTC](https://forums.suse.com/t/unable-to-create-vm/26726/13 "2015-02-27T13:43:08Z")

</div>

ok. SLES 12 is using systemd ;-(

server:/etc/init.d # systemctl show libvirtd.service | grep MEM  
LimitMEMLOCK=65536

server:/etc/init.d # systemctl set-property libvirtd.service LimitMEMLOCK=262144  
Unknown assignment MEMLOCK=262144.

---

<div class="post-metadata">

**Author:** ![mhuels](https://avatars.discourse-cdn.com/v4/letter/m/7ab992/32.png) [@mhuels](https://forums.suse.com/u/mhuels)\
**Post date:** [February 27, 2015, 1:54pm UTC](https://forums.suse.com/t/unable-to-create-vm/26726/14 "2015-02-27T13:54:31Z")

</div>

it needs to edit the file himself with  
server:/etc/init.d # cat /usr/lib/systemd/system/libvirtd.service | grep MEM  
LimitMEMLOCK=262144

and then  
server:/etc/init.d # systemctl kill libvirtd.service  
server:/etc/init.d # systemctl daemon-reload  
server:/etc/init.d # systemctl start libvirtd.service

server:/etc/init.d # systemctl show libvirtd.service | grep Limit  
StartLimitInterval=10000000  
StartLimitBurst=5  
StartLimitAction=none  
MemoryLimit=18446744073709551615  
LimitCPU=18446744073709551615  
LimitFSIZE=18446744073709551615  
LimitDATA=18446744073709551615  
LimitSTACK=18446744073709551615  
LimitCORE=18446744073709551615  
LimitRSS=18446744073709551615  
LimitNOFILE=4096  
LimitAS=18446744073709551615  
LimitNPROC=187199  
LimitMEMLOCK=262144  
 LimitLOCKS=18446744073709551615  
LimitSIGPENDING=187199  
LimitMSGQUEUE=819200  
LimitNICE=0  
LimitRTPRIO=0  
LimitRTTIME=18446744073709551615

but sadly its no use. The error remains.

---

<div class="post-metadata">

**Author:** ![Jens-U](https://avatars.discourse-cdn.com/v4/letter/j/d78d45/32.png) [@Jens-U](https://forums.suse.com/u/Jens-U)\
**Post date:** [February 27, 2015, 1:59pm UTC](https://forums.suse.com/t/unable-to-create-vm/26726/15 "2015-02-27T13:59:33Z")

</div>

Hi Manfred,

> LimitMEMLOCK=262144  
> but sadly its no use. The error remains.

have you tried setting it to “unlimited” or to at least the size of your DomU? From what I can see, the value above is in “bytes” and not megabytes 😉

Regards

---

<div class="post-metadata">

**Author:** ![mhuels](https://avatars.discourse-cdn.com/v4/letter/m/7ab992/32.png) [@mhuels](https://forums.suse.com/u/mhuels)\
**Post date:** [February 27, 2015, 2:15pm UTC](https://forums.suse.com/t/unable-to-create-vm/26726/16 "2015-02-27T14:15:28Z")

</div>

server:/etc/init.d # cat /usr/lib/systemd/system/libvirtd.service

# NB we don’t use socket activation. When libvirtd starts it will

# spawn any virtual machines registered for autostart. We want this

# to occur on every boot, regardless of whether any client connects

# to a socket. Thus socket activation doesn’t have any benefit

[Unit]  
Description=Virtualization daemon  
Before=libvirt-guests.service  
After=network.target  
After=dbus.service  
After=iscsid.service  
After=apparmor.service  
Wants=xencommons.service  
After=xencommons.service  
Documentation=man:libvirtd(8)  
Documentation=[http://libvirt.org](http://libvirt.org)

[Service]  
Type=notify  
EnvironmentFile=-/etc/sysconfig/libvirtd  
ExecStart=/usr/sbin/libvirtd $LIBVIRTD\_ARGS  
ExecReload=/bin/kill -HUP $MAINPID  
KillMode=process  
Restart=on-failure

# Override the maximum number of opened files

#LimitNOFILE=2048

# manni

LimitMEMLOCK=infinity

[Install]  
WantedBy=multi-user.target

server:/etc/init.d # systemctl daemon-reload  
server:/etc/init.d # systemctl kill libvirtd.service  
server:/etc/init.d # systemctl start libvirtd.service  
server:/etc/init.d # systemctl show libvirtd.service | grep Limit  
StartLimitInterval=10000000  
StartLimitBurst=5  
StartLimitAction=none  
MemoryLimit=18446744073709551615  
LimitCPU=18446744073709551615  
LimitFSIZE=18446744073709551615  
LimitDATA=18446744073709551615  
LimitSTACK=18446744073709551615  
LimitCORE=18446744073709551615  
LimitRSS=18446744073709551615  
LimitNOFILE=4096  
LimitAS=18446744073709551615  
LimitNPROC=187199  
LimitMEMLOCK=18446744073709551615  
LimitLOCKS=18446744073709551615  
LimitSIGPENDING=187199  
LimitMSGQUEUE=819200  
LimitNICE=0  
LimitRTPRIO=0  
LimitRTTIME=18446744073709551615  
server:/etc/init.d #

sadly no effect

---

<div class="post-metadata">

**Author:** ![mhuels](https://avatars.discourse-cdn.com/v4/letter/m/7ab992/32.png) [@mhuels](https://forums.suse.com/u/mhuels)\
**Post date:** [February 27, 2015, 2:20pm UTC](https://forums.suse.com/t/unable-to-create-vm/26726/17 "2015-02-27T14:20:13Z")

</div>

same with libvirt-guests.service

server:/etc/init.d # cat /usr/lib/systemd/system/libvirt-guests.service  
[Unit]  
Description=Suspend Active Libvirt Guests  
After=network.target libvirtd.service time-sync.target  
Documentation=man:libvirtd(8)  
Documentation=[http://libvirt.org](http://libvirt.org)

[Service]  
EnvironmentFile=-/etc/sysconfig/libvirt-guests

# Hack just call traditional service until we factor

# out the code

ExecStart=/usr/lib64/libvirt/libvirt-guests.sh start  
ExecStop=/usr/lib64/libvirt/libvirt-guests.sh stop  
Type=oneshot  
RemainAfterExit=yes  
StandardOutput=journal+console

# manni

LimitMEMLOCK=infinity

[Install]  
WantedBy=multi-user.target  
server:/etc/init.d #

---

<div class="post-metadata">

**Author:** ![Jens-U](https://avatars.discourse-cdn.com/v4/letter/j/d78d45/32.png) [@Jens-U](https://forums.suse.com/u/Jens-U)\
**Post date:** [February 27, 2015, 2:53pm UTC](https://forums.suse.com/t/unable-to-create-vm/26726/18 "2015-02-27T14:53:44Z")

</div>

Hi Manfred,

> sadly no effect

```
			my recommendation is to open a service request - this is something that SUSE engineers ought to help you with, and will do much better than I can.

```

In case this turns out to be something simple (although I truly doubt it), please let us know…

Regards,  
Jens

---

<div class="post-metadata">

**Author:** ![mhuels](https://avatars.discourse-cdn.com/v4/letter/m/7ab992/32.png) [@mhuels](https://forums.suse.com/u/mhuels)\
**Post date:** [February 27, 2015, 6:07pm UTC](https://forums.suse.com/t/unable-to-create-vm/26726/19 "2015-02-27T18:07:44Z")

</div>

unfortunately we only have a basic support on Suse/Novell. So there is no support. I will try some ideas next week and will report success (if there is any).  
mfg  
Manfred

---

<div class="post-metadata">

**Author:** ![carnold6](https://avatars.discourse-cdn.com/v4/letter/c/3bc359/32.png) [@carnold6](https://forums.suse.com/u/carnold6)\
**Post date:** [March 1, 2015, 4:35am UTC](https://forums.suse.com/t/unable-to-create-vm/26726/20 "2015-03-01T04:35:55Z")

</div>

[QUOTE=jmozdzen;26572]Hi carnold6,

> Not even sure where the corresponding log file

my best guess would be the /var/log/xen directory, with individual log files per VM (only created when the ComU start was successful), xend.log for the management daemon and probably a separate log file for DomU configuration.

> What do you need to install in order to get a VM working? Xen and KVM or just one of those?

```
            On SLES11 I know you'll only need Xen installed, not KVM. For SLES12, I have no practical experience, so I cannot tell if that has changed... but I'd call any requirement to manually add "kvm" to the list (in order to be able to create Xen DomUs) a dependency problem worth reporting ;)

```

PS: Judging from Manfreds reply, /var/log/libvirt seems to be an additional / alternate location for related log files.[/QUOTE]

So, on a completely different SLES 12 install, the exact same thing happens when creating a VM. Here is the log:

libxl: debug: libxl\_create.c:1362:do\_domain\_create: ao 0x7f91b001a0f0: create: how=(nil) callback=(nil) poller=0x7f91b0012b50  
xc: error: xc\_alloc\_hypercall\_buffer: mmap failed (11 = Resource temporarily unavailabl): Internal error  
libxl: error: libxl.c:570:libxl\_list\_domain: geting domain info list: Resource temporarily unavailable  
libxl: error: libxl.c:314:libxl\_\_domain\_rename: unexpected errorchecking for existing domain  
libxl: error: libxl\_create.c:762:initiate\_domain\_create: cannot make domain: -5  
libxl: error: libxl\_dm.c:1494:kill\_device\_model: unable to find device model pid in /local/domain/1/image/device-model-pid  
libxl: error: libxl.c:1507:libxl\_\_destroy\_domid: libxl\_\_destroy\_device\_model failed for 1  
libxl: debug: libxl\_event.c:1591:libxl\_\_ao\_complete: ao 0x7f91b001a0f0: complete, rc=-3  
libxl: debug: libxl\_create.c:1376:do\_domain\_create: ao 0x7f91b001a0f0: inprogress: poller=0x7f91b0012b50, flags=ic  
libxl: debug: libxl\_event.c:1563:libxl\_\_ao\_\_destroy: ao 0x7f91b001a0f0: destroy  
xc: debug: hypercall buffer: total allocations:34 total releases:33  
xc: debug: hypercall buffer: current allocations:1 maximum allocations:3  
xc: debug: hypercall buffer: cache current size:2  
xc: debug: hypercall buffer: cache hits:31 misses:2 toobig:1

This is only with Xen and Xen tools installed (no KVM)

[Next page](https://forums.suse.com/t/unable-to-create-vm/26726.md?page=2)
