# Unable to set openstack cloud provider

**URL:** <https://forums.suse.com/t/unable-to-set-openstack-cloud-provider/10977>\
**Category:** SUSE Rancher Prime\
**Created:** [July 2, 2018, 10:10am UTC](https://forums.suse.com/t/unable-to-set-openstack-cloud-provider/10977 "2018-07-02T10:10:44Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Alexey\_Maximov](https://avatars.discourse-cdn.com/v4/letter/a/b2d939/32.png) [@Alexey\_Maximov](https://forums.suse.com/u/Alexey_Maximov)\
**Post date:** [July 2, 2018, 10:10am UTC](https://forums.suse.com/t/unable-to-set-openstack-cloud-provider/10977/1 "2018-07-02T10:10:44Z")

</div>

Hi!

I am trying to configure Openstack cloud provider in Rancher 2.0, here is a very basic config:

`cloud_provider: name: "openstack" openstack_cloud_provider: block_storage: ignore-volume-az: false trust-device-path: false global: auth-url: " ***" domain-id: "***" password: " ***" region: "***" tenant-id: " ***" username: "***" load_balancer: create-monitor: false manage-security-groups: false monitor-delay: 0 monitor-max-retries: 0 monitor-timeout: 0 use-octavia: false metadata: request-timeout: 0`  
And I get the following error while provisioning:

```
This cluster is currently Updating.
[workerPlane] Failed to bring up Worker Plane: Failed to verify healthcheck: Failed to check https://localhost:10250/healthz for service [kubelet] on host [192.168.100.11]: Get https://localhost:10250/healthz: dial tcp 127.0.0.1:10250: getsockopt: connection refused, log: F0702 10:00:15.873314 7338 server.go:233] failed to run Kubelet: could not init cloud provider "openstack": 1:8: illegal character U+002C ','

```

Any ideas how to debug and fix this issue will be very helpful! There are no commas in config at all.

PS: This warning confused me because I didn’t find any prerequisites in documentation. Not sure but maybe this is the root cause  
`Configuring a Cloud Provider in your cluster without configuring the prerequisites will cause your cluster to not provision correctly. Prerequisites needed for supported cloud providers can be found in the documentation.`

Thanks,  
Alexey

---

<div class="post-metadata">

**Author:** ![Alexey\_Maximov](https://avatars.discourse-cdn.com/v4/letter/a/b2d939/32.png) [@Alexey\_Maximov](https://forums.suse.com/u/Alexey_Maximov)\
**Post date:** [July 2, 2018, 2:30pm UTC](https://forums.suse.com/t/unable-to-set-openstack-cloud-provider/10977/2 "2018-07-02T14:30:32Z")

</div>

Automatically generated /etc/kubernetes/cloud-config looks like:

```
[Global,omitempty]
auth-url,omitempty = ***
username,omitempty = ***
user-id,omitempty =
password,omitempty = ***
tenant-id,omitempty = ***
tenant-name,omitempty =
trust-id,omitempty =
domain-id,omitempty = *****
domain-name,omitempty =
region,omitempty =
ca-file,omitempty =

[LoadBalancer,omitempty]
lb-version,omitempty =
use-octavia,omitempty = false
subnet-id,omitempty =
floating-network-id,omitempty =
lb-method,omitempty =
lb-provider,omitempty =
create-monitor,omitempty = false
monitor-delay,omitempty = 0
monitor-timeout,omitempty = 0
monitor-max-retries,omitempty = 0
manage-security-groups,omitempty = false

[BlockStorage,omitempty]
bs-version,omitempty =
trust-device-path,omitempty = false
ignore-volume-az,omitempty = false

[Route,omitempty]
router-id,omitempty =

[Metadata,omitempty]
search-order,omitempty =
request-timeout,omitempty = 0

```

Not sure about “,omitempty”. At least after I removed it from config, I got another “Authentification error”.
