# vCenter clould provider error while creating cluster

**URL:** <https://forums.suse.com/t/vcenter-clould-provider-error-while-creating-cluster/19831>\
**Category:** SUSE Rancher Prime\
**Created:** [March 17, 2021, 12:04am UTC](https://forums.suse.com/t/vcenter-clould-provider-error-while-creating-cluster/19831 "2021-03-17T00:04:07Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![biancoda](https://avatars.discourse-cdn.com/v4/letter/b/5e9695/32.png) [@biancoda](https://forums.suse.com/u/biancoda)\
**Post date:** [March 17, 2021, 12:04am UTC](https://forums.suse.com/t/vcenter-clould-provider-error-while-creating-cluster/19831/1 "2021-03-17T00:04:07Z")

</div>

I’m trying to set up the vCenter cloud provider on the rancher yaml file, but I’m getting the following error:

`2021/03/16 23:54:03 [ERROR] cluster [c-xsdtq] provisioning: [workerPlane] Failed to bring up Worker Plane: [Failed to verify healthcheck: Failed to check http://localhost:10248/healthz for service [kubelet] on host [10.87.44.92]: Get "http://localhost:10248/healthz": dial tcp 127.0.0.1:10248: connect: connection refused, log: F0316 23:53:48.890674 25934 server.go:274] failed to run Kubelet: could not init cloud provider "vsphere": 10:28: unknown escape sequence]`

I have been reading that this error could be related to having dashes on some of the variables

> <https://github.com/rancher/rancher/issues/16371>
>
> What kind of request is this (question/bug/enhancement/feature request): bug
> Steps to reproduce (least amount of steps as possible):
> Begin creating a vSphere new...

Although, my username doesn’t have any dashed, but my vcenter password contains \*.  
This is my cloud\_provider code/configuration:

```
  cloud_provider:
    name: vsphere
    vsphereCloudProvider:
      virtual_center:
        vcenter_url:
          user: <domain>\<user>
          password: <pass>
          port: 443
          datacenters: /Datacenter
      workspace:
        server: vcenter_url
        folder: Kubernetes
        default-datastore: /Datacenter/Stage/ClusterStage/ClusterStage_DATA06
        datacenter: /Datacenter
        resourcepool-path: /Datacenter/Kubernetes

```

Any suggestion will be appreciated.

---

<div class="post-metadata">

**Author:** ![biancoda](https://avatars.discourse-cdn.com/v4/letter/b/5e9695/32.png) [@biancoda](https://forums.suse.com/u/biancoda)\
**Post date:** [March 22, 2021, 1:53pm UTC](https://forums.suse.com/t/vcenter-clould-provider-error-while-creating-cluster/19831/2 "2021-03-22T13:53:46Z")

</div>

The problem was related with the user.  
Instead of using \< domain \>\< user \>, I used \< user \>@\< domain \>.com
