# virt-install errors when running as regular user

**URL:** https://forums.suse.com/t/virt-install-errors-when-running-as-regular-user/28159
**Category:** SLES Virtualization
**Created:** [May 12, 2016, 3:46am UTC](https://forums.suse.com/t/virt-install-errors-when-running-as-regular-user/28159 "2016-05-12T03:46:28Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![savithari](https://avatars.discourse-cdn.com/v4/letter/s/35a633/32.png) [@savithari](https://forums.suse.com/u/savithari)
#### Post date: [May 12, 2016, 3:46am UTC](https://forums.suse.com/t/virt-install-errors-when-running-as-regular-user/28159/1 "2016-05-12T03:46:28Z")

</div>

Friends:

I need some help and guidance from you regarding this virt-install issue I am seeing.

`OS : SuseEnterpriseLinuxServer (SLES) 12 Service Pack 1
virt-install version on the box
virtual@SLES12-bare:~> virt-install --version
1.2.1
libvirt version : libvirt-1.3.4-565.1.x86_64
`

What I tried:

I tried to start virt-install as regular user and I am seeing errors listed below.

If I start the same with sudo it works (the user virtual shown here is a sudo enabled user)

I really want to start the virt-install as a regular user.

Please help.

Error

[QUOTE]virtual@SLES12-bare:~\> virt-install --connect qemu:///session -n SLES12\_SP1 --memory 4096 --vcpus 2 --cdrom /data/ADP\_x86\_64\_SLES12SP1.x86\_64-12.1.6.preload.iso --graphics spice --disk /data/kvm\_images/SLES12\_SP1.img  
WARNING Graphics requested but DISPLAY is not set. Not running virt-viewer.  
WARNING No console to launch for the guest, defaulting to --wait -1

Starting install…  
ERROR Failed to connect socket to ‘/run/user/500/libvirt/virtlogd-sock’: No such file or directory  
Domain installation does not appear to have been successful.  
If it was, you can restart your domain by running:  
virsh --connect qemu:///session start SLES12\_SP1  
otherwise, please restart your installation.  
[/QUOTE]

Thank You for your time and attention.  
-Narahari

---

<div class="post-metadata">

### Author: ![malcolmlewis](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/malcolmlewis/32/11375_2.png) [@malcolmlewis](https://forums.suse.com/u/malcolmlewis)
#### Post date: [May 12, 2016, 4:15am UTC](https://forums.suse.com/t/virt-install-errors-when-running-as-regular-user/28159/2 "2016-05-12T04:15:13Z")

</div>

Hi  
You need to create a user session first…

```auto
virt-manager --connect qemu:///session
```

This should then add a user session to run/create vm’s (files would be down in ~/.local/libvirt) I use softlinks to my vm storage device pool.

Then I use for example;

```auto
virt-install --connect qemu:///session -n SLES12_SP1 --memory 4096 --vcpus 2 --cdrom /repositories/iso_images/SLE-12-SP1-Server-DVD-x86_64-GM-DVD1.iso --graphics spice --disk ~/.local/libvirt/images/sled12sp1.qcow2
```

This all assumes you have the libvirtd service started…

---

<div class="post-metadata">

### Author: ![savithari](https://avatars.discourse-cdn.com/v4/letter/s/35a633/32.png) [@savithari](https://forums.suse.com/u/savithari)
#### Post date: [May 12, 2016, 7:30pm UTC](https://forums.suse.com/t/virt-install-errors-when-running-as-regular-user/28159/3 "2016-05-12T19:30:03Z")

</div>

Thank you for your answer Malcomlewis.

I can’t run virt-manager for two reason.

1. I don’t have X on the machine, so I will have to run it remotely or ‘X’ it back and I don’t have a machine for that.
2. virt-manager is not a requirement is my understanding to running virt-install.

But you do bring up a valid point and may be I need to do a virus connect and try.

I will try that.

Thank You  
-Narahari

---

<div class="post-metadata">

### Author: ![malcolmlewis](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/malcolmlewis/32/11375_2.png) [@malcolmlewis](https://forums.suse.com/u/malcolmlewis)
#### Post date: [May 13, 2016, 12:25am UTC](https://forums.suse.com/t/virt-install-errors-when-running-as-regular-user/28159/4 "2016-05-13T00:25:53Z")

</div>

Hi  
Ahh ok, then run;

```auto
virsh --connect qemu:///session
```

AFAIK, once you have a session created all should be good as your user.

See: [http://virt-tools.org/learning/install-with-command-line/](http://virt-tools.org/learning/install-with-command-line/)
