# Websocket error without Reverse Proxy

**URL:** <https://forums.suse.com/t/websocket-error-without-reverse-proxy/11997>\
**Category:** SUSE Rancher Prime\
**Created:** [October 11, 2018, 7:45am UTC](https://forums.suse.com/t/websocket-error-without-reverse-proxy/11997 "2018-10-11T07:45:10Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![checkelmann](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/checkelmann/32/4524_2.png) [@checkelmann](https://forums.suse.com/u/checkelmann)\
**Post date:** [October 11, 2018, 7:45am UTC](https://forums.suse.com/t/websocket-error-without-reverse-proxy/11997/1 "2018-10-11T07:45:10Z")

</div>

Hi @All,

we are using Rancher 2.1 (upgraded from 2.0.5) and we are facing a strange problem. Rancher was running and I was able to install some clusters. All of the sudden I’m getting a websocket error in the UI (the console output: 0:259281 WebSocket connection to ‘wss://rancher.xyz.com/v3/subscribe?sockId=1’ failed: Error during WebSocket handshake: Unexpected response code: 400  
connect @ 0:259281)

So I was searching the GitHub Issues and this Forum but all similar issues are always based on errors with reverse proxy implementations like nginx.

We have a very basic setup

- CentOS 7
- Docker 18.06.1-ce
- Running in a Single Node Installation
- latest rachner docker image
- no reverse Proxy in between
- Exposed the ports 80 and 443

Rancher is using a wildcard certificate (openssl s\_client -connect [rancher.xyz.com:443](http://rancher.xyz.com:443) is fine, all Intermediate and root certificates are valid)

As I said, it was working all the time, but suddenly the error occurred.

When I was checking the Rancher Logs from the Container I’m getting this error:

```
2018/10/11 07:23:02 [INFO] error in remotedialer server [400]: websocket: close 1006 unexpected EOF
2018/10/11 07:23:05 [INFO] error in remotedialer server [400]: websocket: close 1006 unexpected EOF
2018/10/11 07:23:05 [INFO] error in remotedialer server [400]: websocket: close 1006 unexpected EOF
2018/10/11 07:23:05 [INFO] error in remotedialer server [400]: websocket: close 1006 unexpected EOF
2018/10/11 07:23:34 [ERROR] Error during subscribe websocket: could not find connection header with token 'upgrade'
2018/10/11 07:23:34 [ERROR] Unknown error: websocket: could not find connection header with token 'upgrade'
2018/10/11 07:23:34 [INFO] 2018/10/11 07:23:34 http: multiple response.WriteHeader calls

```

So I said to myself OK so I don’t have automatic refresh in the UI and tried to deploy another K8S cluster, but this is not possible anymore

```
time="2018-10-11T05:10:54Z" level=info msg="Connecting to proxy" url="wss://rancher.xyz.com/v3/connect/register"
time="2018-10-11T05:10:54Z" level=error msg="Failed to connect to proxy" error="websocket: bad handshake"
time="2018-10-11T05:10:54Z" level=error msg="Failed to connect to proxy" error="websocket: bad handshake"
time="2018-10-11T05:11:04Z" level=info msg="Connecting to wss://rancher.xyz.com/v3/connect/register with token wrzhwz9rg9chghhrx2ghn7sj6zzqbhxf6rwhj9gzx848mkvjgb5pr2"

```

The existing two clusters don’t have any issues.

Is anyone facing the same problems? I tried all Certificate/CA Cert combos, upgraded rancher from 2.0.5 to 2.1, upgraded docker on the host but still have the errors.

I would appreciate any help on this cause I’m running out of Ideas.

Regards,

Christian
