# Which Hypervisor

**URL:** <https://forums.suse.com/t/which-hypervisor/26743>\
**Category:** SLES Virtualization\
**Created:** [February 28, 2015, 3:41am UTC](https://forums.suse.com/t/which-hypervisor/26743 "2015-02-28T03:41:09Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![carnold6](https://avatars.discourse-cdn.com/v4/letter/c/3bc359/32.png) [@carnold6](https://forums.suse.com/u/carnold6)\
**Post date:** [February 28, 2015, 3:41am UTC](https://forums.suse.com/t/which-hypervisor/26743/1 "2015-02-28T03:41:09Z")

</div>

SLES12. On a test box i installed Xen then tried to create a VM but would get:

Unable to complete install: ‘internal error: libxenlight failed to create new domain ‘2012r2lab’’

Traceback (most recent call last):  
File “/usr/share/virt-manager/virtManager/asyncjob.py”, line 91, in cb\_wrapper  
callback(asyncjob, \*args, \*\*kwargs)  
File “/usr/share/virt-manager/virtManager/create.py”, line 1908, in do\_install  
guest.start\_install(meter=meter)  
File “/usr/share/virt-manager/virtinst/guest.py”, line 426, in start\_install  
noboot)  
File “/usr/share/virt-manager/virtinst/guest.py”, line 490, in \_create\_guest  
dom = self.conn.createLinux(start\_xml or final\_xml, 0)  
File “/usr/lib64/python2.7/site-packages/libvirt.py”, line 3297, in createLinux  
if ret is None:raise libvirtError(‘virDomainCreateLinux() failed’, conn=self)  
libvirtError: internal error: libxenlight failed to create new domain ‘2012r2lab’

I installed KVM and rebooted the server. Then and only then was i able to create a VM.

So my question is 2 fold:  
Which hypervisor to install? and  
Do you need to install anything else when you first run the yast applet install hypervisor and tools?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/flex022/uploads/suse/original/2X/5/5012ba89e3ffb5220dac47d5ea0ba032e2fe1cb6.png) [@system](https://forums.suse.com/u/system)\
**Post date:** [March 5, 2015, 3:30pm UTC](https://forums.suse.com/t/which-hypervisor/26743/2 "2015-03-05T15:30:31Z")

</div>

carnold6,

It appears that in the past few days you have not received a response to your  
posting. That concerns us, and has triggered this automated reply.

Has your issue been resolved? If not, you might try one of the following options:

- Visit [http://www.suse.com/support](http://www.suse.com/support) and search the knowledgebase and/or check all  
the other support options available.
- You could also try posting your message again. Make sure it is posted in the  
correct newsgroup. ([http://forums.suse.com](http://forums.suse.com))

Be sure to read the forum FAQ about what to expect in the way of responses:  
[http://forums.suse.com/faq.php](http://forums.suse.com/faq.php)

If this is a reply to a duplicate posting, please ignore and accept our apologies  
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your SUSE Forums Team  
[http://forums.suse.com](http://forums.suse.com)

---

<div class="post-metadata">

**Author:** ![Willem1](https://avatars.discourse-cdn.com/v4/letter/w/c57346/32.png) [@Willem1](https://forums.suse.com/u/Willem1)\
**Post date:** [March 8, 2015, 8:26pm UTC](https://forums.suse.com/t/which-hypervisor/26743/3 "2015-03-08T20:26:51Z")

</div>

[QUOTE=carnold6;26654]SLES12. On a test box i installed Xen then tried to create a VM but would get:

Unable to complete install: ‘internal error: libxenlight failed to create new domain ‘2012r2lab’’[/QUOTE]

The error you posted is different, but you might probably have been hitting a bug where apparmor is preventing Xen from creating a VM.  
You could try disabling apparmor and then retry creating a VM in Xen. For more info see TID 7016245: [https://www.suse.com/support/kb/doc.php?id=7016245](https://www.suse.com/support/kb/doc.php?id=7016245)

[QUOTE=carnold6;26654]So my question is 2 fold:  
Which hypervisor to install? and  
Do you need to install anything else when you first run the yast applet install hypervisor and tools?[/QUOTE]

Both Xen and KVM are good choices. I personally mostly use Xen when running a Linux hypervisor, but that is more because I have been doing so for many years. Performance wise Xen was much faster than KVM, but with the advances made the last years, KVM should perform just as well (there are differences depending on use case). The feature set is similar.

One nice thing about KVM is that it uses the default kernel and does not need a separate built kernel as is the case with Xen.

Cheers,  
Willem

---

<div class="post-metadata">

**Author:** ![Jens-U](https://avatars.discourse-cdn.com/v4/letter/j/d78d45/32.png) [@Jens-U](https://forums.suse.com/u/Jens-U)\
**Post date:** [March 18, 2015, 2:06pm UTC](https://forums.suse.com/t/which-hypervisor/26743/4 "2015-03-18T14:06:38Z")

</div>

Hi carnold6,

this does look like a duplicate of [https://forums.suse.com/showthread.php?6023-Unable-to-Create-VM](https://forums.suse.com/showthread.php?6023-Unable-to-Create-VM) ?

> So my question is 2 fold:  
> Which hypervisor to install? and  
> Do you need to install anything else when you first run the yast applet install hypervisor and tools

as Willem already pointed out, there’s the apparmor problem that was identified in the referenced thread, and a fix is in the works. I’m unable to test myself, but maybe installing KVM “fixes” the libvirtd apparmor profile, making things work. But once the patch is in the repositories, there will be no need to either deactivate apparmor nor installing KVM to get Xen up &running 🙂

Concerning KVM vs. Xen, Willem already said it all 🙂

Regards,  
Jens

---

<div class="post-metadata">

**Author:** ![Phil\_H](https://avatars.discourse-cdn.com/v4/letter/p/5f9b8f/32.png) [@Phil\_H](https://forums.suse.com/u/Phil_H)\
**Post date:** [August 14, 2015, 12:41pm UTC](https://forums.suse.com/t/which-hypervisor/26743/5 "2015-08-14T12:41:10Z")

</div>

Hi guys,

I will start a new project. So I have 3 CNC machines. This CNC machines should have access to their files over a network share.  
They can only access the old hpfs filesystem of OS/2.

So I tought the best possibility to run the OS/2 is in a virtual Machine. I will use XenServer for virtualization.  
Now I heard for using the Xen-Hypervisor INTEL VT-x is requiered.

Maybe there is a posibility to use Xenserver paravirtualized with Opensuse.

I have some old Intel server hardware. So what do I have to regard for running Xenserver on this old Systems?

Kind regards,  
Phil

---

<div class="post-metadata">

**Author:** ![Jens-U](https://avatars.discourse-cdn.com/v4/letter/j/d78d45/32.png) [@Jens-U](https://forums.suse.com/u/Jens-U)\
**Post date:** [August 17, 2015, 6:08pm UTC](https://forums.suse.com/t/which-hypervisor/26743/6 "2015-08-17T18:08:16Z")

</div>

Hi Phil,

> I will start a new project. So I have 3 CNC machines. […]

this may be considered “thread hijacking” - if possible you should open a new, separate thread for new issues 😉

> Maybe there is a posibility to use Xenserver paravirtualized with Opensuse.  
> I have some old Intel server hardware. So what do I have to regard for running Xenserver on this old Systems?

Whether your hardware supports the selected hypervisor, depends on the hypervisor… but most likely it will require VT-x, yes. But which Hypervisor do you want to use (see below)?

There are some ambiguities here:

- are you looking at running XenServer as a guest to Opensuse? This will likely not work, XenServer is designed to run on the native hardware

- or are you looking at running XenServer on your hardware, then OS/2 and openSUSE as guests?

- Are you actually looking for running XenServer, or “Xen” (the open source version available via SLES and openSUSE)?

- If you’re looking at openSUSE (i.e. as a base OS to run Xen and then to put OS/2 in a DomU), please note that these forums are for supporting SUSE Linux Enterprise Server (SLES) - you’ll find the openSUSE forums over at [https://forums.opensuse.org](https://forums.opensuse.org) (you can use the same login credentials as here, no need for a new account)

Regards,  
Jens
