# Working with SDB...

**URL:** https://forums.suse.com/t/working-with-sdb/26940
**Category:** SLES High Availability Extension
**Created:** [April 15, 2015, 1:46pm UTC](https://forums.suse.com/t/working-with-sdb/26940 "2015-04-15T13:46:26Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![ddgaikwad](https://avatars.discourse-cdn.com/v4/letter/d/d07c76/32.png) [@ddgaikwad](https://forums.suse.com/u/ddgaikwad)
#### Post date: [April 15, 2015, 1:46pm UTC](https://forums.suse.com/t/working-with-sdb/26940/1 "2015-04-15T13:46:26Z")

</div>

Hi There!

I am trying to setup cluster for Sentinel servers using this document here: [https://www.netiq.com/documentation/sentinel72/s721\_install/data/b13k8oh7.html](https://www.netiq.com/documentation/sentinel72/s721_install/data/b13k8oh7.html)

I am using a single iSCSI exposed target, where in I have created two partitions, one of 40 GB and another of 10 MB, which would be SDB.  
The cluster configuration goes just fine, but, when I try to add the other node to the cluster using sleha-join, I get the error, failed to probe new partitions.

The question that I have is that, is the process that I am following right?  
Or is there any specific method which I need to follow in order to have a SDB on the same exposed drive as a separate partition…

Please assist.  
Thank you!

---

<div class="post-metadata">

### Author: ![ab1](https://avatars.discourse-cdn.com/v4/letter/a/d2c977/32.png) [@ab1](https://forums.suse.com/u/ab1)
#### Post date: [April 15, 2015, 2:36pm UTC](https://forums.suse.com/t/working-with-sdb/26940/2 "2015-04-15T14:36:34Z")

</div>

I would probably stick with giving SBD its own device, and not just a  
partition on a device. I’ve never seen an example providing a way to just  
use partitions, but considering SBD’s purpose having it on a shared device  
seems like the wrong approach.

–  
Good luck.

If you find this post helpful and are logged into the web interface,  
show your appreciation and click on the star below…

---

<div class="post-metadata">

### Author: ![ddgaikwad](https://avatars.discourse-cdn.com/v4/letter/d/d07c76/32.png) [@ddgaikwad](https://forums.suse.com/u/ddgaikwad)
#### Post date: [April 15, 2015, 3:35pm UTC](https://forums.suse.com/t/working-with-sdb/26940/3 "2015-04-15T15:35:44Z")

</div>

So, that is why I am getting this, error, “Probing for new partitions…WARNING: Failed to probe new partitions” when I running sleha-join on the second node.  
Here is the complete output:  
[FONT=Courier New]SenHA02:~ # sleha-join  
WARNING: NTP is not configured to start at system boot.  
Do you want to continue anyway? [y/N] y

Join This Node to Cluster:  
You will be asked for the IP address of an existing node, from which  
configuration will be copied. If you have not already configured  
passwordless ssh between nodes, you will be prompted for the root  
password of the existing node.

IP address or hostname of existing node (e.g.: 192.168.1.1) [] 2.2.2.202  
Enabling sshd service  
Retrieving SSH keys from 2.2.2.202  
Password:  
Configuring csync2  
Enabling csync2 service  
Enabling xinetd service  
Merging known\_hosts  
Probing for new partitions…WARNING: Failed to probe new partitions  
done  
Enabling hawk service  
HA Web Konsole is now running, to see cluster status go to:  
[https://2.2.2.203:7630/](https://2.2.2.203:7630/)  
Log in with username ‘hacluster’, password ‘linux’  
WARNING: You should change the hacluster password to something more secure!  
Enabling openais service  
ERROR: Failed to start openais service[/FONT]

So, that means, its not supported to have sdb on the same disk as a separate partition…?  
Right…?

---

<div class="post-metadata">

### Author: ![Jens-U](https://avatars.discourse-cdn.com/v4/letter/j/d78d45/32.png) [@Jens-U](https://forums.suse.com/u/Jens-U)
#### Post date: [April 17, 2015, 1:42pm UTC](https://forums.suse.com/t/working-with-sdb/26940/4 "2015-04-17T13:42:48Z")

</div>

Hi ddgaikwad,

[QUOTE=ddgaikwad;27482]So, that is why I am getting this, error, “Probing for new partitions…WARNING: Failed to probe new partitions” when I running sleha-join on the second node.  
[…]  
So, that means, its not supported to have sdb on the same disk as a separate partition…?  
Right…?[/QUOTE]

in our current setup, we have SDB running on a partition of a shared device:

[CODE]xen101:/usr/lib64/stonith/plugins/external # cat /etc/sysconfig/sbd  
SBD\_DEVICE="/dev/disk/by-id/scsi-1SCST\_FIOe714a0bc-xenserver-lun0-part1"  
SBD\_OPTS="-W"  
xen101:/usr/lib64/stonith/plugins/external # fdisk -l /dev/disk/by-id/scsi-1SCST\_FIOe714a0bc-xenserver-lun0

Disk /dev/disk/by-id/scsi-1SCST\_FIOe714a0bc-xenserver-lun0: 742 MB, 742694912 bytes  
23 heads, 62 sectors/track, 1017 cylinders, total 1450576 sectors  
Units = sectors of 1 \* 512 = 512 bytes  
Sector size (logical/physical): 512 bytes / 4096 bytes  
I/O size (minimum/optimal): 4096 bytes / 524288 bytes  
Disk identifier: 0xc792c14e

```
                                             Device Boot Start End Blocks Id System

```

/dev/disk/by-id/scsi-1SCST\_FIOe714a0bc-xenserver-lun0-part1 2048 10239 4096 83 Linux  
/dev/disk/by-id/scsi-1SCST\_FIOe714a0bc-xenserver-lun0-part2 10240 215039 102400 83 Linux  
xen101:/usr/lib64/stonith/plugins/external #[/CODE]

and we were using “[FONT=Courier New]sleha-join” to join the second node.

Have you made sure the device/partition you have configured on your first node, is available under the exact same name on the second node?

Regards,  
Jens  
[/FONT]
