# YaST2 (Apache2 error: cannot adjust Apache2 service) at 50%

**URL:** <https://forums.suse.com/t/yast2-apache2-error-cannot-adjust-apache2-service-at-50/24495>\
**Category:** SLES Configure-Administer\
**Created:** [September 14, 2013, 8:10am UTC](https://forums.suse.com/t/yast2-apache2-error-cannot-adjust-apache2-service-at-50/24495 "2013-09-14T08:10:13Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![tarzy](https://avatars.discourse-cdn.com/v4/letter/t/f04885/32.png) [@tarzy](https://forums.suse.com/u/tarzy)\
**Post date:** [September 14, 2013, 8:10am UTC](https://forums.suse.com/t/yast2-apache2-error-cannot-adjust-apache2-service-at-50/24495/1 "2013-09-14T08:10:13Z")

</div>

I’ll surmise in advance that I’m in for some serious reading; but acknowledge that I’m always looking for a quicker way out due to a redundant Dyslexia issue that cropped up half a dozen years back.

I am not sure I like the YaST controll of all the things it does, but I’ll reserve judgement for a bit later.

So, using YaST Control Center, I got into looking at the modules, and using what I believed to be common sense, started tinkering with enabling a few modules and then encountered this error while YaST was writing/“adjusting” the config: “Cannot adjust Apache2 Service”. I went to the extent of disabling all of the modules (not keeping any notes) and nothing I tried would stop this error.

What I initially was looking for in YaST was MySQL, which I know I installed once I fixed my initial Networking Problem. Like a Kid in a Sandbox, I got sidetracked, and here I am!

The beauty of this is that I have my 2 domain’s vhosts on my old Fedora 9 rig, which I can examine some items without Danger, and hopefully learn a few things.

Anyhow, while I’m reading in the next few days, if I’ve posted in the correct spot and anyone has any tips, I’ll be happy to have them. Any YaST ones too.

Regards, tarzy…

---

<div class="post-metadata">

**Author:** ![malcolmlewis](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/malcolmlewis/32/11375_2.png) [@malcolmlewis](https://forums.suse.com/u/malcolmlewis)\
**Post date:** [September 14, 2013, 8:21am UTC](https://forums.suse.com/t/yast2-apache2-error-cannot-adjust-apache2-service-at-50/24495/2 "2013-09-14T08:21:51Z")

</div>

Hi  
What version of SLES are you running? If your not to far down the track, you can always force the re-install of Apache2? This should reset everything and the configs.

---

<div class="post-metadata">

**Author:** ![tarzy](https://avatars.discourse-cdn.com/v4/letter/t/f04885/32.png) [@tarzy](https://forums.suse.com/u/tarzy)\
**Post date:** [September 14, 2013, 9:40am UTC](https://forums.suse.com/t/yast2-apache2-error-cannot-adjust-apache2-service-at-50/24495/3 "2013-09-14T09:40:23Z")

</div>

[QUOTE=malcolmlewis;16257]Hi  
What version of SLES are you running? If your not to far down the track, you can always force the re-install of Apache2? This should reset everything and the configs.[/QUOTE]

SLES 11 SP3. I’ll try that, but will need to find out how as I’m a “goofy GUI Guy”. I’ll Google it.

---

<div class="post-metadata">

**Author:** ![malcolmlewis](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/malcolmlewis/32/11375_2.png) [@malcolmlewis](https://forums.suse.com/u/malcolmlewis)\
**Post date:** [September 14, 2013, 2:55pm UTC](https://forums.suse.com/t/yast2-apache2-error-cannot-adjust-apache2-service-at-50/24495/4 "2013-09-14T14:55:17Z")

</div>

> [@](#):
>
> On Sat 14 Sep 2013 06:44:02 AM CDT, tarzy wrote:
> 
> malcolmlewis;16257 Wrote:[color=blue]
> 
> > Hi  
> > What version of SLES are you running? If your not to far down the  
> > track, you can always force the re-install of Apache2? This should  
> > reset everything and the configs.[/color]
> 
> SLES 11 SP3. I’ll try that, but will need to find out how as I’m a  
> “goofy GUI Guy”. I’ll Google it.

Hi  
Probably easier from the command line with zypper…

```auto
zypper in -f <some_package> <some_package2> <etc>
```

In your case it will be apache…

You can find out the installed packages with the search feature of  
zypper;

```auto
zypper se -i apache
```

This will search for packages with apache in there name and the -i  
means it will only show installed ones.

–  
Cheers Malcolm Â°Â¿Â° SUSE Knowledge Partner (Linux Counter #276890)  
openSUSE 12.3 (x86\_64) GNOME 3.8.4 Kernel 3.7.10-1.16-desktop  
If you find this post helpful and are logged into the web interface,  
please show your appreciation and click on the star below… Thanks!

---

<div class="post-metadata">

**Author:** ![tarzy](https://avatars.discourse-cdn.com/v4/letter/t/f04885/32.png) [@tarzy](https://forums.suse.com/u/tarzy)\
**Post date:** [September 15, 2013, 9:56am UTC](https://forums.suse.com/t/yast2-apache2-error-cannot-adjust-apache2-service-at-50/24495/5 "2013-09-15T09:56:37Z")

</div>

[QUOTE=tarzy;16258]SLES 11 SP3. I’ll try that, but will need to find out how as I’m a “goofy GUI Guy”. I’ll Google it.[/QUOTE]

I may be learning some things after all; here is the output from my search to fix this problem:

# httpd2 -t

httpd2: Syntax error on line 117 of /etc/apache2/httpd.conf: Syntax error on line 26 of /etc/apache2/sysconfig.d/loadmodule.conf: Cannot load /usr/lib64/apache2-prefork/mod\_mem\_cache.so into server: /usr/lib64/apache2-prefork/mod\_mem\_cache.so: undefined symbol: ap\_cache\_cacheable\_hdrs\_out

To me, this seems to show I screwed something up with my module fidgiting in YaST. I have a nasty habit of placing roadblocks mentally in my way, but one, whether it is or isn’t is it seems like a steep curve for me personally, in learning YaST. I am slowly trying to absorb the documentation, which is lengthy, like everything in Linux. I desperately want to get this SLES tuned and working, it just seems great, even though I know so little!

Also, does anyone know if Webmin can work with SLES? It is what I have grown so used to for day-to-day tweaks, especially MySQL.

Regards, tarzy

---

<div class="post-metadata">

**Author:** ![malcolmlewis](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/malcolmlewis/32/11375_2.png) [@malcolmlewis](https://forums.suse.com/u/malcolmlewis)\
**Post date:** [September 15, 2013, 5:13pm UTC](https://forums.suse.com/t/yast2-apache2-error-cannot-adjust-apache2-service-at-50/24495/6 "2013-09-15T17:13:47Z")

</div>

> [@](#):
>
> On Sun 15 Sep 2013 07:04:03 AM CDT, tarzy wrote:
> 
> tarzy;16258 Wrote:[color=blue]
> 
> > SLES 11 SP3. I’ll try that, but will need to find out how as I’m a  
> > “goofy GUI Guy”. I’ll Google it.[/color]
> 
> I may be learning some things after all; here is the output from my  
> search to fix this problem:
> 
> # httpd2 -t
> 
> httpd2: Syntax error on line 117 of /etc/apache2/httpd.conf: Syntax  
> error on line 26 of /etc/apache2/sysconfig.d/loadmodule.conf: Cannot  
> load /usr/lib64/apache2-prefork/mod\_mem\_cache.so into server:  
> /usr/lib64/apache2-prefork/mod\_mem\_cache.so: undefined symbol:  
> ap\_cache\_cacheable\_hdrs\_out
> 
> To me, this seems to show I screwed something up with my module  
> fidgiting in YaST. I have a nasty habit of placing roadblocks mentally  
> in my way, but one, whether it is or isn’t is it seems like a steep  
> curve for me personally, in learning YaST. I am slowly trying to absorb  
> the documentation, which is lengthy, like everything in Linux. I  
> desperately want to get this SLES tuned and working, it just seems  
> great, even though I know so little!
> 
> Also, does anyone know if Webmin can work with SLES? It is what I have  
> grown so used to for day-to-day tweaks, especially MySQL.
> 
> Regards, tarzy

Hi  
Webmin will work, what ever you use there, don’t use in YaST. There is  
also WebYaST?

–  
Cheers Malcolm Â°Â¿Â° SUSE Knowledge Partner (Linux Counter #276890)  
openSUSE 12.3 (x86\_64) GNOME 3.8.4 Kernel 3.7.10-1.16-desktop  
If you find this post helpful and are logged into the web interface,  
please show your appreciation and click on the star below… Thanks!

---

<div class="post-metadata">

**Author:** ![tarzy](https://avatars.discourse-cdn.com/v4/letter/t/f04885/32.png) [@tarzy](https://forums.suse.com/u/tarzy)\
**Post date:** [September 15, 2013, 11:24pm UTC](https://forums.suse.com/t/yast2-apache2-error-cannot-adjust-apache2-service-at-50/24495/7 "2013-09-15T23:24:47Z")

</div>

[QUOTE=malcolmlewis;16266]Hi  
Webmin will work, what ever you use there, don’t use in YaST. There is  
also WebYaST?

–  
Cheers Malcolm Â°Â¿Â° SUSE Knowledge Partner (Linux Counter #276890)  
openSUSE 12.3 (x86\_64) GNOME 3.8.4 Kernel 3.7.10-1.16-desktop  
If you find this post helpful and are logged into the web interface,  
please show your appreciation and click on the star below… Thanks![/QUOTE]

Here is my terminal output:

linux-2u6o:~ # /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf  
Syntax error on line 10 of /etc/apache2/vhosts.d/ip-based\_vhosts.conf:  
ScriptAlias takes two arguments, a fakename and a realname

Here is the file in question (which I have not edited):

 DocumentRoot /srv/www/htdocs/pgvdotcom ServerName playguitarvideos.com ServerAdmin [email]admin@playguitarvideos.com[/email] AllowOverride None Order allow,deny Allow from all ScriptAlias /cgi-bin/ AllowOverride None Options +ExecCGI -Includes Order allow,deny Allow from all UserDir public\_html DocumentRoot /srv/www/htdocs/ctdotcom ServerName craigtarwater.com ServerAdmin [email]admin@craigtarwater.com[/email] AllowOverride None Order allow,deny Allow from all ScriptAlias /cgi-bin/ AllowOverride None Options +ExecCGI -Includes Order allow,deny Allow from all UserDir public\_html

Can I ask what could be the syntax error on line 10 (ScriptAlias /cgi-bin), which is on several lines?

---

<div class="post-metadata">

**Author:** ![smflood](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/smflood/32/10576_2.png) [@smflood](https://forums.suse.com/u/smflood)\
**Post date:** [September 16, 2013, 1:03pm UTC](https://forums.suse.com/t/yast2-apache2-error-cannot-adjust-apache2-service-at-50/24495/8 "2013-09-16T13:03:05Z")

</div>

On 15/09/2013 21:25, tarzy wrote:  
[color=blue]

> Here is the file in question (which I have not edited):
> 
> DocumentRoot /srv/www/htdocs/pgvdotcom ServerName playguitarvideos.com ServerAdmin [email]admin@playguitarvideos.com[/email] AllowOverride None Order allow,deny Allow from all ScriptAlias /cgi-bin/ AllowOverride None Options +ExecCGI -Includes Order allow,deny Allow from all UserDir public\_html DocumentRoot /srv/www/htdocs/ctdotcom ServerName craigtarwater.com ServerAdmin [email]admin@craigtarwater.com[/email] AllowOverride None Order allow,deny Allow from all ScriptAlias /cgi-bin/ AllowOverride None Options +ExecCGI -Includes Order allow,deny Allow from all UserDir public\_html
> 
> Can I ask what could be the syntax error on line 10 (ScriptAlias  
> /cgi-bin), which is on several lines?[/color]

The syntax error for the ScriptAlias directive is because you’re missing  
the file/directory path the alias should map to - correct syntax is

ScriptAlias URL-path file-path|directory-path

There are two ScriptAlias directives that need correcting - lines 10 & 28.

I also see that the Directory directive in line 29 doesn’t include a  
directory path.

## HTH.

Simon  
SUSE Knowledge Partner

* * *

## If you find this post helpful and are logged into the web interface, please show your appreciation and click on the star below. Thanks.

---

<div class="post-metadata">

**Author:** ![tarzy](https://avatars.discourse-cdn.com/v4/letter/t/f04885/32.png) [@tarzy](https://forums.suse.com/u/tarzy)\
**Post date:** [September 16, 2013, 6:27pm UTC](https://forums.suse.com/t/yast2-apache2-error-cannot-adjust-apache2-service-at-50/24495/9 "2013-09-16T18:27:59Z")

</div>

Thanks very much, I’ll fix it. I forgot to say I solved the error of this thread’s subject.

[QUOTE=smflood;16280]On 15/09/2013 21:25, tarzy wrote:  
[color=blue]

> Here is the file in question (which I have not edited):
> 
> DocumentRoot /srv/www/htdocs/pgvdotcom ServerName playguitarvideos.com ServerAdmin [email]admin@playguitarvideos.com[/email] AllowOverride None Order allow,deny Allow from all ScriptAlias /cgi-bin/ AllowOverride None Options +ExecCGI -Includes Order allow,deny Allow from all UserDir public\_html DocumentRoot /srv/www/htdocs/ctdotcom ServerName craigtarwater.com ServerAdmin [email]admin@craigtarwater.com[/email] AllowOverride None Order allow,deny Allow from all ScriptAlias /cgi-bin/ AllowOverride None Options +ExecCGI -Includes Order allow,deny Allow from all UserDir public\_html
> 
> Can I ask what could be the syntax error on line 10 (ScriptAlias  
> /cgi-bin), which is on several lines?[/color]

The syntax error for the ScriptAlias directive is because you’re missing  
the file/directory path the alias should map to - correct syntax is

ScriptAlias URL-path file-path|directory-path

There are two ScriptAlias directives that need correcting - lines 10 & 28.

I also see that the Directory directive in line 29 doesn’t include a  
directory path.

## HTH.

Simon  
SUSE Knowledge Partner

* * *

If you find this post helpful and are logged into the web interface,  
please show your appreciation and click on the star below. Thanks.  
------------------------------------------------------------------------[/QUOTE]
