# Zypper patch - Repository is invalid

**URL:** <https://forums.suse.com/t/zypper-patch-repository-is-invalid/45828>\
**Category:** SLES Updates\
**Created:** [August 19, 2025, 12:54pm UTC](https://forums.suse.com/t/zypper-patch-repository-is-invalid/45828 "2025-08-19T12:54:50Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Uwe\_E](https://avatars.discourse-cdn.com/v4/letter/u/ac91a4/32.png) [@Uwe\_E](https://forums.suse.com/u/Uwe_E)\
**Post date:** [August 19, 2025, 12:54pm UTC](https://forums.suse.com/t/zypper-patch-repository-is-invalid/45828/1 "2025-08-19T12:54:50Z")

</div>

**zypper list-patches** or **zypper patch** result in errors repository is invalid.  
please help us to solve the issue

SUSEConnect - -status-text shows modules registered and statusACTIVE

**zypper patch**

Refreshing service ‘Basesystem\_Module\_15\_SP6\_x86\_64’.

Refreshing service ‘Desktop\_Applications\_Module\_15\_SP6\_x86\_64’.

Refreshing service ‘Python\_3\_Module\_15\_SP6\_x86\_64’.

Refreshing service ‘SAP\_Applications\_Module\_15\_SP6\_x86\_64’.

Refreshing service ‘SUSE\_Linux\_Enterprise\_High\_Availability\_Extension\_15\_SP6\_x86\_64’.

Refreshing service ‘SUSE\_Linux\_Enterprise\_Server\_for\_SAP\_Applications\_15\_SP6\_x86\_64’.

Refreshing service ‘Server\_Applications\_Module\_15\_SP6\_x86\_64’.

Building repository ‘SLE-Module-Basesystem15-SP6-Pool’ cache …[done]

Retrieving repository ‘SLE-Module-Basesystem15-SP6-Updates’ metadata .[error]

**Repository ‘SLE-Module-Basesystem15-SP6-Updates’ is invalid**.

[Basesystem\_Module\_15\_SP6\_x86\_64:SLE-Module-Basesystem15-SP6-Updates|[https://updates.suse.com/SUSE/Updates/SLE-Module-Basesystem/15-SP6/x86\_64/update?842fODCw2G2hooku911IS\_f6Xd\_VmYerZGf8\_CsyXPZjyiBFaERAKlgqhRXtX0F32JWvVorry5HQjgw08ozja-mgNqhu5rfWqB8Yh3DZ22bIpIBRIP\_pyouIhT9Gb-RygHp0Qbk4HHUMPwka9a8UWX8-6FWkXTcBgtyhFUbXyU4R\](https://updates.suse.com/SUSE/Updates/SLE-Module-Basesystem/15-SP6/x86_64/update?842fODCw2G2hooku911IS_f6Xd_VmYerZGf8_CsyXPZjyiBFaERAKlgqhRXtX0F32JWvVorry5HQjgw08ozja-mgNqhu5rfWqB8Yh3DZ22bIpIBRIP_pyouIhT9Gb-RygHp0Qbk4HHUMPwka9a8UWX8-6FWkXTcBgtyhFUbXyU4R%5C)] Valid metadata not found at specified URL

History:

- [|] Error trying to read from ‘[https://updates.suse.com/SUSE/Updates/SLE-Module-Basesystem/15-SP6/x86\_64/update?842fODCw2G2hooku911IS\_f6Xd\_VmYerZGf8\_CsyXPZjyiBFaERAKlgqhRXtX0F32JWvVorry5HQjgw08ozja-mgNqhu5rfWqB8Yh3DZ22bIpIBRIP\_pyouIhT9Gb-RygHp0Qbk4HHUMPwka9a8UWX8-6FWkXTcBgtyhFUbXyU4R](https://updates.suse.com/SUSE/Updates/SLE-Module-Basesystem/15-SP6/x86_64/update?842fODCw2G2hooku911IS_f6Xd_VmYerZGf8_CsyXPZjyiBFaERAKlgqhRXtX0F32JWvVorry5HQjgw08ozja-mgNqhu5rfWqB8Yh3DZ22bIpIBRIP_pyouIhT9Gb-RygHp0Qbk4HHUMPwka9a8UWX8-6FWkXTcBgtyhFUbXyU4R)’

**Please check if the URIs defined for this repository are pointing to a valid repository.**

Warning: Skipping repository ‘SLE-Module-Basesystem15-SP6-Updates’ because of the above error.

Building repository ‘SLE-Module-Desktop-Applications15-SP6-Pool’ cache .[done]

…

**Repository ‘SLE-Module-Desktop-Applications15-SP6-Updates’ is invalid.**

Building repository ‘SLE-Module-Python3-15-SP6-Pool’ cache .[done]

Retrieving repository ‘SLE-Module-Python3-15-SP6-Updates’ metadata …[error]

**Repository ‘SLE-Module-Python3-15-SP6-Updates’ is invalid.**

[

**Repository ‘SLE-Module-SAP-Applications15-SP6-Updates’ is invalid.**

….

Building repository ‘SLE-Product-HA15-SP6-Pool’ cache [done]

…

**Repository ‘SLE-Product-HA15-SP6-Updates’ is invalid.**

…

Building repository ‘SLE-Product-SLES\_SAP15-SP6-Pool’ cache ..[done]

…

**Repository ‘SLE-Product-SLES\_SAP15-SP6-Updates’ is invalid.**

Building repository ‘SLE-Module-Server-Applications15-SP6-Pool’ cache ..[done]

..

**Repository ‘SLE-Module-Server-Applications15-SP6-Updates’ is invalid.**

Some of the repositories have not been refreshed because of an error.

Loading repository data…

---

<div class="post-metadata">

**Author:** ![Uwe\_E](https://avatars.discourse-cdn.com/v4/letter/u/ac91a4/32.png) [@Uwe\_E](https://forums.suse.com/u/Uwe_E)\
**Post date:** [September 15, 2025, 11:35am UTC](https://forums.suse.com/t/zypper-patch-repository-is-invalid/45828/2 "2025-09-15T11:35:14Z")

</div>

The issues is solved.  
We had static entries for  
[scc.suse.com](http://scc.suse.com) oder [updates.suse.com](http://updates.suse.com) in /etc/hosts.  
These IP-Adresses are not static, we deleted these entries.

see: [https://www.suse.com/support/kb/doc/?id=000021034](https://www.suse.com/support/kb/doc/?id=000021034)  
Accessing SUSE Customer Center and SUSE registry behind a firewall and/or through a proxy  
“Our new host names will not provide a single static IP address any more”.
