PDA

View Full Version : SLEPOS KIWI OEM Image, boot issues, blogd, pthread mutex



node_jkarabeg
07-Jun-2012, 17:36
Hi All,

Getting this error on the boot up screen. On older hardware this cause the system to hang completely, on newer hardware it occasionally hangs, and other times is able to get past it. However the error always appears twice.

blogd: ../nptl/pthread_mutex_lock.c:62: __pthread_mutex_cond_lock: Assertion 'mutex->__data.__owner == 0' failed.

Some research has led to a preliminary conclusion that it may be related to these files:


/lib/mkinitrd/scripts/boot-blogd.sh
/lib/mkinitrd/scripts/boot-killblogd.sh
/lib/mkinitrd/scripts/boot-killblogd2.sh

# cat /lib/mkinitrd/scripts/boot-blogd.sh

#!/bin/bash
#%stage: boot
#%depends: udev
#%programs: showconsole /sbin/blogd
#%if: -x /sbin/blogd
#%dontshow
#
##### blogd start
##
## This script starts blogd if this has not happened before.
##
## Command line parameters
## -----------------------
##

if test -z "$REDIRECT" ; then
REDIRECT=$(showconsole 2>/dev/null)
if test -n "$REDIRECT" ; then
if test "$devpts" != "yes" ; then
mount -t devpts devpts /dev/pts
devpts=yes
fi
> /dev/shm/initrd.msg
ln -sf /dev/shm/initrd.msg /var/log/boot.msg
mkdir -p /var/run
/sbin/blogd $REDIRECT
fi
fi

# cat /lib/mkinitrd/scripts/boot-killblogd.sh

#!/bin/bash
#
#%stage: setup
#
#%dontshow
#
##### blogd end
##
## This script tells blogd that the initrd is done.
## Additionally it moves /dev to the new root filesystem.
##
## Command line parameters
## -----------------------
##

blogd_pid=$(pidof blogd)
if test -n "$blogd_pid" ; then
kill -IO "$blogd_pid"
fi

# cat /lib/mkinitrd/scripts/boot-killblogd2.sh

#!/bin/bash
#
#%stage: setup
#%depends: killblogd
#%provides: killprogs
#
#%programs: usleep
#%dontshow
#
##### blogd end2
##
## Really kill blogd this time.
##
## Command line parameters
## -----------------------
##

if test -n "$blogd_pid" ; then
kill -QUIT "$blogd_pid"
while [ -d "/proc/$blogd_pid" ]; do
usleep 300000
done
if [ "$devpts" = "yes" ] ; then
umount -t devpts /dev/pts
fi
fi

This issues started just recently, so it may also be related to some other packages that were updated or added, or the minor kernel upgrade that occurred. Has anyone else seen this issue? Any solutions?

Thanks! :cool:

Automatic reply
14-Jun-2012, 13:30
node,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your issue been resolved? If not, you might try one of the following options:

- Visit http://www.suse.com/support and search the knowledgebase and/or check all
the other support options available.
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.suse.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.suse.com/faq.php

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your SUSE Forums Team
http://forums.suse.com

node_jkarabeg
21-Jun-2012, 13:58
node,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your issue been resolved? If not, you might try one of the following options:

- Visit http://www.suse.com/support and search the knowledgebase and/or check all
the other support options available.
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.suse.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.suse.com/faq.php

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your SUSE Forums Team
http://forums.suse.com

Should I expect a response? Not likely! Novell support seems lacking...

linuxsd
10-Jul-2012, 08:36
I am seeing this exact image. Any solutions? I am logging a SR

node_jclark
11-Jul-2012, 13:25
Hi linuxsd,

I only have been using a work-around so far. I just rename blogd to blogd~, I lose the early boot logging, but at least my systems can boot successfully. It seems around these parts you have to open an SR to get anything done. I would love to hear the solution if you get one!

Thanks,
Jason

svalx
25-Jul-2012, 12:15
I receive this error after migrated from SLED11 SP1 to SP2...