PDA

View Full Version : Missing SAP library for SuseLinux



mohdfahad
06-Feb-2018, 21:42
Hello Experts,

I have been trying to install SAPBI4.2 SP5 on SuseLinux. I am getting below error for missing library. I tried with Redhat on AWS, same issue.

Error MSG:-
Installation aborted. The following libraries are required to run the installer:32bit glibc package containing libc.so.6 (eg. glibc-32bit-2.11.1-0.17.4).
32bit libstdc++ package containing libstdc++.so.5 (eg. libstdc++33-3.3.3-11.9).

Any advice or help is highly appreciated.

Regards,
Fahad

malcolmlewis
06-Feb-2018, 22:17
Hello Experts,

I have been trying to install SAPBI4.2 SP5 on SuseLinux. I am getting below error for missing library. I tried with Redhat on AWS, same issue.

Error MSG:-
Installation aborted. The following libraries are required to run the installer:32bit glibc package containing libc.so.6 (eg. glibc-32bit-2.11.1-0.17.4).
32bit libstdc++ package containing libstdc++.so.5 (eg. libstdc++33-3.3.3-11.9).

Any advice or help is highly appreciated.

Regards,
Fahad
Hi and welcome to the Forum :)
Is the system registered to receive updates?

glibc download here;
https://download.novell.com/Download?buildid=tPNeEH0eYWE~
gcc (4.3) download here;
https://download.novell.com/Download?buildid=PYF3oEoYpcU~

mohdfahad
08-Feb-2018, 23:34
Hi and welcome to the Forum :)
Is the system registered to receive updates?

glibc download here;
https://download.novell.com/Download?buildid=tPNeEH0eYWE~
gcc (4.3) download here;
https://download.novell.com/Download?buildid=PYF3oEoYpcU~

Hi Malcolmlewis,

Thanks for warm welcome.
Yes, i have registered OS, thank you so much for the link. I'll check soon and let you know. :-)

Regards,
Fahad

mohdfahad
21-Feb-2018, 22:14
Hi Malcolmlewis,

I tried to install the library and looks like it is still looking for something different.
Please see the m below. Any idea where to get this specific lib? i couldn't locate.



degdwxp5: BOBJ SP5/DATA UNITS/BusinessObjectsServer_tnx # rpm -ivh . 3-17 .95.2.x86 64. rpm
warning: glibc -32bit-2.11 . 3-17 . 95.2. x86 64. rpm: Header ve RSA/SHA256 Signature, key ID 3@7e3d54: NOKEY
Preparing . ################## [100%]
package glibc -32bit- 2.11.3-17 .95.2.x86 64 is installed

//run BOBJ server tools//
SP5/51052539 BOBJ SP5/DATA UNITS/BusinessObjectsServer_tnx # /setup .sh

//error msg//
Installation aborted
The following libraries are required to run the installer:32bit libstdc++ package containing libstdc++ . so .5 (eg. libstdc++3 3-3.3.3-11.9).


Regards,
Fahad

malcolmlewis
21-Feb-2018, 23:40
Hi Malcolmlewis,

I tried to install the library and looks like it is still looking for something different.
Please see the m below. Any idea where to get this specific lib? i couldn't locate.




Regards,
Fahad
Hi
So is gcc and gcc-32bit installed?

smflood
22-Feb-2018, 12:10
On 06/02/18 20:44, mohdfahad wrote:

> I have been trying to install SAPBI4.2 SP5 on SuseLinux. I am getting
> below error for missing library. I tried with Redhat on AWS, same
> issue.
>
> ERROR MSG:-
> Installation aborted. The following libraries are required to run the
> installer:32bit glibc package containing libc.so.6 (eg.
> glibc-32bit-2.11.1-0.17.4).
> 32bit libstdc++ package containing libstdc++.so.5 (eg.
> libstdc++33-3.3.3-11.9).
>
> Any advice or help is highly appreciated.

I can see through the web forums that you tagged your post as SLES11 SP3
but are you using "regular" SLES11 SP3 or SLES for SAP Applications 11
SP3? Please can you post the output from "cat /etc/*release".

HTH.
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------

pschinagl
26-Feb-2018, 11:18
Hi Malcolmlewis,

I tried to install the library and looks like it is still looking for something different.
Please see the m below. Any idea where to get this specific lib? i couldn't locate.




Regards,
Fahad

Hello Fahad,

Simply search and install it with zypper instead of rpm
zypper does dependency solving and is able to search also for capabilities instead of names

example search (on my sp3 system)
zypper search libstdc++

S | Name | Zusammenfassung | Typ
--+-----------------------------+------------------------------------------------+------
| libstdc++-devel | The system GNU C++ development files | Paket
| libstdc++-devel-32bit | The system GNU C++ 32bit development files | Paket
| libstdc++33 | The standard C++ shared library | Paket
| libstdc++33-32bit | The standard C++ shared library | Paket
...
i | libstdc++6 | The standard C++ shared library | Paket
i | libstdc++6-32bit | The standard C++ shared library | Paket
...

example install

zypper install libstdc++33

It does not matter if it is SLES or SLES4SAP as SLES4SAP has 100% SLES included.


... and btw. the BOBJ install guide does show the needed per-requisite and commands

eg. see https://help.sap.com/viewer/65018c09dbe04052b082e6fc4ab60030/4.2.5/en-US
section Preparation -> system requirements

cu
Your SUSE SAP Team

mohdfahad
28-Feb-2018, 22:46
Hello Fahad,

Simply search and install it with zypper instead of rpm
zypper does dependency solving and is able to search also for capabilities instead of names

example search (on my sp3 system)
zypper search libstdc++

S | Name | Zusammenfassung | Typ
--+-----------------------------+------------------------------------------------+------
| libstdc++-devel | The system GNU C++ development files | Paket
| libstdc++-devel-32bit | The system GNU C++ 32bit development files | Paket
| libstdc++33 | The standard C++ shared library | Paket
| libstdc++33-32bit | The standard C++ shared library | Paket
...
i | libstdc++6 | The standard C++ shared library | Paket
i | libstdc++6-32bit | The standard C++ shared library | Paket
...

example install

zypper install libstdc++33

It does not matter if it is SLES or SLES4SAP as SLES4SAP has 100% SLES included.


... and btw. the BOBJ install guide does show the needed per-requisite and commands

eg. see https://help.sap.com/viewer/65018c09dbe04052b082e6fc4ab60030/4.2.5/en-US
section Preparation -> system requirements

cu
Your SUSE SAP Team


Perfect Thank you #pschinagl and #malcolmlewis so so much for your help.:D
This has been a major road-block, couldn't do without your excellent advises.

Only thing i had to do next was setting utf-8 language.

Thanks once again GodSpeed

Regards,
Fahad