PDA

View Full Version : SuSE Manager API missing data



dxc_hhristov
13-Apr-2018, 15:51
Hello,

According to the API documentation Method: listSystems should return the following things:
int "id"
string "name"
dateTime.iso8601 "last_checkin" - Last time server successfully checked in
dateTime.iso8601 "created" - Server registration time
dateTime.iso8601 "last_boot" - Last server boot time
int "extra_pkg_count" - Number of packages not belonging to any assigned channel
int "outdated_pkg_count" - Number of out-of-date packages

but instead it returns only the following data:

{'id': 1234, 'name': 'exampleserver', 'outdated_pkg_count': 0, 'last_checkin': <DateTime '20180413T14:30:36' at 7f417dfce860>}

The following are missing: last_boot, created and extra_pkg_count

Am I missing something?

Automatic Reply
18-Apr-2018, 05:30
dxc,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

These forums are peer-to-peer, best effort, volunteer run and that if your issue
is urgent or not getting a response, you might try one of the following options:

- Visit http://www.suse.com/support and search the knowledgebase and/or check all
the other support options available.
- Open a service request: https://www.suse.com/support
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.suse.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.suse.com/faq.php

If this is a reply to a duplicate posting or otherwise posted in error, please
ignore and accept our apologies and rest assured we will issue a stern reprimand
to our posting bot..

Good luck!

Your SUSE Forums Team
http://forums.suse.com