PDA

View Full Version : dbcopy on sles10sp4 for groupwise backup



HKO
22-Jun-2012, 12:49
On our Groupwise 8 mailsystem, based on OS SLES10SP4 whe use dbcopy to make a D2D backup from the mail databases.
In the weekend whe do a FULL backup, with the following command line :

echo "./dbcopy -m -f $SRC $FINAL_DST" > $DBCOPY_DIR/dbcopy-$ID-job
echo "./dbcopy -m -s $SRC $FINAL_DST" >> $DBCOPY_DIR/dbcopy-$ID-job

BUT every monday the DBCOPY services still run, and must be killed. Because it looks like it 'hang' on the
backup off the "OFVIEWS"
This is the logging : Getting ready to copy post office databases...

Start copying files in OFFILES...


User DB Count: 2876 Message DB Count: 255

Start copying databases files in OFUSER...


Start copying databases files in OFMSG...


Start copying databases files in GWDMS...


Start copying miscellaneous files in root directory...


Start copying files in OFViews... (here it stays / hangs)


Termination request received!! (this is what whe do on monday morning...).

Does anyone have this same problems with dbcopy and/or GW8. ?

kind regards,


HKO

enovaklbank
22-Jun-2012, 13:27
> Start copying files in OFViews... (here it stays / hangs)
You don't really think that this message tells us what the problem is, do you..?

No, I don't have this same problem with dbcopy and/or GW8.

You should
a.) ask for help in a GW forum, if you think it's a GW problem.
b.) analyse the problem from an OS view - I would start with an strace -p `pidof dbcopy` or at least enabling verbose mode.

It's not clear if the first one process hangs, or the second one?

cjcox
23-Jun-2012, 04:32
On 06/22/2012 06:54 AM, HKO wrote:
>
> On our Groupwise 8 mailsystem, based on OS SLES10SP4 whe use dbcopy to
> make a D2D backup from the mail databases.
> In the weekend whe do a FULL backup, with the following command line :
>
>
> echo "./dbcopy -m -f $SRC $FINAL_DST"> $DBCOPY_DIR/dbcopy-$ID-job
> echo "./dbcopy -m -s $SRC $FINAL_DST">> $DBCOPY_DIR/dbcopy-$ID-job
>
> BUT every monday the DBCOPY services still run, and must be killed.
> Because it looks like it 'hang' on the
> backup off the "OFVIEWS"
> This is the logging : Getting ready to copy post office databases...

Files that are locked by another process can cause things like this to happen.
My guess is that there is a file lock there maybe.

For some software, you do a snapshot of the area containing files and quiesce
programs (however that is done) so that they let go of files they had locks on.
Might be something that helps.. not sure.

HKO
25-Jun-2012, 10:11
> Start copying files in OFViews... (here it stays / hangs)
You don't really think that this message tells us what the problem is, do you..?

No, I don't have this same problem with dbcopy and/or GW8.

You should
a.) ask for help in a GW forum, if you think it's a GW problem.
b.) analyse the problem from an OS view - I would start with an strace -p `pidof dbcopy` or at least enabling verbose mode.

It's not clear if the first one process hangs, or the second one?

Yes, it alway hangs on the First process. The full backup. That the only time it's pick the OFVIEWS folder within his
dbcopy backup. Is there a 'simple' parameter/check to unlock OFVIEWS files, instead of a snappshot?

HKO

Magic31
25-Jun-2012, 12:52
Yes, it alway hangs on the First process. The full backup. That the only time it's pick the OFVIEWS folder within his
dbcopy backup. Is there a 'simple' parameter/check to unlock OFVIEWS files, instead of a snappshot?

HKO

Hey HKO,

Also dropped a reply in the Novell forums... in any case I'm curious why you are running a migration dbcopy... instead of just letting dbcopy do a regular copy?

As already mentioned, the GW forums are the better place to drop questions on the dbcopy procedure.

Cheers,
Willem