PDA

View Full Version : SLES 11 SP2 Memory



stevenweiss
05-Jul-2012, 23:35
Hi,

I've got a memory issue.

SLES seems to be incorrectly reporting memory.
The machine has 4GB and this is indicated in the boot.msg:

<7>[ 0.000000] ACPI: Local APIC address 0xfee00000
<6>[ 0.000000] No NUMA configuration found
<6>[ 0.000000] Faking a node at 0000000000000000-0000000100600000
<7>[ 0.000000] node 0 pfn: [0 - 100600]
<7>[ 0.000000] remap_alloc: node 0 [76800000-78a00000) -> [f4e00000-f7000000)
<6>[ 0.000000] Initmem setup node 0 0000000000000000-0000000100600000
<6>[ 0.000000] NODE_DATA [0000000034e00000 - 0000000034e01fff] (remapped)
<5>[ 0.000000] 3220MB HIGHMEM available.
<5>[ 0.000000] 881MB LOWMEM available.

However when doing a free, it only shows around 1.8GB :

linux3:/ # free -l
total used free shared buffers cached
Mem: 1822060 578912 1243148 0 12480 533132
Low: 775100 226448 548652
High: 1046960 352464 694496
-/+ buffers/cache: 33300 1788760
Swap: 2103292 15648 2087644

I get out of memory errors beyond the 1.8GB

Anyone got any ideas ?
How do I reconfigure so that the full 4GB is reflected ?

Regards
Steven

Jim Henderson
06-Jul-2012, 00:31
On Thu, 05 Jul 2012 22:44:01 +0000, stevenweiss wrote:

> Anyone got any ideas ?
> How do I reconfigure so that the full 4GB is reflected ?

What does:

uname -a
cat /proc/meminfo

Show?

Jim
--
Jim Henderson, CNA6, CDE, CNI, LPIC-1, CLA10, CLP10
Novell Knowledge Partner

stevenweiss
06-Jul-2012, 07:15
Hi Jim

linux3:~ # uname -a
Linux linux3 3.0.13-0.27-pae #1 SMP Wed Feb 15 13:33:49 UTC 2012 (d73692b) i686 i686 i386 GNU/Linux


linux3:~ # cat /proc/meminfo
MemTotal: 1822060 kB
MemFree: 1238672 kB
Buffers: 17180 kB
Cached: 523844 kB
SwapCached: 2716 kB
Active: 72416 kB
Inactive: 475288 kB
Active(anon): 4592 kB
Inactive(anon): 5720 kB
Active(file): 67824 kB
Inactive(file): 469568 kB
Unevictable: 0 kB
Mlocked: 0 kB
HighTotal: 1046960 kB
HighFree: 693504 kB
LowTotal: 775100 kB
LowFree: 545168 kB
SwapTotal: 2103292 kB
SwapFree: 2093084 kB
Dirty: 0 kB
Writeback: 0 kB
AnonPages: 5104 kB
Mapped: 5436 kB
Shmem: 3624 kB
Slab: 16044 kB
SReclaimable: 7396 kB
SUnreclaim: 8648 kB
KernelStack: 1360 kB
PageTables: 676 kB
NFS_Unstable: 0 kB
Bounce: 0 kB
WritebackTmp: 0 kB
CommitLimit: 3014320 kB
Committed_AS: 117124 kB
VmallocTotal: 122880 kB
VmallocUsed: 23716 kB
VmallocChunk: 94200 kB
HardwareCorrupted: 0 kB
AnonHugePages: 0 kB
HugePages_Total: 0
HugePages_Free: 0
HugePages_Rsvd: 0
HugePages_Surp: 0
Hugepagesize: 2048 kB
DirectMap4k: 18424 kB
DirectMap2M: 884736 kB

Regards
Steven

Magic31
06-Jul-2012, 11:48
What make/brand is the server? And are the memory chips all of the same type?

Could be something with the BIOS. Maybe check for and apply the latest BIOS for the main board, or not already done so.

-Willem