PDA

View Full Version : SLED 12 SP3 How to set winbind user as the default user in login screen?



Beiw
03-Dec-2018, 09:29
I have joined AD on SLED 12 SP3 via krb5-client & samba-winbind. And I also configured Smart Card authentication on it too, with pam_pkcs11, mozilla-nss, mozilla-nss-tools, pcsc-lite, pcsc-ccid, opensc, coolkey & pcsc-tools.
After configed pam via ''pam-config -a --winbind', I can find two users on the login screen: one is the local user and the other is the domain user. After I selected the domain user and inserted the smart card's pin, I can login as the domain user.
But I want to set the domain user as the default login user. In another word, if I plugged in the smartcard, there is only the winbind user on the login screen. After I plugged off the smartcard, the local user will on the login screen.
I tried to modify the files under /etc/pam.d, but it seems that the modification did not take effect. Can somebody help me? Thanks a lot.

Automatic Reply
10-Dec-2018, 06:30
Beiw,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

These forums are peer-to-peer, best effort, volunteer run and that if your issue
is urgent or not getting a response, you might try one of the following options:

- Visit http://www.suse.com/support and search the knowledgebase and/or check all
the other support options available.
- Open a service request: https://www.suse.com/support
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.suse.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.suse.com/faq.php

If this is a reply to a duplicate posting or otherwise posted in error, please
ignore and accept our apologies and rest assured we will issue a stern reprimand
to our posting bot..

Good luck!

Your SUSE Forums Team
http://forums.suse.com