PDA

View Full Version : NWCCOpenConnByName() returns 0xFFFFFFEA



joeflowers
21-Jul-2009, 16:36
Hello,

I have written a XPLAT Linux program that uses NWCCOpenConnByName() to
acquire a connection to a SLES10SP2OES2SP1 server (127.0.0.1), and then
the program uses this connection provided by NWCCOpenConnByName() to
login to eDirectory with NWDSLoginEx(). The program works fine on my
SLES10SP2OES2SP1 server, but when another person runs the same program
on his SLES10SP2OES2SP1 server, then the program fails;
NWCCOpenConnByName() returns 0xFFFFFFEA.

We both have the Novell Client for Linux installed and working on both
of these servers; meaning, we can login to eDirectory fine with NCL.

Any ideas of things to try to figure out why this program will not run
on his server?

Thanks!

-------------


--
joeflowers
------------------------------------------------------------------------
joeflowers's Profile: http://forums.novell.com/member.php?userid=5949
View this thread: http://forums.novell.com/showthread.php?t=380684

Jacek
13-Nov-2009, 10:33
Hello,
I have written a lot of programms for NetWare platform and I would like to
rewrite
this for OES Linux platform. In your post I see that you use NWCC function
on Linux platform.
My question is:
How can I use (compilation and linking) NWCC (and other) function to create
programms for OES Linux platform
Regards
JacekD

joeflowers
27-Feb-2010, 11:46
An answer:

As of Feb. 23, 2010, any Novell X-Plat API function called in any
32-bit Linux program will return a 0xFFFFFFEA if it is run on a 64-bit
SLEx Linux machine with an NCL installed from http://XXXXX.novell.com/.

-------------


--
joeflowers
------------------------------------------------------------------------
joeflowers's Profile: http://forums.novell.com/member.php?userid=5949
View this thread: http://forums.novell.com/showthread.php?t=380684