PDA

View Full Version : SLES 15 RMT issue with SLES15



ttrcf
24-Apr-2019, 11:02
I have configured an RMT server on a SLES 15 machine and configured it to mirror the repositories for SLED12SP4, SLES12SP4 and SLES15.

If i List the mirrored repositories I get:


>rmt-cli products list

+------+------------------------------------------------+---------+--------+---------+-------------------------+
| ID | Product | Version | Arch | Mirror? | Last mirrored |
+------+------------------------------------------------+---------+--------+---------+-------------------------+
| 1576 | Basesystem Module | 15 | x86_64 | Mirror | 2019-04-24 09:23:05 UTC |
| | sle-module-basesystem/15/x86_64 | | | | |
| 1578 | Desktop Applications Module | 15 | x86_64 | Mirror | 2019-04-24 09:23:45 UTC |
| | sle-module-desktop-applications/15/x86_64 | | | | |
| 1579 | Development Tools Module | 15 | x86_64 | Mirror | 2019-04-24 09:24:13 UTC |
| | sle-module-development-tools/15/x86_64 | | | | |
| 1580 | Server Applications Module | 15 | x86_64 | Mirror | 2019-04-24 09:26:36 UTC |
| | sle-module-server-applications/15/x86_64 | | | | |
| 1629 | SUSE Linux Enterprise Desktop | 12.4 | x86_64 | Mirror | 2019-04-24 09:29:52 UTC |
| | SLED/12.4/x86_64 | | | | |
| 1609 | SUSE Linux Enterprise Desktop | 15 | x86_64 | Mirror | 2019-04-24 09:26:53 UTC |
| | SLED/15/x86_64 | | | | |
| 1625 | SUSE Linux Enterprise Server | 12.4 | x86_64 | Mirror | 2019-04-24 09:28:24 UTC |
| | SLES/12.4/x86_64 | | | | |
| 1575 | SUSE Linux Enterprise Server | 15 | x86_64 | Mirror | 2019-04-24 09:21:35 UTC |
| | SLES/15/x86_64 | | | | |
| 1630 | SUSE Linux Enterprise Software Development Kit | 12.4 | x86_64 | Mirror | 2019-04-24 09:29:27 UTC |
| | sle-sdk/12.4/x86_64 | | | | |
| 1583 | SUSE Linux Enterprise Workstation Extension | 15 | x86_64 | Mirror | 2019-04-24 09:24:53 UTC |
| | sle-we/15/x86_64 | | | | |
| 1813 | SUSE Package Hub | 12.4 | x86_64 | Mirror | 2019-04-24 09:28:57 UTC |
| | PackageHub/12.4/x86_64 | | | | |
| 1743 | SUSE Package Hub | 15 | x86_64 | Mirror | 2019-04-24 09:25:59 UTC |
| | PackageHub/15/x86_64 | | | | |
+------+------------------------------------------------+---------+--------+---------+-------------------------+
Only enabled products are shown by default. Use the `--all` option to see all products.

The mirroring is manually launched with rmt-cli mirror and completes without any errors.

I have then successfully registered a SLED12SP4 machine to the RMT server and if I list enabled repositories on the client machine I get:


> zypper lr
Repository priorities are without effect. All enabled repositories share the same priority.

# | Alias | Name | Enabled | GPG Check | Refresh
---+---------------------------------------------------------------------------------------+--------------------------------------+---------+-----------+--------
1 | SLED12-SP4-12.4-0 | SLED12-SP4-12.4-0 | Yes | (r ) Yes | No
2 | SUSE_Linux_Enterprise_Desktop_x86_64:SLE-12-SP4-GA-Desktop-nVidia-Driver | SLE-12-SP4-GA-Desktop-nVidia-Driver | Yes | (r ) Yes | Yes
3 | SUSE_Linux_Enterprise_Desktop_x86_64:SLED12-SP4-Debuginfo-Pool | SLED12-SP4-Debuginfo-Pool | No | ---- | ----
4 | SUSE_Linux_Enterprise_Desktop_x86_64:SLED12-SP4-Debuginfo-Updates | SLED12-SP4-Debuginfo-Updates | No | ---- | ----
5 | SUSE_Linux_Enterprise_Desktop_x86_64:SLED12-SP4-Installer-Updates | SLED12-SP4-Installer-Updates | No | ---- | ----
6 | SUSE_Linux_Enterprise_Desktop_x86_64:SLED12-SP4-Pool | SLED12-SP4-Pool | Yes | (r ) Yes | No
7 | SUSE_Linux_Enterprise_Desktop_x86_64:SLED12-SP4-Source-Pool | SLED12-SP4-Source-Pool | No | ---- | ----
8 | SUSE_Linux_Enterprise_Desktop_x86_64:SLED12-SP4-Updates | SLED12-SP4-Updates | Yes | (r ) Yes | Yes
9 | SUSE_Linux_Enterprise_Software_Development_Kit_x86 _64:SLE-SDK12-SP4-Debuginfo-Pool | SLE-SDK12-SP4-Debuginfo-Pool | Yes | ( p) Yes | No
10 | SUSE_Linux_Enterprise_Software_Development_Kit_x86 _64:SLE-SDK12-SP4-Debuginfo-Updates | SLE-SDK12-SP4-Debuginfo-Updates | Yes | ( p) Yes | Yes
11 | SUSE_Linux_Enterprise_Software_Development_Kit_x86 _64:SLE-SDK12-SP4-Pool | SLE-SDK12-SP4-Pool | Yes | (r ) Yes | No
12 | SUSE_Linux_Enterprise_Software_Development_Kit_x86 _64:SLE-SDK12-SP4-Source-Pool | SLE-SDK12-SP4-Source-Pool | Yes | ( p) Yes | No
13 | SUSE_Linux_Enterprise_Software_Development_Kit_x86 _64:SLE-SDK12-SP4-Updates | SLE-SDK12-SP4-Updates | Yes | (r ) Yes | Yes
14 | SUSE_Package_Hub_x86_64:SUSE-PackageHub-12-SP4-Debuginfo | SUSE-PackageHub-12-SP4-Debuginfo | Yes | ( p) Yes | Yes
15 | SUSE_Package_Hub_x86_64:SUSE-PackageHub-12-SP4-Pool | SUSE-PackageHub-12-SP4-Pool | Yes | (r ) Yes | No
16 | SUSE_Package_Hub_x86_64:SUSE-PackageHub-12-SP4-Standard-Pool | SUSE-PackageHub-12-SP4-Standard-Pool | Yes | (r ) Yes | No

I think this should tell me that all is well but every time I start the 'Online update' module from YaST2 on the SLED12SP4 client machine it generates the following error:


There was an error in the repository initialization. [SUSE_Package_Hub_x86_64:SUSE-PackageHub-12-SP4-Debuginfo|https://192.168.1.100/repo/SUSE/Backports/SLE-12-SP4_x86_64/standard_debug/?credentials=SUSE_Package_Hub_x86_64] Valid metadata not found at specified URL History: - [SUSE_Package_Hub_x86_64:SUSE-PackageHub-12-SP4-Debuginfo|https://192.168.1.100/repo/SUSE/Backports/SLE-12-SP4_x86_64/standard_debug/?credentials=SUSE_Package_Hub_x86_64] Repository type can't be determined.

Can anyone advise what is different about this particular repository and what I need to do to get rid of this message?

Thanks

Rob

eblock
24-Apr-2019, 15:48
Hi,
although I don't have an explanation for you, I can share my experience. Just a couple of hours ago I tried to register a SLES15 VM to SCC, so no RMT is involved. However, my VM added the respective repository and was registered, but I got this error message:

sles15:~ # SUSEConnect -p PackageHub/15/x86_64 -r <CODE>
command 'zypper --no-refresh --non-interactive install --no-recommends --auto-agree-with-product-licenses -t product PackageHub' failed
Error: zypper returned (106) with 'Error building the cache:
[SUSE_Package_Hub_15_x86_64:SUSE-PackageHub-15-Standard-Pool|https://updates.suse.com/SUSE/Backports/SLE-15_x86_64/standard?...] Valid metadata not found at specified URL
Some of the repositories have not been refreshed because of an error.'
Nevertheless, the repo was there. And after a 'zypper ref' I could use that repo to install a package. To me this looks very related to your description, unfortunately I don't have an explanation.