PDA

View Full Version : SLES 15 xrdp vnc not working properly



patrickheppler
05-Jun-2019, 13:43
Hello,
I just installed a 60 day trial of SLES 15. I choosed SLES for SAP install option and left packages at the default values.
Now if I connect from Windows 10 via RDP, the connections almost all fail. Maybe 1 of 10 work, mostly after reboot. mstsc is setup to use only 24 Bit color depth.
xrdp and sesman log level is set to info. Firewalld is shutdown (machine is already in DMZ).

xrdp.log


[20190605-13:14:15] [INFO ] xrdp_wm_log_msg: Please wait, we now perform access control...
[20190605-13:14:15] [WARN ] getsockname() failed on socket 15: Bad file descriptor
[20190605-13:14:15] [INFO ] xrdp_wm_log_msg: Reply from access control: Success
[20190605-13:14:15] [INFO ] xrdp_wm_log_msg: sesman connect ok
[20190605-13:14:15] [INFO ] xrdp_wm_log_msg: login successful for display 201


sesman.log


[20190605-13:14:15] [INFO ] A connection received from ::1 port 33238
[20190605-13:14:15] [INFO ] Access permitted for user: admin
[20190605-13:14:15] [INFO ] A connection received from ::1 port 33240
[20190605-13:14:15] [INFO ] ++ created session (access granted): username admin, ip ::ffff:192.168.1.13:23856 - socket: 11
[20190605-13:14:15] [INFO ] starting Xvnc session...
[20190605-13:14:15] [INFO ] calling auth_start_session from pid 18972
[20190605-13:14:15] [INFO ] Xvnc :201 -auth .Xauthority -geometry 1920x1080 -depth 24 -rfbauth /home/admin/.vnc/sesman_passwd-admin@localhost:201 -bs -nolisten tcp -localhost -dpi 96
[20190605-13:14:16] [CORE ] waiting for window manager (pid 18973) to exit
[20190605-13:14:16] [CORE ] window manager (pid 18973) did exit, cleaning up session
[20190605-13:14:16] [INFO ] calling auth_stop_session and auth_end from pid 18972
[20190605-13:14:16] [INFO ] ++ terminated session: username admin, display :201.0, session_pid 18972, ip ::ffff:192.168.1.13:23856 - socket: 11


/var/log/messages:


2019-06-05T13:14:15.928142+02:00 localhost systemd-logind[2507]: New session c12 of user admin.
2019-06-05T13:14:15.928974+02:00 localhost systemd[1]: Started Session c12 of user admin.
2019-06-05T13:14:15.932982+02:00 localhost xrdp-sesman: pam_unix(xrdp-sesman:session): session opened for user admin by (uid=0)
2019-06-05T13:14:16.461481+02:00 localhost xrdp-sesman: pam_unix(xrdp-sesman:session): session closed for user admin
2019-06-05T13:14:16.463864+02:00 localhost systemd-logind[2507]: Session c12 logged out. Waiting for processes to exit.
2019-06-05T13:14:16.468284+02:00 localhost systemd-logind[2507]: Removed session c12.


Xvnc popup shows:
http://tinyimg.io/i/FP1oL0E.png

Any idea what's going wrong?

Automatic Reply
10-Jun-2019, 05:30
patrickheppler,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

These forums are peer-to-peer, best effort, volunteer run and that if your issue
is urgent or not getting a response, you might try one of the following options:

- Visit http://www.suse.com/support and search the knowledgebase and/or check all
the other support options available.
- Open a service request: https://www.suse.com/support
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.suse.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.suse.com/faq.php

If this is a reply to a duplicate posting or otherwise posted in error, please
ignore and accept our apologies and rest assured we will issue a stern reprimand
to our posting bot..

Good luck!

Your SUSE Forums Team
http://forums.suse.com