PDA

View Full Version : cyrus cyradm can not authenticate



ibmtigb
21-Aug-2012, 08:24
Hi,
I am using cyrus which an external email-user database (ldap) with sasl-ldap.
My cyrus user is local and must be authenticated against passwd/shadow.
How can i use sasl for email-users and local for cyrus.

Thanks for help

ibmtigb
21-Aug-2012, 14:30
as extension of above.
If i set SASLAUTHD_AUTHMECH=shadow it work for this time. But then no user can access mail....

MoserHans
23-Aug-2012, 13:14
Hi,

why don't you put the cyrus user in ldap as well? This will be by far the most easiest way.

cyradm is an IMAP client. Authentication happens on the server side, so it does not depand on cyradm.

Authentication settings are in imapd.conf. They can be defined by service. Services are defined in cyrus.conf.

So you could define another imap service like imap-adm in cyrus.conf on another port like 99143.
Then you set your authentication settings for this service with the service prefix like "imap-adm_"
imap-adm_SASLAUTHD_AUTHMECH=shadow