PDA

View Full Version : mysql devel package?



mutundis
02-Jan-2013, 03:17
I'm using SLED 11 SP2. I am new to SUSE (although have used other linux distros previously). Is there a SUSE package somewhere that will provide mysql development files (mysql_config, among other things)? If there is do I need to add a repository to the default SLED repository? Is there a list somewhere of prominent SUSE repositories (like e.g.EPEL for RHEL?)

Thanks!

ab
02-Jan-2013, 04:29
I'm not sure where it is exactly, but a lot of the _devel packages are on
the SDK DVD (DVD2 I believe) so that may be why you do not see it yet.

Another place to look for some of these things is the Patch Finder site:

http://download.novell.com/patch/finder

Just type 'mysql' in the lower-left search field and see what shows up;
look under the 'SUSE Linux Enterprise Desktop 11 SP2' product for
something close to what you're after; currently I get sent here when I
click on the links there:
http://download.novell.com/Download?buildid=6GBlgOCIyro~

Good luck.

malcolmlewis
02-Jan-2013, 04:31
On Wed 02 Jan 2013 02:24:03 AM CST, mutundis wrote:


I'm using SLED 11 SP2. I am new to SUSE (although have used other linux
distros previously). Is there a SUSE package somewhere that will provide
mysql development files (mysql_config, among other things)? If there is
do I need to add a repository to the default SLED repository? Is there a
list somewhere of prominent SUSE repositories (like e.g.EPEL for RHEL?)

Thanks!




Hi
You can either download the SLE 11 SDK iso image and install via YaST
add on products. This will then add the online and update repositories.

Link to iso image;
http://download.novell.com/Download?buildid=NgW3ToaagDQ~
You only need DVD1 (the other is the src rpms)

Else if you look on the NCC page for your system, down the bottom there
is a link to 'Mirror Credentials' this has the username/password for
you to use and the list of URLs to add manually via YaST Software
Repositories.

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.11-2.16-desktop
up 0:46, 2 users, load average: 0.03, 0.06, 0.05
CPU Intel® i5 CPU M520@2.40GHz | GPU Intel® Ironlake Mobile

mutundis
03-Jan-2013, 00:27
Thanks Malcolm and ab for your replies - just what I needed to know

sigbj
08-Jan-2013, 19:00
I have a problem that ressembles this one, but it is concerning

mysql-connector-java

that among other things is necessary to make an MessageServiceHandler in ebxml work.

As to the openSuSE 11.4 it has all the necessary packages, but the DVD1 of the SLED_11_SP1 has not. The MSH on opensuse_11.4 works correctly. The SLED_11_SP1 does not.

If you have the spesific address to the DVD/program in question for SLED_11 please paste it in the answer, because it is hard to find

Sincerely S

malcolmlewis
08-Jan-2013, 19:28
On Tue 08 Jan 2013 06:04:01 PM CST, sigbj wrote:


I have a problem that ressembles this one, but it is concerning

mysql-connector-java

that among other things is necessary to make an MessageServiceHandler
in ebxml work.

As to the openSuSE 11.4 it has all the necessary packages, but the DVD1
of the SLED_11_SP1 has not. The MSH on opensuse_11.4 works correctly.
The SLED_11_SP1 does not.

If you have the spesific address to the DVD/program in question for
SLED_11 please paste it in the answer, because it is hard to find

Sincerely S




Hi
You could try the unsupported one from the Java:jpackage-1.7
repository fro SLE 11 SP1?
http://software.opensuse.org/package/mysql-connector-java

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.11-2.16-desktop
up 16:57, 3 users, load average: 0.12, 0.08, 0.06
CPU Intel® i5 CPU M520@2.40GHz | GPU Intel® Ironlake Mobile