PDA

View Full Version : Multimedia on SLED 11 patch 2



sasamatejic
03-Jan-2013, 18:47
Hi!

I just bought laptop with SLED preinstalled. I have some linux experience, but never used SUSE or OpenSUSE. Although most of the system works very well, multimedia does not. How can I install SMplayer along with proprietary codecs?

malcolmlewis
03-Jan-2013, 19:20
On Thu 03 Jan 2013 05:54:01 PM CST, sasamatejic wrote:


Hi!

I just bought laptop with SLED preinstalled. I have some linux
experience, but never used SUSE or OpenSUSE. Although most of the system
works very well, multimedia does not. How can I install SMplayer along
with proprietary codecs?




Hi
You need to add the SLE packman repository;

http://pmbs.links2linux.org/download/Essentials/SLE-11-SP2/

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.11-2.16-desktop
up 1:15, 3 users, load average: 0.25, 0.08, 0.06
CPU Intel® i5 CPU M520@2.40GHz | GPU Intel® Ironlake Mobile

sasamatejic
04-Jan-2013, 02:47
Thanks, Malcolm!

JeffOkolo
21-Jan-2013, 01:03
Thanks for this. I followed the directions and I was able to get the Packman for SLED 11-SP2. Upon installing VLC, I received the message "conflicts in the transaction must be solved manually ... nothing provides libiso9660.so.5()(64bit) needed by vlc..." . I receive similar alerts pertaining to SM Player.

I did notice that the package gave me the wrong version of vlc (2.0.1 instead of 1.1.13).
Could that be why it won't install?
How do I get the earlier version?

Sorry if my terminology is a bit off. I am completely new.
Thanks!

mikewillis
21-Jan-2013, 11:46
Can't help you wit the Packman stuff as personally I don't touch that. You may want to take a look at http://www.novell.com/communities/node/13146/additional-multimedia-codec-support-sled-11-sp1
You'll need to edit the build script so it doesn't complain that you're not using SP1, but other than that it should work. Maybe I should get around to sorting out an SP2 version of that Cool Solution. The process is exactly the same except for slightly newer versions of some packages can be used.

JeffOkolo
22-Jan-2013, 11:32
Can't help you wit the Packman stuff as personally I don't touch that. You may want to take a look at http://www.novell.com/communities/node/13146/additional-multimedia-codec-support-sled-11-sp1
You'll need to edit the build script so it doesn't complain that you're not using SP1, but other than that it should work. Maybe I should get around to sorting out an SP2 version of that Cool Solution. The process is exactly the same except for slightly newer versions of some packages can be used.

Ok. Thanks. I will give it a go.