PDA

View Full Version : Sles 11 SP2 Internet Routing and VMware



RLMILLIES
09-Jan-2013, 17:27
I have installed SLES 11 SP2 on a VMware system and configured 2 NIC cards in SLES to be:

eth0 = 192.168.xxx.12 255.255.255.0 (Private)
eth1 = 99.xxx.236.53 255.255.255.248 (Public)

Gateway under Routing in Yast = 99.xxx.236.54

On workstations I have 192.168.xxx.100 255.255.255 GW 192.168.xxx.12

On the server I can ping the internet and browse but on the workstation I can only ping the second NIC address but not past it. I have disabled all firewalls and restarted the server and workstation.

I have read other posts but for some reason I can't get this figured out.

Any help would be greatly appreciated.

Thanks,
Ken

ab
09-Jan-2013, 18:28
So you are using the SLES VM as a gateway/router, but not doing any
NAT-like stuff, right? What steps have you used to configure SLES as a
router (be specific, and verbose)? For example, have you enabled IP
forwarding via sysctl or the /proc filesystem for a one-time test? Did
this work in any other environment? When you say you can ping the "second
NIC" are you referring to the public IP, I presume?

Good luck.

RLMILLIES
09-Jan-2013, 18:46
First thanks for replying to the question as for NAT, no I have not done anything with NAT. This is just a test server environment, trying to figure linux out before going to production with Linux. I have not gotten routing to work yet.

The Steps I have taken are:
In YAST gone into Network Settings:
Configured eth0 as static with 192.168.xxx.12 subnet mask 255.255.255.0
Configured eth1 as static with 99.xxx.236.53 subnet mask 255.255.255.248
Configured a Hostname and DNS address of 8.8.8.8 and 68.94.156.1
Under Routing Tab - Configured Default Gateway 99.xxx.236.54
Hit OK and returned to Yast console

I also went into /etc/sysctl.conf and change the net.ip4.conf.all.rp_filter to 0 instead of 1

I then restarted the server.

ab
09-Jan-2013, 19:54
Googling for 'confgure suse as router yast' found this link which I think
has what you need about enabling forwarding under the 'Routing Setup' section.

http://www.novell.com/coolsolutions/feature/16579.html

Let us know, please.

Good luck.

RLMILLIES
09-Jan-2013, 21:45
Cool! That link worked for me.

I truly appreciate it,
Ken

ab
09-Jan-2013, 22:19
Great! Thanks for posting back your results as they will likely help
others in the same boat.

Good luck.