PDA

View Full Version : Update of application screws with the disk ....



John_Gill
27-Feb-2013, 14:41
Hi,

Running SLES11sp2 and running Datasync as a XEN virtual machine.

I upgraded the Novell Datasync application on the VM and this went thru fine
and the system update and is working correctly.
but .....
on a reboot of the virtual machine generates the following error:

waiting for device /dev/xvda to appear: ok
invalid root filesystem
exiting to /bin/sh
$

I then type "exit" and then everything works 100%

The "mount" command returns "/dev/xvda1 /boot" and "/dev/xvda3 /" which all
looks correct.

Any ideas ......

Regards
John

jmozdzen
27-Feb-2013, 18:26
Hi John,

I've sometimes seen that the VM's kernel somehow didn't catch the root file system name correctly. You might want to try to set "root=/dev/xvda3"as an EXTRA parameter in your DomU's configuration file and see if that helps.

Regards,
Jens

KBOYLE
27-Feb-2013, 18:30
John Gill wrote:

> I upgraded the Novell Datasync application on the VM and this went
> thru fine and the system update and is working correctly.
> but .....
> on a reboot of the virtual machine generates the following error:
>
> waiting for device /dev/xvda to appear: ok
> invalid root filesystem
> exiting to /bin/sh
> $

Hi John,

You may have encountered Bug 755924. Under certain conditions during an
upgrade or when applying patches, initrd may be built incorrectly.

The solution is quite simple: run mkinitrd to correctly rebuild initrd.

Let me know if this resolves your issue.

--
Kevin Boyle - Knowledge Partner
If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below...

GofBorg
28-Feb-2013, 00:52
> waiting for device /dev/xvda to appear: ok
> invalid root filesystem
> exiting to /bin/sh
> $

Gives you the warm fuzzies doesn't it?
I've hit that bug as well. Good to know it's
not fixed in SP2, I can hold off on that a bit longer.

John_Gill
28-Feb-2013, 08:15
Hey Kevin,

Running "mkinitrd" fiddled in the OS and fixed the issue.

Many thanks
Regards
John

>>> On 27 February 2013 at 19:30, in message
<ForXs.4501$vO3.750@kovat.provo.novell.com>,
KBOYLE<KBOYLE@no-mx.forums.suse.com> wrote:
> John Gill wrote:
>
>> I upgraded the Novell Datasync application on the VM and this went
>> thru fine and the system update and is working correctly.
>> but .....
>> on a reboot of the virtual machine generates the following error:
>>
>> waiting for device /dev/xvda to appear: ok
>> invalid root filesystem
>> exiting to /bin/sh
>> $
>
> Hi John,
>
> You may have encountered Bug 755924. Under certain conditions during an
> upgrade or when applying patches, initrd may be built incorrectly.
>
> The solution is quite simple: run mkinitrd to correctly rebuild initrd.
>
> Let me know if this resolves your issue.

John_Gill
28-Feb-2013, 08:16
Hey Jens,

As per Kevin Boyle I ran "mkinitrd" which fiddled in the OS and fixed the
issue.

Regards
John


>>> On 27 February 2013 at 19:34, in message
<jmozdzen.5rflun@no-mx.forums.suse.com>,
jmozdzen<jmozdzen@no-mx.forums.suse.com> wrote:

> Hi John,
>
> I've sometimes seen that the VM's kernel somehow didn't catch the root
> file system name correctly. You might want to try to set
> "root=/dev/xvda3"as an EXTRA parameter in your DomU's configuration file
> and see if that helps.
>
> Regards,
> Jens

John_Gill
28-Feb-2013, 08:18
Hey GofBorg,

As per Kevin Boyle, just run "mkinitrd" this fiddles in the OS and fixes the
issue.

Regards
John


>>> On 28 February 2013 at 01:52, in message
<h%wXs.4529$vO3.2827@kovat.provo.novell.com>,
GofBorg<GofBorg@no-mx.forums.opensuse.org> wrote:
>> waiting for device /dev/xvda to appear: ok
>> invalid root filesystem
>> exiting to /bin/sh
>> $
>
> Gives you the warm fuzzies doesn't it?
> I've hit that bug as well. Good to know it's
> not fixed in SP2, I can hold off on that a bit longer.

KBOYLE
02-Mar-2013, 02:40
John Gill wrote:

> on a reboot of the virtual machine generates the following error:
>
> waiting for device /dev/xvda to appear: ok
> invalid root filesystem
> exiting to /bin/sh
> $

From time to time I see posts in various forums from others who have
encountered this issue.

I had a bug opened for this almost a year ago. While patches have
reduced the chances of this happening they have not yet completely
resolved the issue. I have asked that it be documented in a TID.

For anyone else who encounters this issue, please refer to this TID:
TID 7011861 Invalid root file system after upgrading or applying
patches.
http://www.novell.com/support/kb/doc.php?id=7011861

--
Kevin Boyle - Knowledge Partner
If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below...