PDA

View Full Version : upgrade sles 10 sp3 to sles 11 sp2?



KeN Etter
14-Mar-2013, 14:41
I have a workstation running sles 10 sp3. Sole purpose is to run
Reload to backup my GroupWise installation. Is it possible to upgrade
sles 10 sp3 (32bit) to sles 11 sp2 (32bit or 64bit)? Or am I better
off starting from scratch? I dug around in the suse docs, but couldn't
find anything.

Ken

jmozdzen
14-Mar-2013, 15:07
Hi Ken,

http://www.novell.com/support/kb/doc.php?id=7010200


Procedure for upgrading from SLES 10 / SLED 10 (GA version, Service Pack 1, Service Pack 2, and Service Pack 3)
There is no supported direct migration path to SLES/SLED 11 SP2. An update has to be performed from SLES/SLED 10 GA to SP 1, then to SP 2, further to SP 3, and then to SP4 by using the respective boot media.

Interestingly, the "upgrade to SLES11SP1" article (http://www.novell.com/support/kb/doc.php?id=7005410) doesn't list the requirement to go to SLES10SP4 first.

I have no experience with GW, so I cannot tell how much hassle it is to configure a fresh SLES11 install to fulfill your requirements.

Regards,
Jens

KeN Etter
14-Mar-2013, 21:32
jmozdzen wrote:

>
> Hi Ken,
>
> http://www.novell.com/support/kb/doc.php?id=7010200
>
> > Procedure for upgrading from SLES 10 / SLED 10 (GA version, Service
> > Pack 1, Service Pack 2, and Service Pack 3)
> > There is no supported direct migration path to SLES/SLED 11 SP2. An
> > update has to be performed from SLES/SLED 10 GA to SP 1, then to
> > SP 2, further to SP 3, and then to SP4 by using the respective boot
> > media.
>
> Interestingly, the "upgrade to SLES11SP1" article
> (http://www.novell.com/support/kb/doc.php?id=7005410) doesn't list the
> requirement to go to SLES10SP4 first.
>
> I have no experience with GW, so I cannot tell how much hassle it is
> to configure a fresh SLES11 install to fulfill your requirements.
>
> Regards,
> Jens

Thanks Jens!

smflood
14-Mar-2013, 23:35
jmozdzen wrote:

> http://www.novell.com/support/kb/doc.php?id=7010200
>
>> Procedure for upgrading from SLES 10 / SLED 10 (GA version, Service Pack
>> 1, Service Pack 2, and Service Pack 3)
>> There is no supported direct migration path to SLES/SLED 11 SP2. An
>> update has to be performed from SLES/SLED 10 GA to SP 1, then to SP 2,
>> further to SP 3, and then to SP4 by using the respective boot media.
>
> Interestingly, the "upgrade to SLES11SP1" article
> (http://www.novell.com/support/kb/doc.php?id=7005410) doesn't list the
> requirement to go to SLES10SP4 first.
>
> I have no experience with GW, so I cannot tell how much hassle it is to
> configure a fresh SLES11 install to fulfill your requirements.

According to section 7.3 of the SLES11Deployment Guide[1] there is no
supported direct migration path from SLES10 SP3 or earlier to SLES11 so you
need to update SLES10 to SP4 first.

You can also only upgrade architecture to same (so 32-bit to 32-bit, 64-bit
to 64-bit). If you want to change the architecture you'd need to install a
new server then migrate data and/or services.

HTH.

[1]
https://www.suse.com/documentation/sles11/book_sle_deployment/data/sec_update_proc_prep_paths.html
--
Simon
SUSE Knowledge Partner