PDA

View Full Version : SLES11SP2+DHCP client+/etc/resolv.conf = problem



skoltogyan
19-Mar-2013, 09:54
We are use SLES11SP2 in the Azure ( get sles11sp2 from the Azure Galery ).
Install - OK.
Log in to the SLES11SP2 over ssh - OK.
ShutDown machine - OK
Resize Virtual machine with SLES11SP2 in the Azure ( Add CPU and RAM). - OK
Start Virtual Machine SLES11SP2 - OK
Log in to the SLES11SP2 over ssh - OK.
In the SLES - don`t work DNS !!
In the /etc/resolve.conf i see OLD RECORDS for DNS Server !!
Why This ??
Please, Help me .

This is about SLES11SP2


amt6t01:/home/azureuser # uname -a
Linux amt6t01 3.0.58-0.6.6-default #1 SMP Tue Feb 19 11:07:00 UTC 2013 (1576ecd) x86_64 x86_64 x86_64 GNU/Linux
amt6t01:/home/azureuser # LANG=en_US.UTF8 zypper repos
# | Alias | Name | Enabled | Refresh
--+------------------------------+--------------------+---------+--------
1 | susecloud:SLES11-SP1-Pool | SLES11-SP1-Pool | Yes | Yes
2 | susecloud:SLES11-SP1-Updates | SLES11-SP1-Updates | Yes | Yes
3 | susecloud:SLES11-SP2-Core | SLES11-SP2-Core | Yes | Yes
4 | susecloud:SLES11-SP2-Updates | SLES11-SP2-Updates | Yes | Yes


Serg

jmozdzen
19-Mar-2013, 12:45
Hi Serg,

> In the /etc/resolve.conf i see OLD RECORDS for DNS Server !!

please define "OLD RECORDS"...

Judging from the subject line, you've configured your machine as a dhcp client. Have you checked what the DHCP server is handing out? Did you receive a DHCP reply at all? What's in the logs, what are the time stamps of the corresponding files (especially the .info file from the DCHP client, /etc/resolv.conf) and have you probably deactivated automatic modification of /etc/resolv.conf?

structural approach:
- does your machine actually issue a DHCP request on boot?
- does your machine receive a DHCP reply?
- does the DHCP reply contain the proper values?
- does the DHCP client try to update resolv.conf?
- is resolv.conf updated at all (but probably with wrongs values)?

Regards,
Jens