PDA

View Full Version : smt-mirror of SLE-SDK-SP3-Pool fails: "Checksum mismatch"



greipel
25-Jul-2013, 14:47
Hi,

I am mirroring repositories on our SMT-Server (SLES11SP3). I normally get no problems with this. Only the repository "SLE-SDK-SP3-Pool" (sle-11-x86_64) fails to mirror with the message:
E '/srv/www/htdocs/repotest/repo/$RCE/SLE11-SDK-SP3-Pool/sle-11-x86_64/.repodata/primary.xml.gz': Checksum mismatch'
This kind of error is repeated three times with other xml.gz files. As a consequence I cannot use the (needed) rpms of the SDK of SP3 on our machines (all x86_64) which all use the SMT-Server.

Is there something wrong with the files on the Mirroring Server? Other causes?

chrbusse
27-Jul-2013, 16:05
Hello greipel,

i don't really know if it is the problem, but SMT have to be installed on SLES11SP2(!!), because the SMT-Update (for compatibility with SP3) itself is not yet available.
Please also read the following section of the releasenotes of SP3:
https://www.suse.com/releasenotes/x86_64/SUSE-SLES/11-SP3/#id348580

May be after the release of the SMT-Patch your error would be fixed ;-)

Nice weekend!

smflood
27-Jul-2013, 17:22
chrbusse wrote:

> i don't really know if it is the problem, but SMT have to be installed
> on SLES11SP2(!!), because the SMT-Update (for compatibility with SP3)
> itself is not yet available.
> Please also read the following section of the releasenotes of SP3:
> https://www.suse.com/releasenotes/x86_64/SUSE-SLES/11-SP3/#id348580

SMT11 SP3 was released on 15 July and is available to download from
http://download.novell.com/Download?buildid=l8FuDkiYOg0~

HTH.
--
Simon
SUSE Knowledge Partner

cyberiad
30-Jul-2013, 10:12
Is there something wrong with the files on the Mirroring Server?
Yes, quite likely. Please try again and report back. Thanks!

rmanga01
23-Mar-2014, 07:18
Yes, quite likely. Please try again and report back. Thanks!

I am also getting same error while mirroring "SLES10-SP2-Updates". Could someone please check what's wrong.

I am using SLES11 for VMware SP3 for SMT server and rest repositories are working fine. Only few packages are showing checksome mismatch error i.e. glibc and Mozilla-xulrunner.

jmozdzen
25-Mar-2014, 13:53
Hi rmanga01,


I am also getting same error while mirroring "SLES10-SP2-Updates". Could someone please check what's wrong.

I am using SLES11 for VMware SP3 for SMT server and rest repositories are working fine. Only few packages are showing checksome mismatch error i.e. glibc and Mozilla-xulrunner.

SLES10-SP2 is out of general support since last year, are you on an extended support contract? If so, you might consider opening a service request.

Regards,
Jens