PDA

View Full Version : SLES 12 and glibc



inta
12-Aug-2013, 10:03
Hello everybody.

Were trying to design a HPC cluster for 2014 now and were deciding the Operating System to install in it.
We have a requirement for one of our users about the glibc, it should has a 2.14 glibc or superior.
Since SLES 11 SP3 has 2.11 glibc, Ive been loooking around to try to know if SLES 12 is coming soon and which glibc it will come with but I cant find anything about it.
Has anybody any information about this?

Thank you very much.

Ruth

mikewillis
12-Aug-2013, 10:40
Given that the current version of openSUSE has glibc 2.17 I would be very surprised if SLES 12 ships with glibc less than 2.14. Such specific details are unlikely to be made public prior to release though. According to https://www.suse.com/communities/conversations/your-opportunity-to-shape-suse-linux-enterprise-12/ SLES 12 is due in 2014, but it doesn't say when. The Presentation Download at https://www.brainshareslc.com/2013/connect/sessionDetail.ww?SESSION_ID=2320 indicates middle of 2014. There's usually a non-public beta test programme you can apply for so you could keep an eye on the SUSE website for an announcement about that.

You've actually posted in the SLED forum. The SLES forum is at https://forums.suse.com/forumdisplay.php?8-SUSE-Linux-Enterprise-Server

smflood
12-Aug-2013, 10:48
On 12/08/2013 10:04, inta wrote:

> We�re trying to design a HPC cluster for 2014 now and we�re deciding
> the Operating System to install in it.
> We have a requirement for one of our users about the glibc, it should
> has a 2.14 glibc or superior.
> Since SLES 11 SP3 has 2.11 glibc, I�ve been loooking around to try to
> know if SLES 12 is coming soon and which glibc it will come with but I
> can�t find anything about it.
> Has anybody any information about this?

SLES12 is not due until 2014 so I suspect it's too early to know which
version of glibc it will include but I'll ask SUSE.

Note that just because SLES includes glibc 2.11 doesn't mean it hasn't
had fixes or features backported from later versions - do you know what
the requirement is for 2.14 or later?

HTH.
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
Do you work with SUSE technologies at a university, college or school?
If so, your campus could benefit from joining the Technology Transfer
Partner (TTP) program. See novell.com/ttp for more details.
------------------------------------------------------------------------

inta
14-Aug-2013, 07:26
Thank you both for the quick answer and for the info.
More or less that was the info I had.
So the answer to my problem seems to be that we cannot make it work with certanty right now.
Anyway, I dont know right know the name of the application that needs the glibc 2.14 because the user is on holiday, but when shed come back at the end of the month Ill give you the rest of the info. As long as I remember it was 2.14 or later.

Sorry for posting this in the wrong thread.
And thanks again.

Best:

Ruth