PDA

View Full Version : multimedia codecs on SP3



hmihaii
18-Aug-2013, 16:05
hi,

i tried the package from https://www.suse.com/communities/conversations/additional-multimedia-codec-support-for-sled-11-sp3

i have the SDK SP3 repo, packman repo. checkdependencies gives me all green (of course i installed with zypper the required packages according to the README).

when running build script, i get this error:
make[3]: Leaving directory `/tmp/tmp.4q2vNRTlPr/gst/coloreffects'
make -C colorspace
make[3]: Entering directory `/tmp/tmp.4q2vNRTlPr/gst/colorspace'
ORCC tmp-orc.c
Feature used that is incompatible with --compat in program cogorc_memcpy_2d
make[3]: *** [tmp-orc.c] Error 1
make[3]: Leaving directory `/tmp/tmp.4q2vNRTlPr/gst/colorspace'
make[2]: *** [colorspace] Error 2
make[2]: *** Waiting for unfinished jobs....
make[4]: Leaving directory `/tmp/tmp.4q2vNRTlPr/gst/camerabin'
make[3]: Leaving directory `/tmp/tmp.4q2vNRTlPr/gst/camerabin'
make[2]: Leaving directory `/tmp/tmp.4q2vNRTlPr/gst'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/tmp.4q2vNRTlPr'
make: *** [all] Error 2

Anyone has an idea for how to fix it?

thanks.

hmihaii
18-Aug-2013, 22:31
i isolated the error to the gst-plugins-bad-0.10.22.tar.gz compiling

if i use version 0.10.17 as in previous multimedia pack, i get liboil missing error, although i have liboil:
checking for LIBOIL... no
configure: error: liboil-0.3.8 or later is required

but zypper says:
Information for package liboil:

Repository: SUSE-Linux-Enterprise-Desktop-11-SP2 11.2.2-1.193
Name: liboil
Version: 0.3.15-3.10
Arch: x86_64
Vendor: SUSE LINUX Products GmbH, Nuernberg, Germany
Support Level: Level 3
Installed: Yes
Status: up-to-date
Installed Size: 548.0 KiB

malcolmlewis
18-Aug-2013, 23:24
On Sun 18 Aug 2013 09:44:02 PM CDT, hmihaii wrote:


i isolated the error to the gst-plugins-bad-0.10.22.tar.gz compiling

if i use version 0.10.17 as in previous multimedia pack, i get liboil
missing error, although i have liboil:
checking for LIBOIL... no
configure: error: liboil-0.3.8 or later is required

but zypper says:
Information for package liboil:

Repository: SUSE-Linux-Enterprise-Desktop-11-SP2 11.2.2-1.193
Name: liboil
Version: 0.3.15-3.10
Arch: x86_64
Vendor: SUSE LINUX Products GmbH, Nuernberg, Germany
Support Level: Level 3
Installed: Yes
Status: up-to-date
Installed Size: 548.0 KiB




Hi
When compiling it is looking for the library header and pc files which
are always in the <name>-devel package. In your case install
liboil-devel package.

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.3 (x86_64) Kernel 3.7.10-1.16-desktop
up 19:08, 3 users, load average: 0.65, 0.26, 0.15
CPU AMD E2-1800@1.70GHz | GPU Radeon HD 7340

hmihaii
19-Aug-2013, 00:06
hi Malcolm,

i did what you said, and got passed the liboil error using the gst-plugins-bad-0.10.17(&19) version (17 with SP1 multimedia pack, 19 with SP3 multimedia pack). using version 22 as it comes with the pack, i still get the error from the opening of this thread.

but now i get another error (after moving on with the liboil on 17&19 version), this time from a tool:
make[3]: Entering directory `/tmp/tmp.JySMnJaL2j/ext/cog'
GEN cogorc.c
/usr/bin/orcc: symbol lookup error: /usr/bin/orcc: undefined symbol: orc_bytecode_from_program
make[3]: *** [cogorc.c] Error 127


the version of the tool is Orc Compiler 0.4.17

what is your advice for this one?

thanks.

malcolmlewis
19-Aug-2013, 00:36
On Sun 18 Aug 2013 11:14:01 PM CDT, hmihaii wrote:


hi Malcolm,

i did what you said, and got passed the liboil error using the
gst-plugins-bad-0.10.17(&19) version (17 with SP1 multimedia pack, 19
with SP3 multimedia pack). using version 22 as it comes with the pack, i
still get the error from the opening of this thread.

but now i get another error (after moving on with the liboil on 17&19
version), this time from a tool:
make[3]: Entering directory `/tmp/tmp.JySMnJaL2j/ext/cog'
GEN cogorc.c
/usr/bin/orcc: symbol lookup error: /usr/bin/orcc: undefined symbol:
orc_bytecode_from_program
make[3]: *** [cogorc.c] Error 127

what is your advice for this one?

thanks.




Hi
Looks like a library linking issue, run the following command before starting your building;


export SUSE_ASNEEDED=0


--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.3 (x86_64) Kernel 3.7.10-1.16-desktop
up 20:20, 4 users, load average: 0.46, 0.60, 0.39
CPU AMD E2-1800@1.70GHz | GPU Radeon HD 7340

hmihaii
19-Aug-2013, 01:11
i uninstalled orc....and it worked, even with the 22 version.

i see this package is only for totem/banshee, not for vlc (vlc does not play my test video yet)
is there anything else that needs to be done to activate ATI video acceleration? i see it is obviously missing, fps is very low.

thank you very much!

malcolmlewis
19-Aug-2013, 01:47
On Mon 19 Aug 2013 12:14:03 AM CDT, hmihaii wrote:


i uninstalled orc....and it worked, even with the 22 version.

i see this package is only for totem/banshee, not for vlc (vlc does not
play my test video yet)
is there anything else that needs to be done to activate ATI video
acceleration? i see it is obviously missing, fps is very low.

thank you very much!




Hi
You should have the ati repo enabled on your system? You can install
the proprietary driver from here?

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.3 (x86_64) Kernel 3.7.10-1.16-desktop
up 21:32, 6 users, load average: 0.60, 0.25, 0.22
CPU AMD E2-1800@1.70GHz | GPU Radeon HD 7340

hmihaii
19-Aug-2013, 09:14
hi Malcolm,

yes, i have fglrx installed and am using compiz with gnome. i also did the following, hoping it would help, but no performance difference observed (in totem/banshee, vlc does not play my file): https://forums.opensuse.org/english/get-technical-help-here/multimedia/477671-enabling-hardware-acceleration-vlc-ati.html

vlc seems too old version in pacman repo, is there an option to update its codecs at least?

thanks.

malcolmlewis
19-Aug-2013, 11:59
On Mon 19 Aug 2013 08:24:01 AM CDT, hmihaii wrote:


hi Malcolm,

yes, i have fglrx installed and am using compiz with gnome. i also did
the following, hoping it would help, but no performance difference
observed (in totem/banshee, vlc does not play my file):
https://forums.opensuse.org/english/get-technical-help-here/multimedia/477671-enabling-hardware-acceleration-vlc-ati.html

vlc seems too old version in pacman repo, is there an option to update
its codecs at least?

thanks.




Hi
AFAIK vlc and vlc-codecs are required now for 2.x series maybe try
rebuilding the src rpm for 2.x?

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.3 (x86_64) Kernel 3.7.10-1.16-desktop
up 5:54, 3 users, load average: 0.03, 0.06, 0.06
CPU AMD E2-1800@1.70GHz | GPU Radeon HD 7340

hmihaii
20-Aug-2013, 17:13
vlc building sounds complicated :)

i've tried to build gstreamer-vaapi, with no success. would it be possible to include this in the multimedia codecs pack?

thanks.

malcolmlewis
20-Aug-2013, 17:42
On Tue 20 Aug 2013 04:24:01 PM CDT, hmihaii wrote:


vlc building sounds complicated :)

i've tried to build gstreamer-vaapi, with no success. would it be
possible to include this in the multimedia codecs pack?

thanks.




Hi
I would suggest switching to videolan then;


screen
zypper ar -f http://download.videolan.org/vlc/SuSE/SLE11/ videolan
zypper ref
zypper patch
zypper up
zypper dup --from videolan

That should cause all packages to switch....

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.3 (x86_64) Kernel 3.7.10-1.16-desktop
up 0:26, 3 users, load average: 0.41, 0.42, 0.34
CPU AMD E2-1800@1.70GHz | GPU Radeon HD 7340

hmihaii
21-Aug-2013, 18:54
i get a missing library error when installing vlc from that repo:

zypper in vlc-gnome
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: nothing provides libdvbpsi.so.7()(64bit) needed by vlc-noX-2.0.5-5.10.x86_64
Solution 1: do not install vlc-gnome-2.0.5-5.10.x86_64
Solution 2: break vlc-noX-2.0.5-5.10.x86_64 by ignoring some of its dependencies

how should i provide the missing lib?

thanks.

hmihaii
21-Aug-2013, 21:09
i took the lib from here: http://rpmfind.net/linux/RPM/sourceforge/v/vl/vlc/SuSE/SLE11/x86_64/libdvbpsi7-0.2.2-8.2.x86_64.html

but no luck with hw acceleration, the option is grayed out in VLC settings.

malcolmlewis
21-Aug-2013, 21:35
On Wed 21 Aug 2013 08:24:02 PM CDT, hmihaii wrote:


i took the lib from here:
http://rpmfind.net/linux/RPM/sourceforge/v/vl/vlc/SuSE/SLE11/x86_64/libdvbpsi7-0.2.2-8.2.x86_64.html

but no luck with hw acceleration, the option is grayed out in VLC
settings.




Hi
Strange it should be libdvbpsi9 not 7.....

Are you sure everything switched to the videolan repo?

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.3 (x86_64) Kernel 3.7.10-1.16-desktop
up 1 day 0:52, 3 users, load average: 0.40, 0.47, 0.51
CPU AMD E2-1800@1.70GHz | GPU Radeon HD 7340

hmihaii
22-Aug-2013, 19:30
yes. the initial install was from packman repo.

what is the best way to install vlc on this system, besides compiling the sources? i've seen some report on http://www.suse.in.th/how-tofaq-%28beginner-skill%29/how-to-installing-vlc-on-sled-11-sp1/ that points to use opensuse repositories.

thanks.

Hi
Strange it should be libdvbpsi9 not 7.....

Are you sure everything switched to the videolan repo?

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.3 (x86_64) Kernel 3.7.10-1.16-desktop
up 1 day 0:52, 3 users, load average: 0.40, 0.47, 0.51
CPU AMD E2-1800@1.70GHz | GPU Radeon HD 7340

hmihaii
22-Aug-2013, 19:49
and without taking rpms from the web...any install vlc-gnome gives me a missing library, either libx264.so.129, libcdio.so.10 etc.

malcolmlewis
22-Aug-2013, 20:13
On Thu 22 Aug 2013 07:04:03 PM CDT, hmihaii wrote:


and without taking rpms from the web...any install vlc-gnome gives me a
missing library, either libx264.so.129, libcdio.so.10 etc.




Hi
I would suggest popping over to the videolan forum and asking there as
it's probably a build bug that needs looking at from their perspective.

I don't use VLC, but just totem and any files I need I use handbrake
(from packman) to convert into a suitable format.

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.3 (x86_64) Kernel 3.7.10-1.16-desktop
up 18:45, 3 users, load average: 0.02, 0.07, 0.17
CPU AMD E2-1800@1.70GHz | GPU Radeon HD 7340

hmihaii
23-Aug-2013, 17:46
thank you Malcolm.

i'll do that, since i even tried your earlier suggestion to build vlc (taken from git, fails from ./bootstrap with all required tools installed). ffmpeg building just works with no headaches.

susecmail
23-Aug-2013, 19:30
Hi
I would suggest switching to videolan then;


screen
zypper ar -f http://download.videolan.org/vlc/SuSE/SLE11/ videolan
zypper ref
zypper patch
zypper up
zypper dup --from videolan

That should cause all packages to switch....

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.3 (x86_64) Kernel 3.7.10-1.16-desktop
up 0:26, 3 users, load average: 0.41, 0.42, 0.34
CPU AMD E2-1800@1.70GHz | GPU Radeon HD 7340

Would this invalidate Novell support for SLED? I can't imagine that they would support packages changed by any given developer.

hmihaii
25-Aug-2013, 09:40
i managed to build VLC to work with VAAPI. details are here:https://forum.videolan.org/viewtopic.php?f=13&t=113205, basically i had to use automake version from openSUSE 11.4.

remains gstreamer-vaapi for a complete ATI hw acceleration solution...will update if/when i manage to build it.

thanks.

mikewillis
27-Aug-2013, 11:37
i've tried to build gstreamer-vaapi, with no success. would it be possible to include this in the multimedia codecs pack?


Speaking as the author of the SUSE Conversations article in question(*), I'll look in to adding it when I have time. I think it's not there currently because when I originally developed this method of adding some codec support some years ago I didn't have SLED on any hardware that was supprted, hence I wouldn't have been able to test it. Also my hardware was able to play all my files without hardware acceleration. Also I think gstreamer-vaapi maybe didn't actually exist at the time. I'm not sure :) I think I now have hardware that is supported though. You could try adding it yourself, you'd need to figure out the newest version of gstreamer-vaapi that'll build (for the other gstreamer components I did this by trying each version incrementally until I reached one that failed) and modify the build script to include it in the list of packages to retrieve/build.


(*) As it says at the end of the article "Disclaimer: As with everything else at SUSE Conversations, this content is definitely not supported by SUSE (so don't even think of calling Support if you try something and it blows up)."

KevinHansen
13-Feb-2014, 22:56
remains gstreamer-vaapi for a complete ATI hw acceleration solution...will update if/when i manage to build it.

Did you, or anyone else, manage to build gstreamer-vaapi on SLED 11 SP3? I will look into it myself as well and all inputs are much appreciated.
Thanks.

/Kevin

malcolmlewis
14-Feb-2014, 00:11
On Thu 13 Feb 2014 10:04:01 PM CST, KevinHansen wrote:


hmihaii;15518 Wrote:
>
> remains gstreamer-vaapi for a complete ATI hw acceleration
> solution...will update if/when i manage to build it.

Did you, or anyone else, manage to build gstreamer-vaapi on SLED 11 SP3?
I will look into it myself as well and all inputs are much appreciated.

Thanks.

/Kevin




Hi
The only reason it's not building on OBS is the lack of libva-devel.
You might want to ping the folks there to sort it out?
https://build.opensuse.org/package/show?project=multimedia%3Alibs&package=gstreamer-0_10-plugins-vaapi
Else grab the libva package and rebuild locally, then build the plugin.
Better to probably branch or copy on OBS and build there perhaps....

--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.2 Kernel 3.11.10-7-desktop
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

KevinHansen
23-Feb-2014, 00:11
Hi
The only reason it's not building on OBS is the lack of libva-devel.
You might want to ping the folks there to sort it out?
https://build.opensuse.org/package/show?project=multimedia%3Alibs&package=gstreamer-0_10-plugins-vaapi
Else grab the libva package and rebuild locally, then build the plugin.
Better to probably branch or copy on OBS and build there perhaps....


Okay - I have come a bit further, but haven't been able to build gstreamer-vaapi yet.
What I have done so far:

Found the following SLE11 SP1 repo: http://download.opensuse.org/repositories/home:/suratom/SLE_11_SP1
Installed from there: libva1 libva-devel vaapi-tools - all Version: 1.0.4-5.5.
So I have actually libva-devel installed, but not sure if its the right version.

Found: https://build.opensuse.org/package/show/home:hellgast/xvba-video-amd
Downloaded xvba-video-amd and extracted to /usr/lib64/dri
Not sure thats the right way to do it, but it actually looks like I have got VAAPI working:

vainfo returns:
VAProfileH264High : VAEntrypointVLD
VAProfileVC1Advanced : VAEntrypointVLD

So to gstreamer-vaapi:

Trying to build gstreamer-vaapi-0.5.4 and gets the following error:
Requested 'glib-2.0 >= 2.28' but version of GLib is 2.22.5

I think I should be able to get glib2 2.32 working from https://build.opensuse.org/package/show/windows:mingw/glib2 ?
However I am very new to OBS and not actually sure how to build the GLib2 src.rpm from the OBS project and not sure if it will work or crash my test-system.

Anyway that's status for now - I will check up on OBS and try to get a newer version of Glib2 installed and take it from there.

In the meantime any help is very much appreciated :)

Kind Regards,
Kevin

malcolmlewis
23-Feb-2014, 02:38
Okay - I have come a bit further, but haven't been able to build gstreamer-vaapi yet.
What I have done so far:

Found the following SLE11 SP1 repo: http://download.opensuse.org/repositories/home:/suratom/SLE_11_SP1
Installed from there: libva1 libva-devel vaapi-tools - all Version: 1.0.4-5.5.
So I have actually libva-devel installed, but not sure if its the right version.

Found: https://build.opensuse.org/package/show/home:hellgast/xvba-video-amd
Downloaded xvba-video-amd and extracted to /usr/lib64/dri
Not sure thats the right way to do it, but it actually looks like I have got VAAPI working:

vainfo returns:
VAProfileH264High : VAEntrypointVLD
VAProfileVC1Advanced : VAEntrypointVLD

So to gstreamer-vaapi:

Trying to build gstreamer-vaapi-0.5.4 and gets the following error:
Requested 'glib-2.0 >= 2.28' but version of GLib is 2.22.5

I think I should be able to get glib2 2.32 working from https://build.opensuse.org/package/show/windows:mingw/glib2 ?
However I am very new to OBS and not actually sure how to build the GLib2 src.rpm from the OBS project and not sure if it will work or crash my test-system.

Anyway that's status for now - I will check up on OBS and try to get a newer version of Glib2 installed and take it from there.

In the meantime any help is very much appreciated :)

Kind Regards,
Kevin
Hi
Upping the glib version may not be a good idea, as well as grabbing a mingw version (these are to build windows versions of software). You might need to wait for SLE 12 to arrive which may be the later part of the year.....