PDA

View Full Version : Using SLED for test and development servers



castedo
01-Nov-2013, 15:50
I launch production servers on SLES in the Amazon cloud (AWS EC2) and for testing and development I have been using openSUSE on locally run virtual machines (using VMWare Fusion on two MacBooks I alternative between).

For various reasons I would like to move from openSUSE to SLE, but now that I tried out both SLES and SLED on trial, I'm having trouble seeing why SLED is not an acceptable and significantly cheaper subscription for test and development servers.

I use AutoYast with an autoinst.xml and have scripts calling zypper setting up my virtual machine test and dev servers so I don't care what the SLED DVD installs by default, I don't use those defaults.

Is there a problem using SLED for test and development servers that I am not able to see?

jmozdzen
01-Nov-2013, 16:58
Hi castedo,

> Is there a problem using SLED for test and development servers that I am not able to see

SLES and SLED use a different package layout - as a result, what works in your test VM may be unable to run in your server VM because of missing libraries or tools. As I have not uses SLED yet, I cannot tell if there may be differing *levels* of the same package for SLES and SLED, too.

Regards,
Jens

mikewillis
01-Nov-2013, 17:31
Is there a problem using SLED for test and development servers that I am not able to see?

SLED and SLES have a common base, but they're different products. There are packages that are in SLES that are not in SLED. (A very quick check I've just done by dumping a list of packages in the -Pool repos for SLES 11 SP3 and SLED 11 SP3 shows 857 packages in the SLES repo that are not in the SLED repo.)