PDA

View Full Version : timeout at login attempting cifs.mount



hipsterical
11-Nov-2013, 18:32
doing a console login with my default user (not with root) , bash hangs for 15 long seconds, then returns with the message :

login:
pam_mount password:

mount error(113). no route to host
refer to the mount.cifs(8) manual page (e.g.man mount cifs)

basically when i log in , the system attempts to mount a windows share which is always down , hence the long timeout and waste of time, and the final "no route to host".

now, i am clueless about why bash (or login?)attempts to mount a resource listed with noauto in /etc/fstab : erasing the line from fstab won't cure this error either.
im pretty positive about the fact that i didn't make this setup _on purpose..._ so i don't know how to reverse this situation. and this is very, very annoying

this problem is present just with one user so i assume that the culprit config file must be in my home directory, checked ~/.bashrc and ~/.profile but can't find hints about what's going on and why.

SOLUTION... i just found out that /etc/security/pam_mount.conf is the culprit, only i'd like to discover how that directive made it into the file. i never edited that myself. at least not directly.

<volume options="user=%(DOMAIN_USER)" user="myuser" server="windows_machine" path="smb://windows_machine/myuser" mountpoint="/home/myuser/windows_machine" fstype="cifs"/>

jmozdzen
11-Nov-2013, 19:19
Hi hipsterical,

> SOLUTION... i just found out that /etc/security/pam_mount.conf is the culprit, only i'd like to discover how that directive made it into the file. i never edited that myself. at least not directly.

one thing to look at is the file modification date and check who was on the machine at that time - or to look at the zypper history (/var/log/zypp/history) in case some installer added that line.

Regards,
Jens

mikewillis
12-Nov-2013, 18:13
What version of SLED is this? My SLED 11 SP3 install doesn't have a /etc/security/pam_mount.conf It does have /etc/security/pam_mount.conf.xml though. The change log of the pam_mount rpm says:


* Mon Oct 08 2007 mc@suse.de
- update to version 0.29
* pam_mount switched to an XML configuration


:~> rpm -qf /etc/security/pam_mount.conf.xml
pam_mount-0.47-13.16.1

Worth running 'rpm -qf' on /etc/security/pam_mount.conf to see which, if any, package it belongs to. I suspect the answer will be pam_mount though.