PDA

View Full Version : how to removable media restriction?



fredlorrain
15-Nov-2013, 22:20
I am testing SLES 11 sp3, I need to copy some files from a CD and am finding it ridiculously hard to do. At times I get a message asking for root privileges any time I use removable media, an understandable security measure, however other times I don't get the prompt, and the media refuses to auto-mount. Where do I unset the restriction, or how do I ensure that I get the prompt every time? I need to copy a database file to a virtual MS guest, and have not been able to. The Guest OS automatically mounted the CD, and I could see the files on it, but when I go to copy them the guest OS reports that it can't find the files! I am guessing that the prompt asking for removable media is somehow interrupting the use of the media, but it never comes up to allow permission. Any help would be appreciated. Thanks

fredlorrain
15-Nov-2013, 22:42
Update, After rebooting the server I was offered the prompt again, I'm aware that I could check the box to remember the root password for removable media, but I'd like to know how to reset it after I'm done setting up the server to preserve the security offered by the prohibition. Thanks.

mikewillis
16-Nov-2013, 11:20
You may do better posting in the SLES rather than SLED forum ;)
https://forums.suse.com/forumdisplay.php?8-SUSE-Linux-Enterprise-Server

I can't try recreating this issue as I don't have a SLES install with any sort of graphical environment installed, but I wonder is this will help:
http://www.novell.com/support/kb/doc.php?id=7003564
The page says it applies to SLES and SLED but I've never seen a root password prompt for mounting USB media in SLED. This post by says that in SLES only root can mount USB devices and it's Malcolm saying it so I believe it :)
https://forums.suse.com/showthread.php?3087-SLES11-is-not-able-to-mount-the-external-storage-media&p=14957#post14957

Maybe mounting the drive manually would help.

$ mkdir /media/foo
$ mount /dev/whatever /media/foo
The value of whatever can be found by looking at the output of dmesg after you attach the USB device. E.g. If dmesg says the device has been allocated /dev/sdd then replace whatever with sdd1 to mount the first partition.