PDA

View Full Version : Error while installing r-base-dev



jeppo21
27-Nov-2013, 14:24
Hello there!
I hope to be in the right place!
I should run some R code which calls C subroutines and for this reason I should install r-base-dev. I have SuSE 11 (patchlevel 1). I'm TOTALLY new to SuSE and to linux, but googling around I found out that I just had to run in the terminal the following code:



sudo zypper r-base-dev

But when doing that, I get the following message:



sudo zypper install r-base-dev
Retrieving repository 'SUSE:SLE-11' metadata [\]
File '/repodata/repomd.xml' not found on medium 'http://download.opensuse.org/reposit...standard/'

Abort, retry, ignore? [a/r/i/?] (a): i
Retrieving repository 'SUSE:SLE-11' metadata [error]
Repository 'SUSE:SLE-11' is invalid.
Can't provide /repodata/repomd.xml : User-requested skipping of a file
Please check if the URIs defined for this repository are pointing to a valid repository.
Warning: Disabling repository 'SUSE:SLE-11' because of the above error.
Loading repository data...
Reading installed packages...
'r-base-dev' not found.
Resolving package dependencies...

Nothing to do.

Reading other similar question, I guessed that the name of the repository has been changed, but I didn't find the right one. Could someone be so kind to help me with this? Thank you very much and sorry for bothering you!

mikewillis
27-Nov-2013, 17:22
Welcome to Linux/SUSE!
I think the first thing we need to do is establish which version of SUSE you're using. "SuSE 11 (patchlevel 1)" could be taken to mean either SUSE Linux Desktop Enterprise (https://www.suse.com/) 11 SP1 , or openSUSE (http://www.opensuse.org/) 11.1. Can you post the output of


$ cat /etc/SuSE-release
Either way I my answer would be that you need to re-install with something newer as both SLED 11 SP1 and openSUSE 11.1 are End Of Life. No support, no updates. Since you're just starting out you should start out with a current version.

r-base-dev seems more like a Debian/Ubuntu type name. SUSE development packages have names ending -devel. You can get an R-base-devel for the current version of SLED or openSUSE at http://software.opensuse.org/package/R-base-devel?search_term=R-base-devel

jeppo21
28-Nov-2013, 12:24
Thank you very much for your answer Mike!
I already ran that command and actually my version is SLED 11 SP1! The problem's that I'm just remotly connecting to my professor's computer, so I cannot force him to install a newer version, unfortunately! Thank you very much, anyway, I try to see what I can do! :)

mikewillis
28-Nov-2013, 13:49
Thank you very much for your answer Mike!
I already ran that command and actually my version is SLED 11 SP1! The problem's that I'm just remotly connecting to my professor's computer, so I cannot force him to install a newer version, unfortunately! Thank you very much, anyway, I try to see what I can do! :)

If you go to
http://software.opensuse.org/package/R-base-devel?search_term=R-base-devel
and click 'Show more packages for unsupported distributions' at the bottom, you'll find packages for SLE SP1. The repo is at
http://download.opensuse.org/repositories/devel:/languages:/R:/base/SLE_11_SP1/
You could add that url as a repo on the machine, do it through YaST or

$ cd /etc/zypp/repos.d
$ wget http://download.opensuse.org/repositories/devel:/languages:/R:/base/SLE_11_SP1/devel:languages:R:base.repo
$ zypper refresh

Then install with zypper

$ zypper in R-base-devel

jeppo21
28-Nov-2013, 14:04
Yeah! It worked! Thank you so much! You have been really kind! I'll buy you a virtual beer! :)