PDA

View Full Version : no "accent grave / aigue" possible with German keyboard



gefro
03-Feb-2014, 10:17
SLED installation:

For direct application on a PC or a VNC connection, it is not possible for me enter an "accent aigue" or a "grave accent" .
When an RDP connection already.

Installation and Keyboard Layout: German

I've also tried from a SLED11 application by the xmodmap-pke modmap to export and then xmodmap modmap be recovered through the SLED.
Then I got no matching keyboard layout more.

Is there a workaround for the problem?

smflood
04-Feb-2014, 00:37
gefro Wrote in message:

> SLED installation:
>
> For direct application on a PC or a VNC connection, it is not possible
> for me enter an "accent aigue" ? or a "grave accent" ?.
> When an RDP connection already.
>
> Installation and Keyboard Layout: German
>
> I've also tried from a SLED11 application by the xmodmap-pke modmap to
> export and then xmodmap modmap be recovered through the SLED.
> Then I got no matching keyboard layout more.
>
> Is there a workaround for the problem?

Which version of SLED are you using? Please post the output from
"cat /etc/*release" command.

HTH.
--
Simon
SUSE Knowledge Partner

----Android NewsGroup Reader----
http://www.piaohong.tk/newsgroup

gefro
04-Feb-2014, 10:38
Hi Simon,
cat /etc/novell-releases:

SUSE Linux Enterprise Desktop 11 (x86_64)
VERSION = 11
PATCHLEVEL = 3

cat /etc/issue:

Welcome to SUSE Linux Enterprise Desktop 11 SP3 (x86_64) - Kernel \r (\l).

uname -a
Linux 3.0.101-0.8-default #1 SMP Fri Nov 1 12:51:09 UTC 2013 (2417eb9) x86_64 x86_64 x86_64 GNU/Linux

mikewillis
04-Feb-2014, 13:53
I'm not certain I understand the problem, but after setting the input language to German and finding a picture of a German keyboard I have been able to type the characters

I've put an image at
http://paste.opensuse.org/78440470
which shows which keys I used to type which characters. (Although I actually used the keys in the equivalent positions on a UK keyboard.) E.g. to type I pressed the key circled in blue followed by the e key.

Does this help?

gefro
05-Feb-2014, 16:03
HI smflood

sorry it does not work

I have a German SLED installation.

When I log directly on SLED or an X-session connection using:
under keyboard settings I have "German Eliminate dead keys"
the standard input for brings me `a
When I use "Germany Macintosh" as layout, we issued correctly, but the rest of the layout is no longer correct.
This is my problem
I connect to the computer with RDP, do the keys work correctly

mikewillis
05-Feb-2014, 18:29
under keyboard settings I have "German Eliminate dead keys"


Under keyboard settings I have 'Germany'.

See http://paste.opensuse.org/24722267

Line 1 is typed with 'Germany'. Line 3 is typed with 'Germany Eliminate dead keys'.

If I use 'Germany' I can type but the same keystrokes with 'Germany Eliminate dead keys' produce 'a.

Can you try using 'Germany' rather than 'Germany Eliminate dead keys'.