PDA

View Full Version : Unable to update to SP3, postgresql dependencies



sysengPS
24-Mar-2014, 17:04
I've inherited this postgresql db server and have to update it to SP3, but am blocked by postgresql dependencies, notably
postgresql92-9.2.4-18.1.x86_64 requires libpq5 >= 9.2.4
postgresql92-devel-9.2.4-20.1.x86_64 requires libecpg6 = 9.2.4,
postgresql92-server-9.2.4-18.1.x86_64 requires postgresql-init >= 9.2
And none of those can be provided. I have SP3 VMware-Pool and SP3-VMware-Updates repositories enabled. Do I need the SDK enabled as well?

Also, I notice that Postgresql is on version 9.3.4, on their website. I'm having problems finding the current version for SLES. Can someone help w/ this?

Thanks much.

sysengPS
24-Mar-2014, 20:09
Ok, couldn't find the button to edit the post. Great
I've added the opensuse repositories for 9.2 and 9.3 containing Postgresql, and even installed libpq5-9.2.7-24.3, but starting the distribution upgrade fails at the same spot:
Prior to upgrading libpq5


sudo zypper dup --from nu_novell_com:SLES11-SP3-VMware-Pool --from nu_novell_com:SLES11-SP3-VMware-Updates
Loading repository data...
Reading installed packages...
Computing distribution upgrade...
2 Problems:
Problem: postgresql92-9.2.4-18.1.x86_64 requires libpq5 >= 9.2.4, but this requirement cannot be provided
Problem: postgresql92-server-9.2.4-18.1.x86_64 requires postgresql-init >= 9.2, but this requirement cannot be provided

Problem: postgresql92-9.2.4-18.1.x86_64 requires libpq5 >= 9.2.4, but this requirement cannot be provided
deleted providers: libpq5-9.2.4-20.1.x86_64
uninstallable providers: libpq5-9.2.7-24.3.i586[Postgres-9.24]
libpq5-9.3.3-14.1.i586[Postgres-9.24]
libpq5-9.2.7-24.3.x86_64[Postgres-9.24]
libpq5-9.3.3-14.1.x86_64[Postgres-9.24]
libpq5-9.2.7-24.3.i586[postgresql-sp3]
libpq5-9.3.3-14.1.i586[postgresql-sp3]
libpq5-9.2.7-24.3.x86_64[postgresql-sp3]
libpq5-9.3.3-14.1.x86_64[postgresql-sp3]
libpq5-9.2.7-24.3.i586[postgresql-sp3.2]
libpq5-9.3.3-14.1.i586[postgresql-sp3.2]
libpq5-9.2.7-24.3.x86_64[postgresql-sp3.2]
libpq5-9.3.3-14.1.x86_64[postgresql-sp3.2]
Solution 1: Following actions will be done:
deinstallation of postgresql92-9.2.4-18.1.x86_64
install libossp-uuid16-1.6.2-46.2.x86_64 from excluded repository
Solution 2: install libpq5-9.3.3-14.1.x86_64 from excluded repository
Solution 3: install libpq5-9.3.3-14.1.x86_64 from excluded repository
Solution 4: break postgresql92-9.2.4-18.1.x86_64 by ignoring some of its dependencies

Upgrading:

sudo zypper in libpq5-9.2.7-24.3.x86_64
Loading repository data...
Reading installed packages...
There is an update candidate 'libpq5-9.3.3-14.1.x86_64' for 'libpq5-9.2.4-20.1.x86_64', but it does not match specified version, architecture, or repository.
Resolving package dependencies...

The following package is going to be upgraded:
libpq5

1 package to upgrade.
Overall download size: 156.0 KiB. After the operation, additional 1.0 KiB will be used.
Continue? [y/n/? shows all options] (y):
Retrieving package libpq5-9.2.7-24.3.x86_64 (1/1), 156.0 KiB (447.0 KiB unpacked)
Retrieving: libpq5-9.2.7-24.3.x86_64.rpm [done (0 B/s)]
Installing: libpq5-9.2.7-24.3 [done]

After upgrading libpq5

sudo zypper dup --from nu_novell_com:SLES11-SP3-VMware-Pool --from nu_novell_com:SLES11-SP3-VMware-Updates
Loading repository data...
Reading installed packages...
Computing distribution upgrade...
2 Problems:
Problem: postgresql92-9.2.4-18.1.x86_64 requires libpq5 >= 9.2.4, but this requirement cannot be provided
Problem: postgresql92-server-9.2.4-18.1.x86_64 requires postgresql-init >= 9.2, but this requirement cannot be provided

Problem: postgresql92-9.2.4-18.1.x86_64 requires libpq5 >= 9.2.4, but this requirement cannot be provided
uninstallable providers: libpq5-9.3.3-14.1.i586[Postgres-9.24]
libpq5-9.3.3-14.1.x86_64[Postgres-9.24]
libpq5-9.3.3-14.1.i586[postgresql-sp3]
libpq5-9.3.3-14.1.x86_64[postgresql-sp3]
libpq5-9.3.3-14.1.i586[postgresql-sp3.2]
libpq5-9.3.3-14.1.x86_64[postgresql-sp3.2]
Solution 1: Following actions will be done:
deinstallation of postgresql92-9.2.4-18.1.x86_64
install libossp-uuid16-1.6.2-46.2.x86_64 from excluded repository
Solution 2: install libpq5-9.3.3-14.1.x86_64 from excluded repository
Solution 3: install libpq5-9.3.3-14.1.x86_64 from excluded repository
Solution 4: break postgresql92-9.2.4-18.1.x86_64 by ignoring some of its dependencies

Any help would be appreciated.

sysengPS
24-Mar-2014, 20:11
Final update. I figured it out. I had to specify the repository during the update process. Wow.

mikewillis
25-Mar-2014, 10:29
Do I need the SDK enabled as well?

The answer to that is almost certainly the same as "Is the SDK SP2 repo currently enabled?" (Unless someone previously enabled it, installed packages from it, then disabled it.)



Also, I notice that Postgresql is on version 9.3.4, on their website. I'm having problems finding the current version for SLES.

Do you actually need the current version? Note that just because SLES includes an older version doesn't mean it's not kept up to date security or bug fix wise.


Ok, couldn't find the button to edit the post. Great

You can't find it because it's not there. Posts can only be edited for a short time after they're made. It can get very confusing if people start editing posts long after they're made.



Final update. I figured it out. I had to specify the repository during the update process. Wow.
Those postgresql92 packages are not part of SLES or the SDK. If you have third party packages installed and/or third party repos enabled, that can make upgrading from one SP level to the next more difficult than it would otherwise be.

Glad to hear you seem to have got it all sorted though.