PDA

View Full Version : SMT error SLES10SP3



dschaldenovell
26-Jan-2012, 19:36
I have a customer that just installed a new SMT server, and they are
trying to have their first server update from that source. The SMT -
server name is - lifeboat2 and the server that they are trying to update
is called DC1-eDir

When they attempted to update the server they are getting the following
error:

Failed to parse XML metadata: Can't add repository at
http://lifeboat2.pwcs.edu/repo/$RCE/OES2-SP3-Online/sles-10-x86_64:
Unknown Error: Downloading metadata
failed (is YUM source?) or user did not accept remote source. Aborting
refresh.ERROR: Could not add 'http://Lifeboat2.pwcs.edu/': Failed to
parse XML metadata: Can't add
repository at
http://lifeboat2.pwcs.edu/repo/$RCE/OES2-SP3-Online/sles-10-x86_64:
Unknown Error: Downloading metadata failed (is YUM source?) or user
did not accept remote source. Aborting
refresh.Cannot execute /usr/bin/rug sa -t nu http://Lifeboat2.pwcs.edu/
SMT-http_Lifeboat2_pwcs_edu: Bad file descriptor
DC1-eDIR:~/downloads #

They also tried the following

We also try to edit the robots.txt file and added the " Allow:
/repo/keys " before the Disallow: / line but received the same results.

I forgot to let you know that but in both cases we get the same error.


Would anyone have any ideas what I can start looking into to fix this
problem?

Thank you,


--
dschaldenovell
------------------------------------------------------------------------
dschaldenovell's Profile: http://forums.novell.com/member.php?userid=93234
View this thread: http://forums.novell.com/showthread.php?t=451395

Automatic Reply
31-Jan-2012, 21:27
dschaldenovell,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your problem been resolved? If not, you might try one of the following options:

- Visit http://support.novell.com and search the knowledgebase and/or check all
the other self support options and support programs available.
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.novell.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.novell.com/faq.php

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your Novell Product Support Forums Team
http://forums.novell.com/

dschaldenovell
09-Feb-2012, 13:10
I have a customer that just installed a new SMT server, and they are
trying to have their first server update from that source. The SMT -
server name is - lifeboat2 and the server that they are trying to update
is called DC1-eDir

When they attempted to update the server they are getting the following
error:

Failed to parse XML metadata: Can't add repository at
http://lifeboat2.pwcs.edu/repo/$RCE/OES2-SP3-Online/sles-10-x86_64:
Unknown Error: Downloading metadata
failed (is YUM source?) or user did not accept remote source. Aborting
refresh.ERROR: Could not add 'http://Lifeboat2.pwcs.edu/': Failed to
parse XML metadata: Can't add
repository at
http://lifeboat2.pwcs.edu/repo/$RCE/OES2-SP3-Online/sles-10-x86_64:
Unknown Error: Downloading metadata failed (is YUM source?) or user
did not accept remote source. Aborting
refresh.Cannot execute /usr/bin/rug sa -t nu http://Lifeboat2.pwcs.edu/
SMT-http_Lifeboat2_pwcs_edu: Bad file descriptor
DC1-eDIR:~/downloads #

They also tried the following

We also try to edit the robots.txt file and added the " Allow:
/repo/keys " before the Disallow: / line but received the same results.

I forgot to let you know that but in both cases we get the same error.


Would anyone have any ideas what I can start looking into to fix this
problem?

Thank you,


--
dschaldenovell
------------------------------------------------------------------------
dschaldenovell's Profile: http://forums.novell.com/member.php?userid=93234
View this thread: http://forums.novell.com/showthread.php?t=451395


Another SMT server issue for my customer,

"In reference to the SMT project. I have about a 15 zen7 servers that get the same error when trying to run the SMT script or even do a rug sl. See below for error. I went thru about 190 servers and about 15 zen7 out of 90(-ish) zen7 get that same error. Any advice??

BRMS-Zen7:~/downloads # rug sl

** (/usr/lib64/rug/rug.exe:30898): WARNING **: process_set_current: error creating process handle

** (/usr/lib64/rug/rug.exe:30898): WARNING **: thread_attach: error creating thread handle

** (/usr/lib64/rug/rug.exe:30898): WARNING **: CreateThread: error creating thread handle

Unhandled Exception: System.ExecutionEngineException: Couldn't create thread

Any thoughts would be most appreciated.