PDA

View Full Version : how to install bumblebee in SLED?



albumns
22-May-2014, 07:04
Hello:

I've bought a validate license for SLED and I found that there is some problem to install bumblee in my laptop. I google it and only found some guideline for opensuse instead of SLED. In http://software.opensuse.org event doesn't have bumblebee repository for SLED.

If possbile, could someone tell me how exactly we can make NVIDIA optirun work?

thx a lot

mikewillis
22-May-2014, 16:56
http://software.opensuse.org[/url] event doesn't have bumblebee repository for SLED.


Which version of SLED are you using?

There's a repo for SUSE SLE-11 SP 3 listed at http://software.opensuse.org/package/bumblebee which I assume will work with SLED 11 SP3. I have no relevant hardware to try though.

albumns
22-May-2014, 17:32
that's for pointing out.

I am using SLED 11 SP3.

It is not enough, it will requried different packages including:

dkms dkms-nvidia dkms-bbswitch bumblebee primus x11-video-nvidia

it is quite tricky to make things work. Initially I installed opensuse 13.1 in a laptop following instructions:

http://smithfarm-thebrain.blogspot.ch/2013/10/opensuse-131-nvidia-optimus-bumblebee.html

Then I upgrade the system through zypper, and my nvidia doesn't work anymore. I try to repeat the steps in above thread, but the author removed the Overman79 repository. I use the suse official bumbeeble repository, it doesn't contains a full list of above list package, and my nvidia doesn't work at all.


It always failed with messages when I try to run optirun
Xlib: extension "GLX" missing on display ":8".
OpenGL GLX extension not supported by display ':0'
Info) [0] Quadro K1100M 2 SM_3.0 @ 0.71 GHz, 2.0GB RAM, KTO, OIO, ZCP
Warning) Detected X11 'Composite' extension: if incorrect display occurs
Warning) try disabling this optional X server feature.
Xlib: extension "GLX" missing on display ":8".
ERROR) The X server does not support the OpenGL GLX extension.


So I am just wondering is there any tutorial for SLED 11SP3 to install bumblebee correctly? I am trying to install it in Dell M3800.

thx a lot

ofvergara
08-Sep-2014, 19:34
hello, i had the same issue. i recently upgraded to sled11sp3 from sled11sp2 (on which i had bumblebee working correctly with the old set up).
due to a repartitioning mistake i made while testing the laptop, i had to format/reinstall everything from scratch and i forgot how i did it the last time and at the same time i could not find the files i used to install it back then.

my specifications:
sled11 sp3 32bit on dell xps L502x laptop
intel hd 3000 + nvidia 525gt
dual (triple?) booting: win7 64bit + win xp 32bit + sled11sp3 32bit-i586


Steps that worked for me:
1) just in case to avoid problems, i installed: kernel-sources + kernel-pae-devel + linux-kernel-headers + gcc + make + patch (gnu patch)

2) subscribe to this repository (i prefer older+proven+working nvidia packages, not bleeding edge):
http://download.opensuse.org/repositories/home:/Bumblebee-Project:/nVidia:/295.75/SLE_11_SP2/

3) download/install the following files listed there:
dkms + dkms-nvidia + nvidia-compute + nvidia-compute-devel + x11-video-nvidia + x11-video-nvidia-devel
(if dkms complains about a missing dependency for kernel, ignore it and go ahead, i'll explain why later)

4) from this repository below, install only "Virtual GL"
http://download.opensuse.org/repositories/home:/Bumblebee-Project:/Bumblebee/SLE_11_SP3/

5) from this website http://rpm.pbone.net/index.php3/stat/2/simple/2 , select in the search options below suse11 and opensuse 11, then search and download the following files available for opensuse 11.4 and put them in a folder:
libbsd0-0.4.2-6.1.i586.rpm
libturbojpeg-1.2.1-1.4.i586.rpm

6) still in the rpm pbone website, go here: http://rpm.pbone.net/index.php3/stat/4/idpl/23354437/dir/opensuse/com/dkms-bbswitch-0.7-3.2.noarch.rpm.html
download bbswitch rpm and put with the others in the folder.

7) now go here:
http://software.opensuse.org/package/bumblebee --> do not 1-click install --> download bumblebee-3.0.1-46.1.i586.rpm and put in folder with the others
(i took it from opensuse 12.2, it was an older working version, newer versions of bumblebee point to systemd service and not the good old sysVinit from SLED11. That's why newer versions of bumblebee rpms don't and won't create the bumblebeed daemon. it took me 3 days to figure that out since most tutorials are for new opensuse versions already using systemd)

8) after all these files are there together, simple open the terminal, go root with "su" and the issue the good old command: rpm -Uvh *.rpm
when it finishes, still as root, type command: SuSEconfig

9) reboot and pray.

10) double check your yast/system-boot log. there should be something listed about bbswitch 0.7 and bumblebeed daemon running. go inspect the /etc/bumblebee/bumblebee.conf and inspect the file (i did not need to do anything, all worked out of the box)

11) verify bumblebee is ready and running:
in a terminal, type this: cat /proc/acpi/bbswitch
the system should tell you something like this: 0000:01:00.0 OFF
OFF means bumblebee is working.

****

In case it is not working because the daemon for some reason was not activated, there's a couple of steps to execute (A & B):
A) do this as root in a terminal:
# bumblebeed --daemon
# /sbin/chkconfig bumblebeed on
# tee /proc/acpi/bbswitch <<<OFF
# cat /proc/acpi/bbswitch

B) then go to yast > etc/sysconfig editor > system > kernel > MODULES_LOADED_ON_BOOT
in this section (don't delete anything already there!!) just type to the side of the last command:
bbswitch load_state=0
and press OK.

C) reboot and pray again. it should be working by now.

D) in case you have a laptop reset and you temporarily lose energy saving features (still with bumblebee/bbswitch correctly installed with all the files), just execute instruction "A"..

hope this helps.
Cheers.