PDA

View Full Version : Hung Server Console



GofBorg
28-Jan-2012, 00:13
I am running KVM on my SLES 11 server and at present I have a hung console
on the root system. I have no way of shutting down the KVM virtual instance
under it at this point. I have tried doing a CTL+ALT+F1 to get to another
console to shut down to no avail. The console session is completely hung.
The virtual server is still running just dandy but I have lost control over
the machine. I cannot VNC or ssh into the machine. Any ideas?

magic31
28-Jan-2012, 13:16
GofBorg;2171318 Wrote:
> I am running KVM on my SLES 11 server and at present I have a hung
> console
> on the root system. I have no way of shutting down the KVM virtual
> instance
> under it at this point. I have tried doing a CTL+ALT+F1 to get to
> another
> console to shut down to no avail. The console session is completely
> hung.
> The virtual server is still running just dandy but I have lost control
> over
> the machine. I cannot VNC or ssh into the machine. Any ideas?

Pull the plug? :O)

Seriously... it seems you have a rock and a hard place scenario there.
With no console options on the KVM host and no remote options on the
guest... not much you can do as far as I can see.

Any other services running that you might be able to get to on host or
guest (WebYaST, NoRM,....)?

-Willem


--
Novell Knowledge Partner (voluntary sysop)

It ain't anything like Harry Potter.. but you gotta love the magic IT
can bring to this world
------------------------------------------------------------------------
magic31's Profile: http://forums.novell.com/member.php?userid=2303
View this thread: http://forums.novell.com/showthread.php?t=451469

Bob-O-Rama
29-Jan-2012, 05:56
You can't use Ctrl-Alt-F1, that is used by KVM. Ctrl-Alt-F2 to get the
KVM console then use sendkey to send whatever key combination you
choose. You can also just abort the VM using the CLI. Ctrl-Alt-F1
gets you back to the VM's console.

-- Bob


--
Bob Mahar -- Novell Knowledge Partner
Do you do what you do at a .EDU? http://novell.com/ttp
"Programming is like teaching a jellyfish to build a house."
More Bob: 'Twitter' (http://twitter.com/BobMahar) 'Blog'
(http://blog.trafficshaper.com) 'Vimeo' (http://vimeo.com/boborama) <--
Click And Be Amazed!
------------------------------------------------------------------------
Bob-O-Rama's Profile: http://forums.novell.com/member.php?userid=5269
View this thread: http://forums.novell.com/showthread.php?t=451469

GofBorg
30-Jan-2012, 21:30
I was able to find a working SSH connection to the guest OS and shut it
down. Beyond that though it was the reset button. Doh!

GofBorg
30-Jan-2012, 21:35
> You can't use Ctrl-Alt-F1, that is used by KVM. Ctrl-Alt-F2 to get the
> KVM console then use sendkey to send whatever key combination you
> choose. You can also just abort the VM using the CLI. Ctrl-Alt-F1
> gets you back to the VM's console.
>
> -- Bob

Unfortunately Ctrl-Alt-FX was hosed. The SLES 11 console just seemed to go
bye bye. I was able to at least shut down the guest by finding an open SSH
connection. Couldn't find anything other than the reset button to unlock the
server console. It all began with the keyboard. At first it would not type,
then after fooling with it for a bit it started typing okay. Then I clicked
on YaST and then Doftware Managament and it was all over. The mouse cursor
changed to the pointer that looks like the window resize tool and just
stayed that way.

Bob-O-Rama
31-Jan-2012, 05:46
GofBorg;2171741 Wrote:
> Then I clicked
> on YaST and then -*Doftware Managament*- and it was all over.

:-) "Doftware," I like it.

Is this SLES 11 SP1 or just SLES 11? We had issues with the GUI going
wonky on SLES 11 FCS.

-- Bob



-- Bob


--
Bob Mahar -- Novell Knowledge Partner
Do you do what you do at a .EDU? http://novell.com/ttp
"Programming is like teaching a jellyfish to build a house."
More Bob: 'Twitter' (http://twitter.com/BobMahar) 'Blog'
(http://blog.trafficshaper.com) 'Vimeo' (http://vimeo.com/boborama) <--
Click And Be Amazed!
------------------------------------------------------------------------
Bob-O-Rama's Profile: http://forums.novell.com/member.php?userid=5269
View this thread: http://forums.novell.com/showthread.php?t=451469

GofBorg
31-Jan-2012, 20:34
It's just SLES11. Don't think I have access to SP1 just now since
I don't have a support contract. Maybe in the future. We are looking at
SLES for some other things. This current system is a pilot project...
so far, more problems out of it than OpenSuSE.

GofBorg
04-Feb-2012, 00:29
Okay, so today I checked my server and it is at SP1.
Here are my latest observations.

If I launch KVM at all, I lose control of the server....even from a shell
console.

So if I run 'virsh start instance' then keyboard goes bye bye. Virtual
machine is running but any input into the host is gone. The virtual host
guest is also SLES 11 SP1.

Any ideas?